Announcement

Collapse
No announcement yet.

Sporadic errors sending UPB commands

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sporadic errors sending UPB commands

    Hi Spud -
    I've got your UPB plugin running on a Homeseer SEL and connected to a serial Simply Automated PIM through a USB-Serial interface. In general it has worked well for the last couple weeks testing. But twice now it has lost communication and I can't figure out what brings it back alive. Last time it happened I uninstalled the plug-in, swapped PIMs, restarted, etc. and something brought it back to life but I don't know which one.

    I'm now getting this error again:

    Nov-24 10:05:42 UPBSpud ERROR PIM_SEND:: ERROR: Unable to send message ID 7 [0714010BFF30AA] to PIM -- timed out 5 times -- discarding message

    Edit: Here is some additional info in case it helps:

    Comm port: /dev/ttyUSB0 (it hasn't changed since it was setup and worked)
    UPBSpud version: 3.0.0.40

    I also have UPBSpud working on a windows 7 pc with the same PIM at another house and it's been rock solid.

    This one is in a remote location 200 miles away so I'd like to proceed carefully as to not lock up the machine.

    Any ideas?

    Thanks.

    Pat
    Last edited by beerguy; November 25th, 2017, 01:14 PM.

  • #2
    Update:
    I deleted the plugin from the HS PlugIns interface, restarted the SEL, reinstalled the plugin, and everything is working again.

    Any ideas or thoughts on what I can do on this end so this doesn't happen?

    Thanks,

    Pat

    Comment


    • #3
      it's hard to say...
      Did you try to just restart the SEL instead of deleting and reinstalling the plugin?

      next time, set the log to debug, and try restarting the plugin or the SEL.

      Comment

      Working...
      X