Announcement

Collapse
No announcement yet.

UPB Plug-in - Beta Testing

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #76
    Originally posted by spud View Post
    If you can replicate this crash, send me your ini file and .upe, If I can replicate the crash, I can fix it.
    The first thing I did was simply disable and re-enable the plugin. This caused it to crash when I clicked on the UPB config link. My procedure: disable plugin, wait 1 minute, enable plugin, click on UPBSpud on manage plugins page. This results in the plugin program crashing.

    Is this reproducible on your system?
    _______________________________________________

    HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
    Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
    Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

    Comment


    • #77
      Originally posted by jlrichar View Post
      The first thing I did was simply disable and re-enable the plugin. This caused it to crash when I clicked on the UPB config link. My procedure: disable plugin, wait 1 minute, enable plugin, click on UPBSpud on manage plugins page. This results in the plugin program crashing.

      Is this reproducible on your system?
      No I can't reproduce this crash on my system.

      Does it crash everytime you try?
      Please send me your ini and upe file

      Comment


      • #78
        installation step - Go to the "PLUG-INS > Manage" page and click the "Update Listing" button, then click "Additional interfaces > Test Plugin" and check the UPB line.
        I click Additional interfaces but I don't see any buttons that say Test Plugin" and check the UPB line. Nor does that come up by hitting additional interfaces.
        HS3 pro S5. Just got system and the UPB install seems like a nightmare compared to the old system. Any suggestions?

        Comment


        • #79
          New Pulseworx IP-PIM

          Hey Spud, can you add support for the new IP-PIM?

          Comment


          • #80
            Originally posted by westover_man View Post
            Hey Spud, can you add support for the new IP-PIM?
            Do you have some specs for this IP-PIM?
            How does it work with UPStart? Do you just enter the ip of the IP-PIM?
            Was it supported by the UPB HS2 plugin?

            Comment


            • #81
              I do not have one but attended a webinar relating to the device.

              The new Upstart (version 7.0) talks to it.

              It is a custom job using a Digi embedded webserver OS and just a serial connection to the UPB pieces of it.

              How does it work with UPStart? Yes

              Do you just enter the ip of the IP-PIM? Upstart 7.0 uses a discovery tool and finds it.

              Was it supported by the UPB HS2 plugin? no

              It provides remote network management of the UPB network.

              Its MFG list price is up there. That said Amazon has them for $462.50

              http://www.amazon.com/PCS-PulseWorx-.../dp/B00K1H6IE4

              What is neato about the device is that you can put it anywhere in your home and just connect to it your home network via a wired or wireless connection. That said you can remote manage your UPB network this way via a WAN link. This is the first of its kind.

              You could run a HS3 plugin talking to the device at a remote site if you wanted to.
              - Pete

              Auto mator
              Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
              Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

              X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

              Comment


              • #82
                Web Mountain had a similar device a few years ago but did not find it very useful. Also Pulseworxs had an IP Controller a few years ago but i dont think it took off. I have one around somewhere. It only worked with Pulseworxs devices at the time.


                Sent from my iPad using Tapatalk

                Comment


                • #83
                  Here I have 1 UPB PIM plugged into the Leviton OPII panel. Another two plugged into HS boxes and a floater.

                  3 of the PIMs are adjacent to the fuse panel.

                  The floater is plugged in wherever and today its plugged into a network serial server where I can access it with Upstart. I use it mostly to play and check signal strengths of the UPB device from around the house on the two phases.

                  You can also today just build a little DIY box with wireless or wired connectivity and it would be smaller than the PIM and could be sort of an automation controller just for UPB.

                  You could probably also run the HS3 plugin on the box and remotely connect it to the mothership.

                  Doing the two of these things you could manage your UPB PIM remotely via a wireless/wired network connection and have the HS3 UPB plugin running at the same time.
                  - Pete

                  Auto mator
                  Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
                  Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

                  X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                  Comment


                  • #84
                    Poll Devices Every x seconds

                    Hello, I have been working with this plugin a little bit and have noticed that if I turn on / off a device from my android phone, it works great and tracks the status of the light, but if the light is controlled from the switch, it doesn't reflect the status in the app. If I re-poll all devices on the network, it then syncs status with the app. I was wondering if there is a way to automatically poll devices statuses on a regular basis, so that the app is synced up with what is actually going on with the light? Thank you.

                    Comment


                    • #85
                      Originally posted by bjhiltbrand View Post
                      Hello, I have been working with this plugin a little bit and have noticed that if I turn on / off a device from my android phone, it works great and tracks the status of the light, but if the light is controlled from the switch, it doesn't reflect the status in the app. If I re-poll all devices on the network, it then syncs status with the app. I was wondering if there is a way to automatically poll devices statuses on a regular basis, so that the app is synced up with what is actually going on with the light? Thank you.
                      I believe there is a Poll scripting function that you could call from a recurring event, but I would not advise it.
                      UPB is supposed to send status report to your PIM, when the light is controlled from the switch. Can you tell me more about the device you are testing and their configuration in UPStart?

                      Comment


                      • #86
                        Originally posted by spud View Post
                        I believe there is a Poll scripting function that you could call from a recurring event, but I would not advise it.
                        UPB is supposed to send status report to your PIM, when the light is controlled from the switch. Can you tell me more about the device you are testing and their configuration in UPStart?
                        In UPstart this is an optional checkbox. You should be able to go into each device and make sure the "send status update upon local activation" (or some such) is checked.
                        _______________________________________________

                        HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
                        Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
                        Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

                        Comment


                        • #87
                          Originally posted by jlrichar View Post
                          In UPstart this is an optional checkbox. You should be able to go into each device and make sure the "send status update upon local activation" (or some such) is checked.
                          That did it. I saw that checkbox, but was unsure of what it did when I originally set up my switches. Thank you for pointing it out. This plugin is incredibly easy to set up and interact with. The next steps are setting up voice control, IFTTT control from my cell phone's GPS location, and Integration with the garage door opener. Much appreciated.

                          Comment


                          • #88
                            Hi Spud,

                            Not necessarily related to UPB Plug-in Version 3.0.0.23. I noticed when I updated from 3.0.0.22 today that the COM Port doesn't seem to reconnect properly when the new version is started up during the upgrade process. I then had to restart to get the COM Port to allow the PIM to be addressed by the plug-in. Any ideas why it wouldn't connect cleanly? Serial Port Init or Reset not occurring or needing a delay in the process? Example of log just after upgrade of plug-in completed below:

                            Thanks,

                            -Travis

                            ----------------------------------------------------------------------------
                            Aug-04 8:07:06 AM UPBSpud ERROR PIM_SEND:: ERROR: Unable to send message ID 2 [07140103FF30B2] to PIM -- timed out 5 times -- discarding message
                            Aug-04 8:07:00 AM UPBSpud INFO Checking HS Devices Completed
                            Aug-04 8:06:58 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140103FF30B2 ]
                            Aug-04 8:06:58 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 2 to PIM, retry count=5
                            Aug-04 8:06:58 AM UPBSpud DEBUG PIM_SEND:: Timeout waiting for PIM response -- now trying to send command again
                            Aug-04 8:06:51 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140103FF30B2 ]
                            Aug-04 8:06:51 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 2 to PIM, retry count=4
                            Aug-04 8:06:51 AM UPBSpud DEBUG PIM_SEND:: Timeout waiting for PIM response -- now trying to send command again
                            Aug-04 8:06:43 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140103FF30B2 ]
                            Aug-04 8:06:43 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 2 to PIM, retry count=3
                            Aug-04 8:06:43 AM UPBSpud DEBUG PIM_SEND:: Timeout waiting for PIM response -- now trying to send command again
                            Aug-04 8:06:42 AM Web Server Web Server authorized login successful from: 12.118.62.134 User: tjones
                            Aug-04 8:06:41 AM Web Server Web Server authorized login successful from: 12.118.62.134 User: tjones
                            Aug-04 8:06:35 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140103FF30B2 ]
                            Aug-04 8:06:35 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 2 to PIM, retry count=2
                            Aug-04 8:06:35 AM UPBSpud DEBUG PIM_SEND:: Timeout waiting for PIM response -- now trying to send command again
                            Aug-04 8:06:28 AM Web Server Web Server authorized login successful from: 12.118.62.134 User: tjones
                            Aug-04 8:06:27 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140103FF30B2 ]
                            Aug-04 8:06:27 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 2 to PIM, retry count=1
                            Aug-04 8:06:27 AM UPBSpud DEBUG PIM_SEND:: Timeout waiting for PIM response -- now trying to send command again
                            Aug-04 8:06:19 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140103FF30B2 ]
                            Aug-04 8:06:19 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 2 to PIM, retry count=0
                            Aug-04 8:06:19 AM UPBSpud DEBUG PIM_SEND:: Extracted next message to send from queue (ID 2)
                            Aug-04 8:06:19 AM UPBSpud DEBUG UPB_MGR:: passing queueMessage for UPB message to media-adapter
                            Aug-04 8:06:19 AM UPBSpud DEBUG UPB_MGR:: STATE_QUEUE:: Sending state query for device Garage Side Door (3)
                            Aug-04 8:06:19 AM UPBSpud ERROR PIM_SEND:: ERROR: Unable to send message ID 1 [07140102FF30B3] to PIM -- timed out 5 times -- discarding message
                            Aug-04 8:06:12 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140102FF30B3 ]
                            Aug-04 8:06:12 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 1 to PIM, retry count=5
                            Aug-04 8:06:11 AM UPBSpud DEBUG PIM_SEND:: Timeout waiting for PIM response -- now trying to send command again
                            Aug-04 8:06:04 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140102FF30B3 ]
                            Aug-04 8:06:04 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 1 to PIM, retry count=4
                            Aug-04 8:06:04 AM UPBSpud DEBUG PIM_SEND:: Timeout waiting for PIM response -- now trying to send command again
                            Aug-04 8:05:56 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140102FF30B3 ]
                            Aug-04 8:05:56 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 1 to PIM, retry count=3
                            Aug-04 8:05:56 AM UPBSpud DEBUG PIM_SEND:: Timeout waiting for PIM response -- now trying to send command again
                            Aug-04 8:05:53 AM Z-Wave Device: Downstairs Downstairs Hall kW Hours Set to 3.11 (3.11 kW Hours)
                            Aug-04 8:05:49 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140102FF30B3 ]
                            Aug-04 8:05:49 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 1 to PIM, retry count=2
                            Aug-04 8:05:48 AM UPBSpud DEBUG PIM_SEND:: Timeout waiting for PIM response -- now trying to send command again
                            Aug-04 8:05:41 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140102FF30B3 ]
                            Aug-04 8:05:41 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 1 to PIM, retry count=1
                            Aug-04 8:05:41 AM UPBSpud DEBUG PIM_SEND:: Timeout waiting for PIM response -- now trying to send command again
                            Aug-04 8:05:33 AM UPBSpud DEBUG PIM_SEND:: ABOUT_TO_SEND[07140102FF30B3 ]
                            Aug-04 8:05:33 AM UPBSpud INFO Checking HS Devices Started
                            Aug-04 8:05:33 AM UPBSpud DEBUG PIM_SEND:: Sending Message ID 1 to PIM, retry count=0
                            Aug-04 8:05:33 AM UPBSpud INFO Import of UPStart file completed
                            ----------------------------------------------------------------------------

                            Comment


                            • #89
                              3.0.24 not reading new upe file

                              I updated to 3.0.24. I made a couple of changes to my UPE file using upstart. Told plugin to import. Log says completed successfully. New devices I added do not show up in homeseer.

                              Any ideas?

                              Comment


                              • #90
                                Originally posted by Overst View Post
                                I updated to 3.0.24. I made a couple of changes to my UPE file using upstart. Told plugin to import. Log says completed successfully. New devices I added do not show up in homeseer.

                                Any ideas?
                                what kind of devices have you added?

                                could you send me debug logs of the plugin start up.

                                Comment

                                Working...
                                X