Announcement

Collapse
No announcement yet.

Event Trigger Options for Links

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Event Trigger Options for Links

    The trigger values for links is more limited under your HS3 plugin than was the HomeSeer HS2 plugin, see images.

    Specifically, I need to trigger when a link is set to FADE OFF


    thanks,

    tenholde
    Attached Files
    tenholde

  • #2
    Further investigation shows that the plugin appears to change the link device value to 0 for a FADE OFF action, thus I cannot distinguish between OFF and FADE OFF.

    tenholde
    tenholde

    Comment


    • #3
      well, I think the On/Off control/status for HS3 are equivalent to the Fade On/Fade Off for HS2. If you look at your screenshot there is no On/Off status in HS2.

      On/Off for a Link in my plugin means turn on/off all devices associated with this link at the default fade rate.

      Comment


      • #4
        The problem is not what is happening to the targets of the link, but the values of the link device itself.

        Further investigation using SNAP OFF:

        I have a paddle that sends ACTIVATE for the top of the rocker, and SNAP OFF for the bottom of the rocker.

        When I press the top, the target light ramps on, and the value of the link device goes to -2 (activate). When I press the bottom, the target light snaps off, but the value of the link device goes to 0 (off). It should have gone to -3 (snap off).

        Therefore, when I define a trigger for the link device that requests a trigger when the link device value goes to SNAP OFF, it will never trigger the event.

        tenholde


        tenholde

        Comment


        • #5
          Originally posted by tenholde View Post
          The problem is not what is happening to the targets of the link, but the values of the link device itself.

          Further investigation using SNAP OFF:

          I have a paddle that sends ACTIVATE for the top of the rocker, and SNAP OFF for the bottom of the rocker.

          When I press the top, the target light ramps on, and the value of the link device goes to -2 (activate). When I press the bottom, the target light snaps off, but the value of the link device goes to 0 (off). It should have gone to -3 (snap off).

          Therefore, when I define a trigger for the link device that requests a trigger when the link device value goes to SNAP OFF, it will never trigger the event.

          tenholde


          please test version 3.0.0.20 in which I have fixed the problem with Snap On / Snap Off for Links

          Comment


          • #6
            Thanks for the quick response. I'll try it this afternoon when I return home and report back.
            tenholde

            Comment


            • #7
              That worked!

              Thanks,

              tenholde
              tenholde

              Comment

              Working...
              X