Announcement

Collapse
No announcement yet.

Error loading UPB plugin after reboot

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Error loading UPB plugin after reboot

    I get the following error loading the plugin only on the automatic startup of Home Seer after a reboot. When I stop Homeseer and open the application again the plugin load fine.

    12/25/2008 10:05:12 AM - UPB - ***:Error in InitIO: System.Exception: Can not open Com port 1. Please check your UPB configuration settings - System.UnauthorizedAccessException: Access to the port 'COM1' is denied. at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str) at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace) at System.IO.Ports.SerialPort.Open() at HSPI_UPB.HSPI.InitIO(Int64 Port) at HSPI_UPB.HSPI.InitIO(Int64 Port)
    12/25/2008 10:05:12 AM - UPB - Writing to error log file - D:\Program Files\HomeSeer HSPRO\Config\UPB Error Report.Log
    12/25/2008 10:05:12 AM - Error - Initializing interface: UPB->System.Exception: Can not open Com port 1. Please check your UPB configuration settings - System.UnauthorizedAccessException: Access to the port 'COM1' is denied. at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str) at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace) at System.IO.Ports.SerialPort.Open() at HSPI_UPB.HSPI.InitIO(Int64 Port) at HSPI_UPB.HSPI.InitIO(Int64 Port)
    12/25/2008 10:05:12 AM - Info - Finished initializing plug-in UPB

    #2
    I have seen this before when a program that starts with windows tries to open the com ports looking for a device. When HomeSeer starts the port is blocked, but if HomeSeer is started just a second or two later then everything is fine. Check your startup apps and other plug-INS.


    Jon
    Jon Ort
    JonOrt@The--Orts.com
    (Remove the dashes in the address, spam is getting out of hand)

    Comment


      #3
      Thankx for the hint... Not sure how to control or delay the startup as I just have an shortcut in the startup folder...

      Comment


        #4
        A quick search turned up this, should do what you want.

        http://board.homeseer.com/showthread...ystarthomeseer
        Marty
        ------
        XPpro SP3 /w HS Standard 2.5.0.80, HSTouch Server - 1.0.0.70, HSTouch Client 1.0.0.73 HSTouch Android - 1.0.0.2, HSTouch iPhone - 1.0.0.2
        Playing with HS3 a bit but it's just play at this point.

        Comment

        Working...
        X