Announcement

Collapse
No announcement yet.

HS2 to HS3 - Cannot communicate with CM 11 to X10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS2 to HS3 - Cannot communicate with CM 11 to X10

    I have been using HS2 for years using a CM11 serial/USB device to send X10 instructions on port 3.

    Now that I have bought HS3 I find that whilst everything looks correctly set up on HS3 also using port 3 with the same CM11 device that no signals are apparently being sent so HS3 is currently un usable.

    Can anyone please help me?

    Why does the setup work with HS2 and not HS3???

  • #2
    Hello Pickles871,

    Welcome to the HomeSeer board! Sorry you're having issues getting the X10 plugin working under HS3. I'll try to help you get it running.

    Let's make sure you have covered all the basics:
    1. On the 'Manage Plugins' page install and enable the "X10" plugin.
    2. Set the COM port for the plugin to match the hardware COM port of your USB-RS232 adapter (note that if you moved this to a different USB port or different machine the port number may have changed!)
    3. Enable the X10 plugin.
    4. Plugin status says 'OK' (a DOS window may appear when the plugin is enabled, just minimize this but do not close it!)
    5. After the plugin is installed and running, create new devices according to these instructions.


    Note that you MUST create new X10 devices using the X10 tab otherwise the new devices will not be owned by the X10 plugin and they will not work as X10 devices!

    If the plugin status (on the Manage Plugins page) does not show "OK", please post that status message and any HS3 log entries for the plugin here so we can see what is happening.

    Also, please understand that there are several different versions of the "X10" plugin so it will be important to let us know a few things about your system:
    1) What OS are you running HS3 under: Windows or Linux?
    2) What version of HS3 are you running?
    3) What version of the X10 plugin are you running?

    Finally, you may want to install the latest beta version of the plugin as several issues have been addressed. The beta X10 plugin can be found here (install the latest one): https://forums.homeseer.com/showthread.php?t=185551
    Best regards,
    -Mark-

    If you're not out on the edge, you're taking up too much room!
    Interested in 3D maps? Check out my company site: Solid Terrain Modeling

    Comment


    • #3
      Have tried beta cm 11 plugin (version 40)

      I am running Windows 10
      HS3 is version 3.0.0.298

      Still having communication problems. See below.

      HS3 seems start off okay and then loses communication with CM11 as things go on.

      See log below

      HOME
      VIEW
      TOOLS
      PLUG-INS


      Filter

      Auto Update
      Refresh
      Log settings

      Date/Time Pri Type/Error Message/Source
      Jan-30 15:33:13 X10 WARNING CM11A Possible no response to send data, still waiting
      Jan-30 15:33:04 X10 WARNING CM11A Possible no response to send data, still waiting
      Jan-30 15:32:55 X10 WARNING CM11A Possible no response to send data, still waiting
      Jan-30 15:32:48 Device Control Device: Upstairs B Den Lighting Lamps Desk Light to Off (0)
      Jan-30 15:32:46 X10 WARNING CM11A Possible no response to send data, still waiting
      Jan-30 15:32:43 Device Control Device: Upstairs B Den Lighting Lamps Reading Peters to Off (0)
      Jan-30 15:32:38 Device Control Device: Upstairs B Den Lighting Lamps Reading to Off (0)
      Jan-30 15:32:36 Event Deleting event after run: "Delayed Actions Lamps Gable (Delayed Action)"
      Jan-30 15:32:36 Device Control Device: Upstairs B Den Lighting Lamps Gable to Off (0)
      Jan-30 15:32:36 Event Event Trigger "Delayed Actions Lamps Gable (Delayed Action)"
      Jan-30 15:32:33 Event Event Trigger "Manual Den Lights Off"
      Jan-30 15:32:33 Device Control Device: Upstairs B Den Lighting Lamps All Upstairs to Off (0) by/from: CAPI Control Handler
      Jan-30 15:32:30 Device Control Device: Upstairs B Den Lighting Lamps Reading Peters to Off (0) by/from: CAPI Control Handler
      Jan-30 15:32:13 Device Control Device: Upstairs B Den Lighting Lamps Gable to On (100)
      Jan-30 15:32:08 Device Control Device: Upstairs B Den Lighting Lamps Reading Peters to On (100)
      Jan-30 15:32:03 Device Control Device: Upstairs B Den Lighting Lamps Reading to On (100)
      Jan-30 15:32:01 Event Deleting event after run: "Delayed Actions Lamps Desk Light (Delayed Action)"
      Jan-30 15:32:01 Device Control Device: Upstairs B Den Lighting Lamps Desk Light to On (100)
      Jan-30 15:32:01 Event Event Trigger "Delayed Actions Lamps Desk Light (Delayed Action)"
      Jan-30 15:31:58 Event Event Trigger "Manual Den Lights On"
      Jan-30 15:31:58 Device Control Device: Upstairs B Den Lighting Lamps All Upstairs to On (100) by/from: CAPI Control Handler
      Jan-30 15:31:08 Device Control Device: Upstairs B Den Lighting Lamps All Upstairs to Off (0) by/from: CAPI Control Handler
      Jan-30 15:30:12 Device Control Device: Upstairs B Den Lighting Lamps Desk Light to Off (0) by/from: CAPI Control Handler
      Jan-30 15:30:09 Device Control Device: Upstairs B Den Lighting Lamps Gable to On (100) by/from: CAPI Control Handler
      Jan-30 15:30:06 Device Control Device: Upstairs B Den Lighting Lamps Desk Light to On (100) by/from: CAPI Control Handler
      Jan-30 15:27:05 Device Control Device: Upstairs D Towel Rails Towel Rail (Peters) to Off (0)
      Jan-30 15:26:35 Device Control Device: Downstairs D Towel Rails Towel Rail (Janets) to Off (0)
      Jan-30 15:26:05 Device Control Device: Upstairs D Towel Rails Towel Rail (Peters) to Off (0)
      Jan-30 15:25:35 Device Control Device: Downstairs D Towel Rails Towel Rail (Janets) to Off (0)
      Jan-30 15:25:16 X10 WARNING CM11A Possible no response to send data, still waiting
      Jan-30 15:25:07 X10 WARNING CM11A Possible no response to send data, still waiting
      Jan-30 15:25:05 Device Control Device: Upstairs D Towel Rails Towel Rail (Peters) to Off (0)
      Jan-30 15:24:51 X10 WARNING CM11A Possible no response to send data, still waiting
      Jan-30 15:24:51 TTS Speak ():Web server port number is 250
      Jan-30 15:24:50 TTS Speak ():Welcome to Home-Seer
      Jan-30 15:24:50 Speaker Speaker host added, Name: PetesAcer Instance: Default IP address: 127.0.0.1
      Jan-30 15:24:42 X10 WARNING CM11A Possible no response to send data, still waiting
      Jan-30 15:24:40 Event Deleting event after run: "Delayed Actions Towel Rail (Janets) (Delayed Action)"
      Jan-30 15:24:40 Device Control Device: Downstairs D Towel Rails Towel Rail (Janets) to Off (0)
      Jan-30 15:24:40 Event Event Trigger "Delayed Actions Towel Rail (Janets) (Delayed Action)"
      Jan-30 15:24:35 Event Event Trigger "Towel Rails Towel Rail Off Afternoon Recurring"
      Jan-30 15:24:35 Info System connected to MyHomeSeer Service successfully.
      Jan-30 15:24:34 Info System connected to MyHomeSeer Service, waiting for acknowledge...
      Jan-30 15:24:34 Startup Start up complete.
      Jan-30 15:24:34 Startup HSSentry is disabled in Setup, sentry will not be started.
      Jan-30 15:24:34 Startup (Startup.vb script) No speaker clients detected, waiting up to 30 seconds for any to connect...
      Jan-30 15:24:34 Startup (Startup.vb script) Scripting is OK and is now running Startup.vb
      Jan-30 15:24:34 Startup Starting Event Scheduler...
      Jan-30 15:24:34 Startup Running the startup script Startup.vb
      Jan-30 15:24:34 HSTouch Server Server started on port 10200
      Jan-30 15:24:34 Startup Starting DDNS service...
      Jan-30 15:24:34 Startup Updater services starting...
      Jan-30 15:24:33 Database Opening (Mode=Read/Write) up HomeSeer Energy database C:\Program Files (x86)\HomeSeer HS3\Data\Energy\Energy.hsd
      Jan-30 15:24:33 Speech Listening for remote speaker connections on port 10401
      Jan-30 15:24:33 Startup Initializing Speaker Client Interface
      Jan-30 15:24:33 Startup Start automation engine...
      Jan-30 15:24:32 Web Server Web Server authorized local login successful from: 192.168.2.2 User: Peter
      Jan-30 15:24:32 Web Server Web Server authorized local login successful from: 192.168.2.22 User: Peter
      Jan-30 15:24:32 Startup Creating ASP.NET application host...
      Jan-30 15:24:31 Web Server Web Server started on port 250
      Jan-30 15:24:31 Web Server UPNP Discovery started
      Jan-30 15:24:31 Web Server Local IP address (subnet) is: 192.168.2.22 (255.255.255.0)
      Jan-30 15:24:31 Plug-In Finished initializing plug-in X10
      Jan-30 15:24:31 Info Initializing CM11A/12U on COM port COM3
      Jan-30 15:24:31 Info Plugin X10 has connected. IP:127.0.0.1:50433
      Jan-30 15:24:31 Plug-In Finished initializing plug-in HSTouch Server
      Jan-30 15:24:31 Info Plugin HSTouch Server has connected. IP:127.0.0.1:50431
      Jan-30 15:24:30 Startup Initializing Plug-Ins
      Jan-30 15:24:30 Plug-In Found plug-in: X10, version: 3.0.0.40
      Jan-30 15:24:30 Plug-In Found plug-in: HSTouch Server, version: 3.0.0.68
      Jan-30 15:24:30 Startup Checking for available plug-ins
      Jan-30 15:24:30 Info Remote plug-in API interface started on port 10400
      Jan-30 15:24:30 Startup This version of HomeSeer is registered as a HS3STANDARD version.
      Jan-30 15:24:30 HSPhone HomeSeer Phone Web Interface initializing.
      Jan-30 15:24:30 Startup Initializing phone interface...
      Jan-30 15:24:30 Startup Creating Speaker Client Interface Object...
      Jan-30 15:24:30 Startup HomeSeer version is: 3.0.0.298
      Jan-30 15:24:30 Load Config Loading TIMERS...
      Jan-30 15:24:30 Load Config Loading COUNTERS...
      Jan-30 15:24:30 Load Config 71 total events loaded.
      Jan-30 15:24:30 Load Config Loading Events...
      Jan-30 15:24:30 Load Config Loading Event Groups...
      Jan-30 15:24:30 Load Config 62 total devices loaded.
      Jan-30 15:24:30 Database Loading Devices...
      Jan-30 15:24:30 Database Opening (Mode=Read Only) up HomeSeer database C:\Program Files (x86)\HomeSeer HS3\Data\HomeSeerData.hsd
      Jan-30 15:24:30 Startup Loading configuration file ...
      Jan-30 15:24:30 Startup Database SAVE process started.
      Jan-30 15:24:29 Startup Local voice recognition class started.
      Jan-30 15:24:29 Startup HSPhone external interface class started.
      Jan-30 15:24:29 Startup Plug-In Interface class started.
      Jan-30 15:24:29 Startup E-Mail RECEIVE class started.
      Jan-30 15:24:29 Startup E-Mail SEND class started.
      Jan-30 15:24:29 Startup Web server class started.
      Jan-30 15:24:29 Startup Application interface class started.
      Jan-30 15:24:29 Startup COM port classes started.
      Jan-30 15:24:29 Startup Creating Class Objects...
      Jan-30 15:24:29 Startup
      Jan-30 15:24:29 Startup ************************************************************ ********************
      Jan-30 15:24:29 Startup HomeSeer version 3.0.0.298 Edition: HS3 Standard Starting Now
      Jan-30 15:24:29 Startup ************************************************************ ********************
      Jan-30 15:24:29 Startup
      Jan-30 15:24:29 Startup Settings Loaded.

      Comment


      • #4
        CM11 connected and stable

        Using the latest beta plug in I am now up and running.

        The only remaining issue is that I have had to disconnect my XTB-IIR signal booster as it it is boosting too much extraneaous stuff and permanently resetting. It seemed to worki okay with HS2 but not so good with HS3.

        Comment


        • #5
          Originally posted by Pickles871 View Post
          I have had to disconnect my XTB-IIR signal booster as it it is boosting too much extraneaous stuff and permanently resetting.
          I did not notice any change in noise on the power line after moving from HS2 to HS3. What is the nature of the unwanted signals that are being amplified? You may also get some useful information if you describe what you are seeing to Jeff Volp, and ask his advice on how to avoid the unwanted background noise.
          Mike____________________________________________________________ __________________
          HS3 Pro Edition 3.0.0.548

          HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

          Comment


          • #6
            XTB IIR issues

            I am obtaining a controller to enable me to try some mode changes. I'll see how that goes.

            Comment

            Working...
            X