Announcement

Collapse
No announcement yet.

Multiple X10 commands supported by X10 plugin?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MrX10
    replied
    Thanks Mark, .44 is working great!

    Leave a comment:


  • mfisher
    replied
    Hey John, thanks for finding this! My bad, I'll post .44 shortly.

    Leave a comment:


  • MrX10
    replied
    X10 Plugin v3.0.0.42 and v3.0.0.43 issues

    Mark, I jumped directly from .40 to .43 and noticed the following:

    I have an event that sends All Devices OFF for a single housecode. The command made it to the powerline and turned the devices off, however the individual device states in HomeSeer did not change.

    I backed down to .42 and still observed the same behavior. When I reverted to .41, the behavior of the individual device states changed as expected when sending the ALL Devices OFF.

    As always, thanks for the time and effort you put into supporting this!
    John
    Last edited by MrX10; April 8, 2017, 04:54 PM.

    Leave a comment:


  • MrX10
    replied
    Thanks Mark, your suggestion is exactly what I was planning to do in the interim. I appreciate the response and as others have indicated here, we really appreciate your support of this plugin!
    John

    Leave a comment:


  • mfisher
    replied
    Unfortunately you have discovered a bug in the plugin. I have added this to the bug list and will address it when I am able.

    In the interim, here is a way to get around this. On your 6308, disable all but one of the X10 devices, say C1, so that it only transmits C1 ON/OFF. Then in HS3 create two events:
    1) If Device C1 Changes to ON then Control Device C2 ON, C3 ON, C4 ON.
    2) If Device C1 Changes to OFF then Control Device C2 OFF, C3 OFF, C4 OFF.
    This will emulate the functionality of the 6308 by having HS3 turn the other 3 devices on or off when the first device is controlled by the 6308.

    Leave a comment:


  • MrX10
    started a topic Multiple X10 commands supported by X10 plugin?

    Multiple X10 commands supported by X10 plugin?

    There may not be a way to do this, but I have to ask.

    Background:
    I have an old Leviton 6308 X10 Dusk to Dawn Sensor. The great functionality of this device is the ability to send On or Off commands to up to 4 devices when triggered. It has been my failsafe over the years to turn on/off all of my exterior home lights (4 unit codes) in the event that HomeSeer was down or not functioning properly. It has also been a great way to trigger other scripts through HomeSeer when dusk/dawn is detected. This thing is hard-wired and outdoor rated just like a typical 120v dusk to dawn sensor that many homes have to automatically turn on/off garage lights.

    Problem:
    When I was running HS2, the commands generated by this device were picked up fine. Now with HS3, they are not. I am using a TI103 and version 3.0.0.40 of the X10 plugin. The sensor is set to Housecode C and is set trigger units 1,2,3,&4. At dusk, the command generated (as seen is the log) is:
    Callback: Dev= C1+C2+C3+C4, HC= C, Cmd= 2, 0/0

    I have been able to replicate this transmission on the powerline using an old Maxi-controller, set to housecode C, press[1]press[2]press[3]press[4]press[on]

    I have X10 devices C2, C3, C4 defined (properly through the X10 tab) that will indeed respond to discreet individual On/Off/Dim commands , but HomeSeer does not seem to understand the above command sequence. None of the Housecode C 1-4 devices change status in HomeSeer, and I have been unsuccessful in defining an event that will capture this sequence.

    Any X10 experts out there know of a way to accommodate this through an event or definition of the X10 device, or is this a limitation of the plugin?

    I have yet to find a suitable, robust replacement for this device and I would love to continue to keep it a part of my setup.

    Thanks for any help or suggestions!
    Last edited by mfisher; February 2, 2017, 10:35 AM.
Working...
X