Announcement

Collapse
No announcement yet.

CM11 status ok but x10 commands not working [Resolved]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CM11 status ok but x10 commands not working [Resolved]

    Hi,

    I have been using X10 for many years (about 45 devices) running Cmax 2 on an Ocelot. I am getting tired of constant and growing reliability issues (probably too many "chopping" power supplies in the house) and want to move over gradually to Z-Wave.

    I have downloaded HomeSeer (Trial Version for the time being) and the first thing I want to do before I start buying Z-Wave replacement modules, is to have my existing X10 modules running on HomeSeer.

    I installed HomeSeer, the X10 plug-in and connected a CM11 on one of my serial lines.

    Under the "Installed Plug ins" screen the X10 Plug-in the status column shows OK (in green)

    I then defined a couple of my X10 devices and they show up correctly in the "Device list".

    I was expecting these X10 devices to react on/off when I click in the "Control Section" of the Device List.

    Is my expectation incorrect? Is the CM11 not supposed to pass the X10 codes transparently in both directions? Should I "manually" download some program in the CM11 for this to happen, and if so where can I find it ?

    Thanks in advance.

    JP
    Last edited by mfisher; March 26th, 2017, 08:07 PM.

  • #2
    Hello JP and welcome to the HomeSeer board!

    It sounds like you've got the plugin installed properly and it's working. Please be sure that you are creating your X10 devices according to the procedure outlined in this post in the X10 section: https://forums.homeseer.com/showthread.php?t=179522 If you just create them from the 'Config' tab they will not be recognized as X10 devices and will not be controllable from HS3!

    Also, please install the latest beta version of the X10 plugin as described in this thread as it fixes many bugs: https://forums.homeseer.com/showthread.php?t=185551
    Best regards,
    -Mark-

    If you're not out on the edge, you're taking up too much room!
    Interested in 3D maps? Check out my company site: Solid Terrain Modeling

    Comment


    • #3
      Hi Mark,

      Thank you very much for your quick answer.

      I had already found your note earlier, and installed the X10 devices accordingly, and I will install the bug fix that you mention.

      However meanwhile I have noticed something I had not seen before and I am now very suspicious about my CM11.

      (I bought it long ago and never really used it before because I quickly decided to use a more powerful Ocelot)

      I realised that X10 instructions send by devices are read by HS3 and the on/off status is updated in the devices screen. However when click on the on/off buttons on the device page, the on/off status changes on the display but it looks like no X10 instruction is sent on the grid.

      I reloaded an old version of Active Home and I have the same behaviour.

      I think my CM11 is sick and that it can receive X10 instructions but cannot send them.

      I will investigate further to confirm my suspicion and I will keep you posted.

      Best regards.

      JP

      Comment


      • #4
        Found a spare CM11

        I have been lucky to find a spare CM11 on ebay. Got it a couple of hours ago.

        I have a multi port (4) serial card on my PC which show up as COM(3,4,5 and 6).

        The CM11 worked fine on COM5 using ActiveHome Pro but failed to mount with HS3. Checked port setting on HS3 and all looked correct.

        I then connected the CM11 to the next port on the interface set HS3 to COM6 and it worked fine.

        Looks like my previous CM11 was indeed sick, but a bit worried the "new" did not mount properly on COM5 on HS3, while it did work on ActiveHome Pro.

        Best.

        JP

        Comment


        • #5
          Glad that you were able to find another CM11a and that it has resolved your X10 sending issue!

          I suspect that ActiveHome Pro may continue to run in the background after the user interface is closed and why HS could not use COM5. Or perhaps it is loading a service in the background. You might try changing the port number in ActiveHome to COM6 or COM7, reboot the PC and see if HS can use COM5. A reboot of your system without running ActiveHome after your PC starts might resolve this as well.
          Best regards,
          -Mark-

          If you're not out on the edge, you're taking up too much room!
          Interested in 3D maps? Check out my company site: Solid Terrain Modeling

          Comment

          Working...
          X