Announcement

Collapse
No announcement yet.

X10 Device Polling

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • X10 Device Polling

    I have several X10 LM14A lamp modules. These modules have 2-way communications capabilities and were working well with HS1.

    I went straight to HS3 from HS1...

    How would one poll these modules via the X10 plugin programmatically?

    Cheers,

    Wade

  • #2
    I will have to look at this and get back to you.

    A few questions so I know which code base to look at:
    1) What OS are you running the plugin under: Windows or Linux?
    2) Which interface are you using?
    3) Which plugin (X10 or CM15a) and version are you using?
    Best regards,
    -Mark-

    If you're not out on the edge, you're taking up too much room!
    Interested in 3D maps? Check out my company site: Solid Terrain Modeling

    Comment


    • #3
      X10 Device Polling

      Sorry about that... I should have included in the first message.

      Using a X10 CM11a

      HomeSeer Version: HS3 Standard Edition 3.0.0.368
      Operating System: Microsoft Windows 10 Home - Work Station
      System Uptime: 2 Days 21 Hours 8 Minutes 55 Seconds
      Number of Devices: 87
      Number of Events: 166
      Available Threads: 400

      Enabled Plug-Ins
      1.3.3.0: SimpleRF
      3.0.0.36: X10
      3.0.1.130: Z-Wave

      Comment


      • #4
        Thanks for the info!

        Yes, calls to hs.ExecX10 no longer work in HS3. However, the functionality still exists within the X10 plugin (not the CM15a plugin) and you can call the ExecX10() function from a script. The details are in this thread: https://forums.homeseer.com/showthread.php?p=1217862

        Let me know if you have any questions!
        Best regards,
        -Mark-

        If you're not out on the edge, you're taking up too much room!
        Interested in 3D maps? Check out my company site: Solid Terrain Modeling

        Comment

        Working...
        X