Announcement

Collapse
No announcement yet.

X10 ERROR (Ti103) "...Argument 'Start' must be greater than zero" [Resolved]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    X10 Error

    Originally posted by mfisher View Post
    Hi Ed, I just posted v46e which changes how the issue is handled and reported. The debug messages will still be shown as errors so they stand out in the HS log, but they are not really errors.

    Please load this version when you get a chance and post the results. I think this is resolved but I'd like to understand the timing of the interaction between the two calling mechanisms that were causing the issue.

    Thanks!
    Just saw this. Download and will install as soon as I can.

    Thanks
    Ed

    Comment


    • #47
      X10 Error

      So, Just installed 46e and booted. This is the initial log info!

      Feb-20 10:58:22 AM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 1mS for other call to clear.
      Feb-20 10:58:22 AM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=0, rbuf=[$<2800!4]
      Feb-20 10:58:22 AM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.015600, StartTime=39502.660470, CallCountChangedTime=39502.660470, EndTime=39502.676070. Calling MSComm1_OnComm()

      Comment


      • #48
        X10 Error

        Just had an opportunity to look at the log... Full of stuff!!!! Hope this helps.



        Feb-21 12:47:06 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 9mS for other call to clear.
        Feb-21 12:47:06 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:47:06 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=46026.043836, CallCountChangedTime=46026.043836, EndTime=46026.063836. Calling MSComm1_OnComm()
        Feb-21 12:45:20 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 32mS for other call to clear.
        Feb-21 12:45:19 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=10, rbuf=[$<2800!4]
        Feb-21 12:45:19 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=45919.903687, CallCountChangedTime=45919.903687, EndTime=45919.923687. Calling MSComm1_OnComm()
        Feb-21 12:42:52 PM Z-Wave Device: Lights Radio Room Light Set to OFF
        Feb-21 12:33:52 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 191mS for other call to clear.
        Feb-21 12:33:49 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:33:49 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=45229.222720, CallCountChangedTime=45229.222720, EndTime=45229.242720. Calling MSComm1_OnComm()
        Feb-21 12:32:56 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 194mS for other call to clear.
        Feb-21 12:32:54 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:32:54 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=45174.962644, CallCountChangedTime=45174.962644, EndTime=45174.982644. Calling MSComm1_OnComm()
        Feb-21 12:32:37 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 188mS for other call to clear.
        Feb-21 12:32:35 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:32:35 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=45155.862617, CallCountChangedTime=45155.862617, EndTime=45155.882617. Calling MSComm1_OnComm()
        Feb-21 12:32:10 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 187mS for other call to clear.
        Feb-21 12:32:08 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:32:08 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=45128.172579, CallCountChangedTime=45128.172579, EndTime=45128.192579. Calling MSComm1_OnComm()
        Feb-21 12:31:32 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 161mS for other call to clear.
        Feb-21 12:31:30 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:31:30 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=45090.742526, CallCountChangedTime=45090.742526, EndTime=45090.762526. Calling MSComm1_OnComm()
        Feb-21 12:31:04 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 193mS for other call to clear.
        Feb-21 12:31:02 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:31:02 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=45062.392487, CallCountChangedTime=45062.392487, EndTime=45062.412487. Calling MSComm1_OnComm()
        Feb-21 12:30:43 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 192mS for other call to clear.
        Feb-21 12:30:41 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:30:41 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=45041.552457, CallCountChangedTime=45041.552457, EndTime=45041.572457. Calling MSComm1_OnComm()
        Feb-21 12:30:14 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 190mS for other call to clear.
        Feb-21 12:30:12 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:30:12 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=45012.932417, CallCountChangedTime=45012.932417, EndTime=45012.952417. Calling MSComm1_OnComm()
        Feb-21 12:29:15 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 187mS for other call to clear.
        Feb-21 12:29:13 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:29:13 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44953.742334, CallCountChangedTime=44953.742334, EndTime=44953.762334. Calling MSComm1_OnComm()
        Feb-21 12:28:58 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 166mS for other call to clear.
        Feb-21 12:28:56 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=10, rbuf=[$<2800!4]
        Feb-21 12:28:56 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44936.862311, CallCountChangedTime=44936.862311, EndTime=44936.882311. Calling MSComm1_OnComm()
        Feb-21 12:28:40 PM Z-Wave Device: Lights Radio Room Light Set to 25
        Feb-21 12:28:34 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 190mS for other call to clear.
        Feb-21 12:28:32 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:28:32 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44912.642277, CallCountChangedTime=44912.642277, EndTime=44912.662277. Calling MSComm1_OnComm()
        Feb-21 12:28:03 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 166mS for other call to clear.
        Feb-21 12:28:02 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:28:02 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44882.062234, CallCountChangedTime=44882.062234, EndTime=44882.082234. Calling MSComm1_OnComm()
        Feb-21 12:27:26 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 192mS for other call to clear.
        Feb-21 12:27:24 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:27:24 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44844.712182, CallCountChangedTime=44844.712182, EndTime=44844.732182. Calling MSComm1_OnComm()
        Feb-21 12:27:05 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 191mS for other call to clear.
        Feb-21 12:27:03 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:27:03 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44823.882153, CallCountChangedTime=44823.882153, EndTime=44823.902153. Calling MSComm1_OnComm()
        Feb-21 12:26:34 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 193mS for other call to clear.
        Feb-21 12:26:33 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:26:33 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44793.032109, CallCountChangedTime=44793.032109, EndTime=44793.052109. Calling MSComm1_OnComm()
        Feb-21 12:25:50 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 196mS for other call to clear.
        Feb-21 12:25:48 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:25:48 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44748.452047, CallCountChangedTime=44748.452047, EndTime=44748.472047. Calling MSComm1_OnComm()
        Feb-21 12:25:31 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 189mS for other call to clear.
        Feb-21 12:25:29 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:25:29 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44729.242020, CallCountChangedTime=44729.242020, EndTime=44729.262020. Calling MSComm1_OnComm()
        Feb-21 12:25:05 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 189mS for other call to clear.
        Feb-21 12:25:04 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:25:04 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44704.031985, CallCountChangedTime=44704.031985, EndTime=44704.051985. Calling MSComm1_OnComm()
        Feb-21 12:24:40 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 193mS for other call to clear.
        Feb-21 12:24:38 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:24:38 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44678.781949, CallCountChangedTime=44678.781949, EndTime=44678.801949. Calling MSComm1_OnComm()
        Feb-21 12:22:45 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 42mS for other call to clear.
        Feb-21 12:22:45 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:22:45 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44565.041790, CallCountChangedTime=44565.041790, EndTime=44565.061790. Calling MSComm1_OnComm()
        Feb-21 12:21:43 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 14mS for other call to clear.
        Feb-21 12:21:43 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:21:43 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44502.981703, CallCountChangedTime=44502.981703, EndTime=44503.001703. Calling MSComm1_OnComm()
        Feb-21 12:20:10 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 4mS for other call to clear.
        Feb-21 12:20:10 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:20:10 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44410.621574, CallCountChangedTime=44410.621574, EndTime=44410.641574. Calling MSComm1_OnComm()
        Feb-21 12:16:59 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 17mS for other call to clear.
        Feb-21 12:16:59 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:16:59 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44219.031306, CallCountChangedTime=44219.031306, EndTime=44219.051306. Calling MSComm1_OnComm()
        Feb-21 12:16:18 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 3mS for other call to clear.
        Feb-21 12:16:18 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:16:18 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44178.781249, CallCountChangedTime=44178.781249, EndTime=44178.801249. Calling MSComm1_OnComm()
        Feb-21 12:14:19 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 6mS for other call to clear.
        Feb-21 12:14:19 PM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
        Feb-21 12:14:19 PM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=44059.901083, CallCountChangedTime=44059.901083, EndTime=44059.921083. Calling MSComm1_OnComm()

        Comment


        • #49
          X10 Error

          Looks like it started sometime around 5:300 this morning


          Feb-21 5:33:28 AM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
          Feb-21 5:33:28 AM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=20008.759407, CallCountChangedTime=20008.759407, EndTime=20008.779407. Calling MSComm1_OnComm()
          Feb-21 5:32:25 AM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 6mS for other call to clear.
          Feb-21 5:32:25 AM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
          Feb-21 5:32:25 AM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=19945.679318, CallCountChangedTime=19945.679318, EndTime=19945.699318. Calling MSComm1_OnComm()
          Feb-21 5:28:23 AM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=0, RS232 bytes=0, rbuf=[], waited for 6mS for other call to clear.
          Feb-21 5:28:23 AM X10 ERROR Ti103.MSComm1_OnComm(): re-entrant call! Call count=1, RS232 bytes=2, rbuf=[]
          Feb-21 5:28:23 AM X10 ERROR Ti103.CommThreadLoop(): EventWasHandled=False, ElapsedTime=0.020000, StartTime=19703.588979, CallCountChangedTime=19703.588979, EndTime=19703.608979. Calling MSComm1_OnComm()
          Feb-21 5:22:32 AM Web Server IP Address 219.111.9.97 has been re-enabled for access to the system.
          Feb-21 5:06:00 AM Energy DB Info All energy database compacting routines completed.

          Comment


          • #50
            Thanks for the data. Yes, it is very helpful and I see that in every instance the 'issue' comes up the system is properly handling the event, ie; no real errors.

            Besides the messy log, has your system been stable, crashed or missed any X10 events while running these last couple of test builds?
            Best regards,
            -Mark-

            If you're not out on the edge, you're taking up too much room!
            Interested in 3D maps? Check out my company site: Solid Terrain Modeling

            Comment


            • #51
              X10 Error

              Originally posted by mfisher View Post
              Thanks for the data. Yes, it is very helpful and I see that in every instance the 'issue' comes up the system is properly handling the event, ie; no real errors.

              Besides the messy log, has your system been stable, crashed or missed any X10 events while running these last couple of test builds?
              No, All appears to be working-as expected. I have several Light switches that are controlled by daily events. No problems with execution of the events.

              Ed

              Comment


              • #52
                Cool, I'll post a new build soon.
                Best regards,
                -Mark-

                If you're not out on the edge, you're taking up too much room!
                Interested in 3D maps? Check out my company site: Solid Terrain Modeling

                Comment


                • #53
                  X10 Error

                  Originally posted by mfisher View Post
                  Cool, I'll post a new build soon.
                  Any ideas on a release? Lots and Lots of red in the log

                  Many thanks for resolving this matter.

                  Ed

                  Comment


                  • #54
                    X10 Error

                    Good Morning,

                    Just checking in. Any news on a final version. Would like to get some of the red ink out of the log.

                    Again many hanks

                    Ed

                    Comment


                    • #55
                      Official beta release of v3.0.0.46 is posted. Sorry about the delay, I've been swamped with my business and have not had any spare time...

                      Please let me know that everything is ok with this build as I removed all the debug code and made a slight change to how redundant calls to the receive serial data routine are handled.

                      Thanks again for your patience!
                      Best regards,
                      -Mark-

                      If you're not out on the edge, you're taking up too much room!
                      Interested in 3D maps? Check out my company site: Solid Terrain Modeling

                      Comment


                      • #56
                        Thank you Mark. Your time and efforts are sincerely appreciated.

                        I noticed but forgot to post that I cannot shut off the debug mode in HS3 V.422 / X10 V.3.0.0.45.

                        Thinking maybe this was an issue with HS3 rather than the plugin.

                        Yesterday updated HS3 to V.422 and today will update X10 to v3.0.0.46. (done)

                        To turn it off I shut down Homeseer 3 first, edited the ini file then started HS3. Looking at the logs debug was still on and enabled once again in the INI file.

                        Restarted HS3 with updated X10 plugin and again it is in debug mode.

                        Mar-03 11:32:54 AM X10 DEBUG CM11A.GetUpload(): Upload byte count: 3
                        Mar-03 11:32:54 AM X10 DEBUG CM11A.GetUpload(): Upload Data: 0x2 Time: 41574.224
                        Mar-03 11:32:54 AM X10 DEBUG CM11A.GetUpload(): Upload Data: 0x65 Time: 41574.239
                        Mar-03 11:32:54 AM X10 DEBUG CM11A.GetUpload(): Upload Data: 0x62 Time: 41574.253

                        Looking at the X10.ini file and it reset itself to debug mode.

                        [settings]
                        PluginDebug=True
                        Override=False
                        COMPort=/dev/ttyUSBX10

                        See this in the settings.ini file.

                        COMPort_X10:=/dev/ttyUSBX10

                        Should I manually remove this line from the settings.ini file?

                        [ATTACH]67190[/ATTACH]
                        Last edited by Pete; March 3rd, 2018, 12:49 PM.
                        - Pete

                        Auto mator
                        Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
                        Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

                        X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                        Comment


                        • #57
                          Thanks Pete.

                          The X10 plugin checks the value in the ini file when it is started, so if HS3 is re-enabling it in the ini then the plugin will continue to have this enabled and will post debug messages. Note that checking and unchecking the 'Developer Mode' checkbox on the Manage Plugins page is supposed to be changing this in the ini file (so you don't have to edit the ini). You might also try making the change there instead and see if it's any different.

                          I've not touched any of that code in any of the plugins, so please let me know what you find and if there is an issue I'll dig into it!
                          Best regards,
                          -Mark-

                          If you're not out on the edge, you're taking up too much room!
                          Interested in 3D maps? Check out my company site: Solid Terrain Modeling

                          Comment


                          • #58
                            Thank you Mark.

                            Duh!

                            Forgot about the "Developer Mode" checkbox. Unchecked it and the debug logging is gone.
                            - Pete

                            Auto mator
                            Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
                            Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

                            X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                            Comment


                            • #59
                              LOL! Good to know you're still human like the rest of us mortals
                              Best regards,
                              -Mark-

                              If you're not out on the edge, you're taking up too much room!
                              Interested in 3D maps? Check out my company site: Solid Terrain Modeling

                              Comment

                              Working...
                              X