Announcement

Collapse
No announcement yet.

HomeSeer sporadically loses connection with CM15A

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HomeSeer sporadically loses connection with CM15A

    I don't know what sets this off. I was able to fix it by unplugging and reconnecting the USB cord, as the log suggested. It happens every few days.

    Any ideas? Thanks!

    ==================================

    Log:

    Jun-03 9:01:42 PM
    CM15A Connected to CM15A successfully. Jun-03 9:01:37 PM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused Jun-03 9:01:32 PM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused Jun-03 9:01:27 PM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused Jun-03 9:01:21 PM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused Jun-03 9:01:21 PM CM15A Unable to send to CM15A: The operation is not allowed on non-connected sockets. Jun-03 9:01:18 PM CM15A Unable to send to CM15A: The operation is not allowed on non-connected sockets. Jun-03 9:01:16 PM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused Jun-03 9:01:16 PM CM15A Unable to send to CM15A: Unable to write data to the transport connection: The socket has been shut down. Jun-03 8:56:33 PM Event Event Trigger "Lighting Outback off to X10" Jun-03 8:56:33 PM Z-Wave Device: First Floor Kitchen Outside Back Lights Set to OFF
    =================================

    System Profile:

    Current Date/Time: 6/3/2018 9:04:54 PM
    HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.423
    Linux version: Linux HomeTrollerZeeS2V2 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux System Uptime: 7 Days 8 Hours 47 Minutes 39 Seconds
    IP Address: 192.168.1.112
    Number of Devices: 16
    Number of Events: 9
    Available Threads: 394
    HSTouch Enabled: False
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed:

    Enabled Plug-Ins
    3.0.0.5: CM15A
    3.0.1.130: Z-Wave

  • #2
    Hello Brian, my apologies for the delay in getting back to you.

    Version 3.0.0.5 of the HS3 CM15a Linux plugin in the updater is the latest, so you are running the most current version. Only beta releases are posted on the message board and those must be installed manually by copying file(s) into the HS3 directory.

    Code:
    Jun-03 8:56:33 PM	Z-Wave Device: First Floor Kitchen Outside Back Lights Set to OFF 
    Jun-03 8:56:33 PM	Event Event Trigger "Lighting Outback off to X10"
    Jun-03 9:01:16 PM	CM15A Unable to send to CM15A: Unable to write data to the transport connection: The socket has been shut down.
    Jun-03 9:01:16 PM	CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
    Jun-03 9:01:18 PM	CM15A Unable to send to CM15A: The operation is not allowed on non-connected sockets.
    Jun-03 9:01:21 PM	CM15A Unable to send to CM15A: The operation is not allowed on non-connected sockets.
    Jun-03 9:01:21 PM	CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
    Jun-03 9:01:27 PM	CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
    Jun-03 9:01:32 PM	CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
    Jun-03 9:01:37 PM	CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
    Jun-03 9:01:42 PM	CM15A Connected to CM15A successfully.
    Regarding your disconnection issue, the entries in your log indicate that the operating system (linux) in your HomeTroller thinks the CM15a is no longer connected to it. For the sake of clarity here is the communication chain between the HS3 CM15a plugin and the CM15a interface:

    HomeSeer3 <--> CM15a Plugin <--TCP/IP--> MOCHAD <--> UDEV (Linux) <--> USB Port <--> USB Cable <--> CM15a

    MOCHAD is a linux driver for the CM15a. It is started by linux (not HomeSeer or the plugin) when a CM15a is attached to the system and it is stopped when the CM15a is disconnected. The CM15a plugin opens a 'connection' to MOCHAD to communicate and errors out when it cannot talk to MOCHAD, just like you are seeing.

    A few questions to get the troubleshooting started:
    1) Are you certain that the CM15a is powered on all the time?
    2) Is the physical connection (USB) between the CM15a and the HS box firm and solid? (No chance the cable is loose).
    3) Have you tried a different USB cable?
    4) Have you installed any software on the HomeTroller other than HS3 plugins?
    5) Do you have any experience with linux and using SSH?

    As a quick test, the next time it fails please try the following before disconnecting the CM15a:
    1) Go to the Manage Plugins page in HS3 and disable the CM15a plugin
    2) Once the plugin is shutdown re-enable the CM15a plugin
    3) Note the plugin status after the plugin has enabled
    4) Copy and post the relevant entries from your log and plugin status here

    Also, please reboot your HomeTroller and post a copy of the log from startup until a bit after the CM15a plugin is initialized and an attampt is made to control an X10 device. Please attach it as a text file to your post if it's really long.
    Best regards,
    -Mark-

    If you're not out on the edge, you're taking up too much room!
    Interested in 3D maps? Check out my company site: Solid Terrain Modeling

    Comment


    • #3
      My cm15a works from laptop using Active Home, but no longer works with my Zee2 Hometroller. Tried different cables, usb slots etc.

      This is what my log shows.
      Dec-01 6:11:29 PM Info Processing updates completed.
      Dec-01 6:11:29 PM Info System connected to MyHS Service successfully with license ID 98517.
      Dec-01 6:11:29 PM Info Latest BETA update available is: 3.0.0.483
      Dec-01 6:11:29 PM Info Latest update available is: 3.0.0.475
      Dec-01 6:11:29 PM Info System connected to MyHS Service, waiting for acknowledge...
      Dec-01 6:11:28 PM TTS Speak ():Welcome to Home-Seer
      Dec-01 6:11:28 PM Startup Scripting is OK and is now running Startup.vb
      Dec-01 6:11:28 PM Info Checking for updates...
      Dec-01 6:11:28 PM Startup HSSentry is disabled in Setup, sentry will not be started.
      Dec-01 6:11:28 PM Startup Starting Event Scheduler...
      Dec-01 6:11:24 PM Startup Running the startup script Startup.vb
      Dec-01 6:11:24 PM System Synchronizing events from 12/1/2018 6:11:24 AM until now
      Dec-01 6:10:36 PM Starting Plug-In Plugin CM15A started successfully in 501 milliseconds
      Dec-01 6:10:35 PM CM15A Initialization Successful.
      Dec-01 6:10:35 PM CM15A mochad is not running, starting...
      Dec-01 6:10:35 PM Starting Plug-In Initializing plugin CM15A ...
      Dec-01 6:10:35 PM Info Plugin CM15A has connected. IP:127.0.0.1:52868
      Dec-01 6:10:34 PM Startup Powerfail Recovery will take place in 30 Seconds
      Dec-01 6:10:34 PM Startup Starting Find service...
      Dec-01 6:10:34 PM Startup Updater services starting...
      Dec-01 6:10:34 PM Database Opening (Mode=Read/Write) up HomeSeer Energy database /usr/local/HomeSeer/Data/Energy/Energy.hsd
      Dec-01 6:10:34 PM Speech Listening for remote speaker connections on port 10401
      Dec-01 6:10:34 PM Startup Initializing Speaker Client Interface
      Dec-01 6:10:34 PM Startup Start automation engine...
      Dec-01 6:10:34 PM Web Server Web Server started on port 80
      Dec-01 6:10:34 PM Web Server Local IP address is: 192.168.86.21
      Dec-01 6:10:34 PM Startup HStouch server started, waiting for clients to connect.
      Dec-01 6:10:34 PM HSTouch Server Server started on port 10200
      Dec-01 6:10:34 PM Plug-In Finished initializing plug-in CM15A
      Dec-01 6:10:34 PM Startup Initializing Plug-Ins
      Dec-01 6:10:34 PM Plug-In Found plug-in: CM15A, version: 3.0.0.5
      Dec-01 6:10:33 PM Database Opening (Mode=Read/Write) up HomeSeer LOG database /tmp/HomeSeerLog.hsd
      Dec-01 6:10:33 PM Startup Checking for available plug-ins
      Dec-01 6:10:33 PM Info Remote plug-in API interface started on port 10400
      Dec-01 6:10:33 PM Startup This version of HomeSeer is registered as a HS3ZEES2 version.
      Dec-01 6:10:33 PM Startup Creating Speaker Client Interface Object...
      Dec-01 6:10:33 PM Startup HomeSeer version is: 3.0.0.475
      Dec-01 6:10:33 PM Load Config Loading TIMERS...
      Dec-01 6:10:33 PM Load Config Loading COUNTERS...
      Dec-01 6:10:33 PM Load Config 12 total events loaded.
      Dec-01 6:10:32 PM Load Config Loading Events...
      Dec-01 6:10:32 PM Load Config Loading Event Groups...
      Dec-01 6:10:32 PM Load Config 11 total devices loaded.
      Dec-01 6:10:32 PM Database Loading Devices...
      Dec-01 6:10:32 PM Database Opening (Mode=Read Only) up HomeSeer database /usr/local/HomeSeer/Data/HomeSeerData.hsd
      Dec-01 6:10:32 PM Startup Loading configuration file ...
      Dec-01 6:10:32 PM Startup Database SAVE process started.
      Dec-01 6:10:32 PM Startup Local voice recognition class started.
      Dec-01 6:10:32 PM Startup Plug-In Interface class started.
      Dec-01 6:10:32 PM Startup E-Mail RECEIVE class started.
      Dec-01 6:10:32 PM Startup E-Mail SEND class started.
      Dec-01 6:10:32 PM Startup Web server class started.
      Dec-01 6:10:32 PM Startup Application interface class started.
      Dec-01 6:10:32 PM Startup COM port classes started.
      Dec-01 6:10:32 PM Startup Creating Class Objects...
      Dec-01 6:10:32 PM Startup
      Dec-01 6:10:32 PM Startup ************************************************************ ********************
      Dec-01 6:10:32 PM Startup HomeSeer version 3.0.0.475 Edition: HS3 ZEE S2 Starting Now
      Dec-01 6:10:32 PM Startup ************************************************************ ********************
      Dec-01 6:10:32 PM Startup
      Dec-01 6:10:32 PM Startup Settings Loaded.

      Comment


      • #4
        Looks like it starting fine .....

        Starting Plug-In ... Plugin CM15A started successfully in 501 milliseconds

        then the mochad service is not found ...

        then it restarts the mochad service....

        Initializing plugin CM15A ...

        then it connects...

        Plugin CM15A has connected. IP:127.0.0.1:52868

        Just to confirm that it is running fine; I would enable debug first....once connected there is a lot of chatter that you will see..

        If you confirm the chatter to the CM15A then following the documenation to create an X10 device. It has to be created manually versus the device being automagically created.

        Put Homeseer 3 / Installed Plugins in Develope mode (check box) first then make sure the debug flag is enabled in the ini file.

        Here continue to utilize a CM11A for powerline and a W800 for wireless X10.

        - Pete

        Auto mator
        Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
        Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

        X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

        Comment


        • #5
          Hello,

          Have you solved this issue? I've the same...
          Every few days I have to disable/enable plugin or restart whole HomeTroller Zee S2

          Rafal

          Comment


          • #6
            Have you guys set up the Mochad daemon correctly.

            Comment


            • #7
              Maybe not. Can you explain how to setup this daemon to work stable?

              Comment


              • #8
                You'll need to do a little more research on this. Here's a good starting point to set up the service properly https://sourceforge.net/p/mochad/act...24ca5eb45a6a88

                Just make sure you are using Mochad 17

                Comment


                • #9
                  I am having the same issue. Cm15a becomes disconnected every few days. Restarting the plugin fixes it for a while. At this point the system is less stable than my old Active Home which is pretty sad. Any idea how to fix this? I have the latest released version of the plugin.

                  Thanks for your help.

                  TJ


                  Log upon failure
                  May-04 6:55:59 AM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
                  May-04 6:55:54 AM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
                  May-04 6:55:49 AM CM15A Unable to send to CM15A: The operation is not allowed on non-connected sockets.
                  May-04 6:55:49 AM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
                  May-04 6:55:49 AM CM15A Unable to send to CM15A: Unable to write data to the transport connection: The socket has been shut down.
                  May-04 6:55:49 AM Event Event Trigger "Light Groups Den Lights Off"
                  May-04 6:55:49 AM Event Event Trigger "Motion Detector Den Motion Off"
                  May-04 6:55:49 AM Z-Wave Device: Downstairs Den Motion Set to NOTIFICATION for type Home Security, Event: No Event
                  May-04 6:38:56 AM Event Event Trigger "Light Groups Upstairs Lights Off"

                  Log after restart
                  May-04 7:00:40 AM Event Event Trigger "Outside Lights Front Yard Lights Off"
                  May-04 7:00:40 AM Event Event Outside Lights Front Yard Lights Off triggered by the event page 'Run' button.
                  May-04 7:00:24 AM Plug-In Finished initializing plug-in CM15A
                  May-04 7:00:24 AM Starting Plug-In CM15A loaded in 2503 milliseconds
                  May-04 7:00:24 AM Starting Plug-In Plugin CM15A started successfully in 1443 milliseconds
                  May-04 7:00:23 AM CM15A Initialization Successful.
                  May-04 7:00:22 AM CM15A mochad is not running, starting...
                  May-04 7:00:22 AM Starting Plug-In Initializing plugin CM15A ...
                  May-04 7:00:22 AM Info Plugin CM15A has connected. IP:127.0.0.1:42848
                  May-04 7:00:14 AM Info Plugin CM15A with instance: has disconnected
                  May-04 7:00:14 AM Plug-In Shutting down Plug-In: CM15A
                  May-04 7:00:10 AM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
                  May-04 7:00:04 AM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
                  May-04 6:59:59 AM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
                  May-04 6:59:54 AM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...: Connection refused
                  May-04 6:59:49 AM CM15A Unable to communicate with CM15A, try re-connecting to USB port, will retry in 5 seconds...:

                  homeseer data
                  Current Date/Time: 5/4/2019 7:32:26 AM CDT
                  HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.531 (Linux)
                  HomeSeer: Is Registered
                  System Uptime: 0 Days 0 Hours 59 Minutes 27 Seconds
                  User Name and Access Level: tjankovs (Admin)
                  LAN IP Address: 192.168.1.221 (HomeTrollerZeeS2V5)
                  Client IP Address: 192.168.1.209 (192.168.1.209)
                  External IP Address: 104.188.236.17 (104.188.236.17)
                  Network Adapter: HomeSeer Adapter -> Loopback Address (localhost) IP: 127.0.0.1
                  Web Server Port: 80
                  Number of Devices: 69
                  Number of Events: 73
                  Event Last Ran: Outside Lights : Backyard Lights Off, Ran at 5/4/2019 7:00:50 AM
                  Number of unique event scripts used: 0
                  Plug-Ins Enabled: Z-Wave:,CM15A:
                  Modules/Threads: 65 Modules, 41 Threads
                  Available Threads: 399
                  HomeSeer Memory Used: 88 Mbytes
                  Plug-In Memory Used:

                  Comment


                  • #10
                    Well, it has gotten worse. I need to restart the homeseer box or restart the plugin every couple of hours now. Any ideas?

                    Comment


                    • #11
                      OK it is fixed and has been stable for a week. Replacing the CM15 hardware did it.

                      Comment

                      Working...
                      X