Announcement

Collapse
No announcement yet.

Sunrise-, Sunset- Event does not run all actions [Moved to CPUXA Ocelot]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sunrise-, Sunset- Event does not run all actions [Moved to CPUXA Ocelot]

    Hi!
    I use two events (triggers are sunrise and sunset) für opening and closing my rolling shutters. This worked well for about 10 years. Since a few mounths only 1-3 rolling shutters are opening or closing automatically. Manually triggering the event gives the same result.
    At the beginning I suspected the SW10 s (X10 switches), but they still work fine using HSTouch or pressing them manually.
    I already tried splitting each event (adressing 6 SW10 at once) into 6 events (each with one second delay), but this didnt solve the problem.

    Now I have 12 single events. Each one adresses one SW10 and tells it to open or close the rolling shutter. If I run one of the events, nothing will happen.
    If I push one of the HSTouch buttons adressing a SW10 it will open, close and even dim.

    Does anyone have an idea how to make it work again.

    ;-)

    I already posted this in the general discussion area and got the hint to better ask the question in the X10 forum:
    https://forums.homeseer.com/forum/ho...un-all-actions

    I will soon add some more information about software versions an plugins used.
    The comunication from the Win10-Server to the SW10s runs over an XM10.
    Last edited by mfisher; November 23rd, 2018, 09:05 AM.

  • #2
    Hi,
    - the plugin I use is: GTS CPUXA Version
    3.5.16263.159


    - all events have the correct "last run" time.

    LOG (sunset triggered):
    Nov-20 17:07:16 GTS CPUXA X10 SW10 C1 has been set to Up
    Nov-20 17:07:16 Device Control Device: GTS CPUXA X10 X10 C1 to Down (0)
    Nov-20 17:07:16 Event Event Trigger "Rolladen Rolladen auto zu Bad"
    Nov-20 17:07:15 GTS CPUXA X10 SW10 B5 has been set to Up
    Nov-20 17:07:15 Device Control Device: GTS CPUXA X10 X10 B5 to Down (0)
    Nov-20 17:07:15 Event Event Trigger "Rolladen Rolladen auto zu Wohnzimmer"
    Nov-20 17:07:14 GTS CPUXA X10 SW10 B4 has been set to Up
    Nov-20 17:07:14 Device Control Device: GTS CPUXA X10 X10 B4 to Down (0)
    Nov-20 17:07:14 Event Event Trigger "Rolladen Rolladen auto zu Terrasse Wohn"
    Nov-20 17:07:13 GTS CPUXA X10 SW10 B3 has been set to Up
    Nov-20 17:07:13 Device Control Device: GTS CPUXA X10 X10 B3 to Down (0)
    Nov-20 17:07:13 Event Event Trigger "Rolladen Rolladen auto zu Terrasse Ess"
    Nov-20 17:07:12 GTS CPUXA X10 SW10 B2 has been set to Up
    Nov-20 17:07:12 Device Control Device: GTS CPUXA X10 X10 B2 to Down (0)
    Nov-20 17:07:12 Event Event Trigger "Rolladen Rolladen auto zu Esszimmer"
    Nov-20 17:07:11 GTS CPUXA X10 SW10 B1 has been set to Up
    Nov-20 17:07:11 Device Control Device: GTS CPUXA X10 X10 B1 to Down (0)
    Nov-20 17:07:11 Event Event Trigger "Rolladen Rolladen auto zu Küche"
    LOG (triggered by HSTouch):
    Nov-20 21:30:48 GTS CPUXA X10 SW10 B2 has been set to Up
    Nov-20 21:30:48 Device Control Device: GTS CPUXA X10 X10 B2 to Down (0) by/from: CAPI Control Handler
    Event:
    Event Name: Type Group Reassign:
    (Enter New Type Name)BMmanuell (Create A New Group)BeregnungDelayed ActionsHarmonyLichtRolladen
    Voice Command:



    Do you need more information?








    Edit T

    Comment


    • #3
      Hmm...copy paste didnt work verry well :-(

      Comment


      • #4
        For future reference, I find posting log entries works best when pasted into Notepad first then copied to the board.

        Here are log entries from my system when pasted into Notepad first


        Nov-20 2:34:26 PM HSBuddy Cleanup thread removed 8433 entries from device history.
        Nov-20 2:31:50 PM Event Event Trigger "Appliance Status Chest Freezer 1 Stopped"
        Nov-20 2:31:18 PM Event Event Trigger "Power - Entertainment LR Subs OFF with Receiver and Sonos"
        Nov-20 2:29:52 PM PHLocation2 (SetIOMulti) Poll rate changed for [9345] to 45 minutes.
        Nov-20 2:29:52 PM Event Event Trigger "Location Michelle - 45 minute polling when home or work - 60 minutes or more"
        Nov-20 2:22:04 PM Event Event Trigger "Arduino LCD LCD Backlights On"
        Nov-20 2:19:26 PM HSBuddy Cleanup thread removed 8329 entries from device history.
        Nov-20 2:17:03 PM Event Event Trigger "Appliance Status Chest Freezer 1 Running"
        Nov-20 2:10:04 PM DoorWindow Door Count: 1
        Nov-20 2:10:04 PM DoorWindow Front Door Open
        Nov-20 2:09:59 PM DoorWindow Window Count: 1
        Nov-20 2:09:59 PM DoorWindow Randy Office Window Open
        Nov-20 2:07:04 PM Event Event Trigger "Arduino LCD LCD Backlights On"
        Nov-20 2:04:26 PM HSBuddy Cleanup thread removed 8360 entries from device history.
        Nov-20 2:00:27 PM SonosSpeak Announce End (event)
        Nov-20 2:00:23 PM Event Event Trigger "Sonos LR Speakers - Rear OFF"
        Nov-20 2:00:23 PM Event Event Trigger "Sonos LR Speakers - Playing Stopped"
        Nov-20 2:00:23 PM Event Event Trigger "Sonos LR Sonos NOT PLaying"
        Nov-20 2:00:08 PM Event Event Trigger "Sonos LR Sonos PLaying"
        Nov-20 2:00:06 PM SonosSpeak Announce Start (event)
        Nov-20 2:00:03 PM SonosSpeak Group link begun
        Randy Prade
        Aurora, CO
        Prades.net

        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

        Comment


        • #5
          Originally posted by fagor View Post
          the plugin I use is: GTS CPUXA Version
          3.5.16263.159

          - all events have the correct "last run" time.
          I am not familiar with that plug-in. I'm hoping Mark will join the conversation. He may know more.

          The comunication from the Win10-Server to the SW10s runs over an XM10.
          I also am not familiar with the XM10 or the SM10. I assume those are required for your power line characteristics.

          Is it possible to use a version of the HST plug-in with your hardware or are they incompatible?

          More questions:
          Can you post a screen shot of one of the events that is not working?
          How do you actuate the switch with HSTouch? Are you controlling the HS device associated with the switch.
          What happens if you control the switch device with the buttons on the HS Device Management page?

          Last edited by Uncle Michael; November 20th, 2018, 07:52 PM. Reason: added more questions
          Mike____________________________________________________________ __________________
          HS3 Pro Edition 3.0.0.548

          HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

          Comment


          • #6
            Fagor, sorry you are having troubles. The X10 plugins discussed in this forum are not compatible with your CPUXA (Ocelot) hardware. Some folks who frequent this forum may be familiar with the CPUXA but may not be familiar with the GTS plugin for it. I have no experience with either of them. You might want to ask your questions in the forum for that plugin: https://forums.homeseer.com/forum/an...ocelot-bbowser

            With that said, let's see if we can help get to the root of your issue...

            Just to clarify for everyone reading, can you please confirm that this is your setup:

            [WIN10 + HS3 + GTS CPUXA plugin] ---(RS232 serial)---> [CPUXA] ---(telephone cable)---> [XM10] ---{power line}---> [SW10] ---> Roller Shutter

            Where:
            CPUXA is a CPUXA "Ocelot"
            XM10 is the X10 powerline interface (220v version of the TW523)


            As I see it here are the parts of your X10 system where the problem may exist:
            1) power line communication
            2) X10 hardware: CPUXA, XM10 or SM10
            3) CPUXA plugin
            4) HS3 event engine

            Upon review of your log file it appears that the events are being properly triggered and are correctly requesting the CPUXA to control the shutters. Did the shutters referenced in the log events move or not move when these events in your log were executed?

            Since your system was working correctly for some time, my first question is - what changed?
            - Was the HS3 software updated?
            - Was the CPUXA plugin updated?
            - Did something change in your X10 system, such as plugging in a new module, removing a module, an new computer/phone/TV/etc. in the house?

            Some additional questions:
            1) Are there any problems with X10 communications on your power line? Can you manually control all of your X10 devices reliably? All of the time?
            2) Do you have any other X10 devices such as lights? If so, do you have any problems controlling them?
            3) As asked in the post above, can you reliably control the shutters using controls on the Device Management page in HS?
            4) What happens if you manually run these events from the HS Events page? Do the shutters open and close as expected?
            5) What other things are happening when these problem events are run? Maybe other HS events, X10 devices being controlled, electrical devices being turned on or off?
            Best regards,
            -Mark-

            If you're not out on the edge, you're taking up too much room!
            Interested in 3D maps? Check out my company site: Solid Terrain Modeling

            Comment


            • #7
              Thank you mfisher. I moved this into the GTS CPUXA plugin section:
              https://forums.homeseer.com/forum/an...un-all-actions

              Comment

              Working...
              X