Announcement

Collapse
No announcement yet.

HS3 ZEE S2 Edition 3.0.0.534 (Linux) X10 Logging Missing....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3 ZEE S2 Edition 3.0.0.534 (Linux) X10 Logging Missing....

    While attempting to setup a few older X10 devices with the ZEE S2 I noticed that any and all X10 commands, whether sent or received by the ZEE are missing from the HS Log.

    Any reason why commands are no longer logged and will this problem be fixed anytime soon?

    I was told by HS support (Greg Hughes) that they no longer support the plugin and have sold it to others, yet they still make it available to install as an HS legacy product. Why a company like Homeseer who's original core product relied solely on X10 would abandon longtime users and supporters of there software products is beyond me..... Worse yet is that they apparently don't test these, now 3rd party plugins for proper operation before placing them on their site for installation.

    Thanks,

    Don

  • #2
    A911Pro

    Yes the X10 plugin development from HS3 folks stopped. Good news is that Mark has fixed it and it is working well and it is free and better than ever.

    Debug logging does work in Linux. You have to turn on Developer Mode to see the X10 debug stuff.

    Ideally debug (X10 logging) should be an automous switch in the configuration of the plugin.

    Enable it and watch it as it is very chatty kathy with my CM11A.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
    Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

    Comment


    • #3
      Well, it may work for you but with debug turned on all I get in the log is this in response to received X10 commands, no House/Unit Code Info.
      X10 DEBUG CM11A Upload Data: 1 Time: 33129.622
      Jun-20 9:12:09 AM X10 DEBUG CM11A Upload byte count: 2
      Jun-20 9:12:07 AM X10 DEBUG CM11A Upload Data: A Time: 33127.889
      Jun-20 9:12:07 AM X10 DEBUG CM11A Upload byte count: 5
      Jun-20 9:12:03 AM X10 DEBUG CM11A Upload Data: A Time: 33123.433
      Jun-20 9:12:03 AM X10 DEBUG CM11A Upload byte count: 5
      Jun-20 9:11:58 AM X10 DEBUG CM11A Upload Data: 2 Time: 33118.783
      Jun-20 9:11:58 AM X10 DEBUG CM11A Upload byte count: 3

      Comment


      • #4
        Yeah the debug does not show the device house unit code.

        You would probably have to enable logging of the X-10 devices.

        Click image for larger version

Name:	X10.jpg
Views:	102
Size:	66.7 KB
ID:	1311550

        xxx
        - Pete

        Auto mator
        Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
        Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

        X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

        Comment


        • #5
          That's fine if there is already a device configured but I was looking for ALL received/transmitted codes to be recorded in the log like it always did from back in the beginning, early 90's.

          I still can't understand how, exactly the plugin got screwed up, but I can understand HS not wanting to support it as they want to sell there newer devices. Problem is that there are still many people using it.

          Thanks for your help!

          Comment


          • #6
            Yes the Homeseer 3 X10 plugin doesn't do discovery. Rather you have to create each X10 device manually.

            I am still using X10 here with the CM11A, TW-523, Volp TW-523 dual phased device and Volp X10 Amplifier from many years ago.

            I started to tinker with it around 1978 and did have X10 in first home purchased a bit after that. It works fine for me today.

            but I can understand HS not wanting to support it as they want to sell there newer devices. Problem is that there are still many people using it.

            Understood and see that.

            I have migrated my in wall switches to powerline UPB and I am a happy camper here today and have too much nowadays invested in UPB to change and I am old now...
            - Pete

            Auto mator
            Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
            Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

            X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

            Comment


            • #7
              While attempting to setup a few older X10 devices with the ZEE S2 I noticed that any and all X10 commands, whether sent or received by the ZEE are missing from the HS Log.

              Any reason why commands are no longer logged and will this problem be fixed anytime soon?
              That's fine if there is already a device configured but I was looking for ALL received/transmitted codes to be recorded in the log like it always did from back in the beginning, early 90's.

              I still can't understand how, exactly the plugin got screwed up, but I can understand HS not wanting to support it as they want to sell there newer devices. Problem is that there are still many people using it.

              Thanks for your help!
              Logging all of the X10 traffic was removed by HST when the HS2 versions of the plugins (X10 and CM15a) were migrated to HS3. I can only assume they were tyring to reduce clutter in the log.

              Please install the latest beta release for the X10 plugin: https://forums.homeseer.com/forum/li...-beta-releases

              The logging of X10 traffic for devices that are not owned by the plugin was added back in at v3.0.0.42: … Added new feature: Log all received X10 commands for devices not owed by the plugin when Debug Mode is enabled.
              Best regards,
              -Mark-

              If you're not out on the edge, you're taking up too much room!
              Interested in 3D maps? Check out my company site: Solid Terrain Modeling

              Comment


              • #8
                Mark,

                Thanks for the info but not quite sure how I would get the beta X10 plugin into the Zee S2?

                Don

                Comment

                Working...
                X