Announcement

Collapse
No announcement yet.

New to X-10 Integration with Hometroller & HS3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New to X-10 Integration with Hometroller & HS3

    I have been using X-10 technology for many years and have many devices and switches already in place. I purchased a Hometroller SEL with HS3 a few years ago but never got around to figuring out how to integrate the X-10 technology with the Hometroller platform. I would again like to try to get this setup, but according to HomeSeer they do not support the legacy X-10 and they pointed me to this forum. I would also like to get all this integrated up with my Alexa and other wireless technology that I have acquired.
    But for now - can someone please help figure out way I need to do to get this all rolling. I'm pretty certain that I have all the hardware I need to do this, but am missing/unsure of the software and plug-ins that I need and how to get everything setup and working. I bought the Hometroller specifically because I thought they would be available to help with getting this all setup, but it appears that is no longer the case...

    Here is a list of the hardware that I have:
    Hometroller SEL with HS3 (is there a reason that I might want to upgrade to HS3 Pro or HS4/Pro?)
    CM15A (but no software with this)
    PowerLinc Modem #2413U
    TM751 and RR501 Transceivers
    DSC IT-100
    Assorted X-10 appliance and lamp modules
    Assorted X10 switches and outlets
    Assorted Amazon Echo, Dots, Tap, and Shows
    TP-Link Casa Smart WiFi Plug
    EcoBee Smart Thermostat
    Phillips Hue Bridge
    Plillips Hue Lighting

    #2
    Welcome to the forum! You've come to the right place, but because there is so much activity here, finding answers can sometimes be challenging. Once you get rolling i think you will really be glad you tried HomeSeer. The beauty of HS is that you can mix and match technologies, both old and new. You just need the correct hardware interface and the HS plug-in. My advice is to start simple - just get the x-10 stuff working before moving on to other things. And do lots of reading in the sub forums here.

    You need to start HS3 and install the CM15A plug-in from the Legacy section in the Updater list. You can find it by going into Plugin-Manage. From there, and assuming the CM15A is hooked up to the Troller, you should be able to add devices.

    Barry

    Comment


      #3
      Originally posted by lhfarm View Post
      And do lots of reading in the sub forums here.
      I totally agree with Barry, but want to emphasize the sticky posts, especially the last one. It's really important to follow those instructions.

      Also a caution: There is an intermittent bug that affects some people more than others.
      The bug is that when you click on the '+' symbol to create a new device, sometimes the window to do that fails to open and you just get an un-formatted new device. Unfortunately, when that happens you cannot use the device as a new X10 device. The only remedy is to keep trying until you get the new device window to stay open. Then follow the instructions for creating an X10 device. Once you have one X10 device created, I find it much easier to simply copy that device and edit the copy to get additional devices.

      Mike____________________________________________________________ __________________
      HS3 Pro Edition 3.0.0.548, NUC i3

      HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

      Comment


        #4
        It's been a long time but isn't there a USB driver required for the CM15A? I don't remember if Windows finds it or if I had to go hunt for it.
        Other than that, as said already, the plugin is really all you'll need to get going.
        Real courage is not securing your Wi-Fi network.

        Comment


          #5
          Originally posted by toolmanflowers View Post
          I have been using X-10 technology for many years and have many devices and switches already in place. I purchased a Hometroller SEL with HS3 a few years ago but never got around to figuring out how to integrate the X-10 technology with the Hometroller platform. I would again like to try to get this setup, but according to HomeSeer they do not support the legacy X-10 and they pointed me to this forum. I would also like to get all this integrated up with my Alexa and other wireless technology that I have acquired.
          But for now - can someone please help figure out way I need to do to get this all rolling. I'm pretty certain that I have all the hardware I need to do this, but am missing/unsure of the software and plug-ins that I need and how to get everything setup and working. I bought the Hometroller specifically because I thought they would be available to help with getting this all setup, but it appears that is no longer the case...

          Here is a list of the hardware that I have:
          Hometroller SEL with HS3 (is there a reason that I might want to upgrade to HS3 Pro or HS4/Pro?)
          CM15A (but no software with this)
          PowerLinc Modem #2413U
          TM751 and RR501 Transceivers
          DSC IT-100
          Assorted X-10 appliance and lamp modules
          Assorted X10 switches and outlets
          Assorted Amazon Echo, Dots, Tap, and Shows
          TP-Link Casa Smart WiFi Plug
          EcoBee Smart Thermostat
          Phillips Hue Bridge
          Plillips Hue Lighting
          Welcome to HomeSeer and the X10 forum! As others have already noted, all that you need are your Hometroller, CM15a and your X10 devices. Once your Hometroller is running, add the CM15a plugin from the Manage Plugins page / Legacy section. The plugin should install the appropriate Linux driver (mochad) for the CM15a and then you should be able to add X10 devices to HS3. Please be sure to read this sticky post before adding any X10 devices: https://forums.homeseer.com/forum/li...very-important

          Just a note that the PowerLinc Modem is not supported by the CM15a or X10 plugins.

          Integration with Alexa, etc. is handled by HS3 and does not involve the CM15a plugin.
          Best regards,
          -Mark-

          If you're not out on the edge, you're taking up too much room!
          Interested in 3D maps? Check out my company site: Solid Terrain Modeling

          Comment


            #6
            Originally posted by Uncle Michael View Post
            I totally agree with Barry, but want to emphasize the sticky posts, especially the last one. It's really important to follow those instructions.

            Also a caution: There is an intermittent bug that affects some people more than others.
            The bug is that when you click on the '+' symbol to create a new device, sometimes the window to do that fails to open and you just get an un-formatted new device. Unfortunately, when that happens you cannot use the device as a new X10 device. The only remedy is to keep trying until you get the new device window to stay open. Then follow the instructions for creating an X10 device. Once you have one X10 device created, I find it much easier to simply copy that device and edit the copy to get additional devices.
            I just purchased a Zee S2 and am glad i stumbled upon this post as I was scratching my head trying to figure out how to add my legacy X10 devices. I cannot get the new device window to appear, as you say. It just creates the unformatted new device. Has anyone found a work around for this issue yet? Also, where can i find the specific instructions for adding an X10 Device?

            Thanks in advance!

            Comment


              #7
              Originally posted by steve.lee View Post

              I just purchased a Zee S2 and am glad i stumbled upon this post as I was scratching my head trying to figure out how to add my legacy X10 devices. I cannot get the new device window to appear, as you say. It just creates the unformatted new device. Has anyone found a work around for this issue yet? Also, where can i find the specific instructions for adding an X10 Device?

              Thanks in advance!
              Try the following:
              1) On the device menu page, deselect all device types, except X10.
              2) On the device menu page, set "Floor" and "Room" to all (I do this, because the program sometimes sends the new device to "Unknown" floor and "Unknown" room).
              3) Then, click + sign to add new device.
              Elliott

              Comment


                #8
                Originally posted by steve.lee View Post

                I just purchased a Zee S2 and am glad i stumbled upon this post as I was scratching my head trying to figure out how to add my legacy X10 devices. I cannot get the new device window to appear, as you say. It just creates the unformatted new device. Has anyone found a work around for this issue yet? Also, where can i find the specific instructions for adding an X10 Device?

                Thanks in advance!
                Be sure that you have installed the X10 plugin, HS does not support X10 without using the appropriate plugin for your X10 interface hardware - note that there are 3 different X10 plugins for different interfaces!

                Instructions to add a new device are here: https://forums.homeseer.com/forum/li...very-important

                You will also want to install the latest beta version of the plugin, and that can be found here: https://forums.homeseer.com/forum/li...-beta-releases
                Best regards,
                -Mark-

                If you're not out on the edge, you're taking up too much room!
                Interested in 3D maps? Check out my company site: Solid Terrain Modeling

                Comment

                Working...
                X