Announcement

Collapse
No announcement yet.

X10 dead after a rebuild

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    X10 dead after a rebuild

    I've recently had to rebuild my HS2 Pi zee s2 (3.0.0.548), after having a memory chip failure. Almost all of my system is working again, except for my X10. I previously had migrated everything I could from X10 to Zwave years ago, but have just a couple devices remaining.

    I have a TI103, connected with a USB->Serial adapter. The X10 plugin software I've been trying to load is the 3.0.0.46. I have no idea what my old X10 plugin release was, but it most likely was a year old or so version.

    I've tried everything I can think of or find in the forums that I thought might be relevant.

    The plugin appears to install and load okay (have done this numerous times in attempt to resolve this), and shows OK as it's status. I am getting the previously forum mentioned problem of error message X10 error Ti103 com thread loop. I obviously don't know the secret handshake, as I can't find the .48 beta version anywhere to try. For that matter, can't find an older version either.

    I have deleted and rebuilt the HS device, and that all looks okay.

    I did find an old post which talked about a zwave and x10 compatibility problem when reloading a system....something to the effect that the zwave had to be disabled with the x10 plugin loaded first, and then enable the zwave. Tried that process, which had no change in symptoms.

    So I'm really not sure how to go about trouble shooting this any further, or trying a different x10 plugin. Any guidance? Thanks in advance.


    ++EDITED++ I found where the beta releases are stored here in the forums. If I was stil running my Windows version I'd have no problem doing that upgrade. I'm not sure I'm Linux smart enough to try it, but will try later tonight. I'm hoping I can take the chip out of the Pi, bring it over to my windows system and do the upgrade.

    #2
    Hi Dave,

    Glad you found the beta release section! You can download the .zip file to your Window machine, unzip, copy the .exe to a thumb drive, plug that into your Zee then from a command prompt (on the Zee) copy the exe to your HS dir. Then restart the plugin. I would install the latest beta version (v.48) as it includes support for HS4 and tweaks tot he Ti103 logging code.

    The Ti103 "error" message is really a debug message that was not reclassified to a debug message. The fact that you are seeing those indicates that the plugin is resolving the issue. This logging "issue" was addressed in v.47 as you can see in the release notes.

    I am not aware of any Zwave vs X10 plugin issues and all recent versions of the plugin (last 5 years) should work with your existing devices and events in HS.

    Is the plugin working? Can you control your X10 devices?
    Best regards,
    -Mark-

    If you're not out on the edge, you're taking up too much room!
    Interested in 3D maps? Check out my company site: Solid Terrain Modeling

    Comment

    Working...
    X