No announcement yet.

X10 with HS4 presets not working

  • Filter
  • Time
  • Show
Clear All
new posts

    X10 with HS4 presets not working

    I have many Lightolier Compose switches in my home. They all work perfectly by themselves. I've been using Homeseer for many years and have been extremely happy with it. I recently upgraded to HS4. all of my devices carried over without a problem and I can operate them manually and through events in homeseer with the following exception. I have created preset dim buttons on some devices, mimicking scene selections. This all worked fine in HS3. In HS4 I can operate the scenes through events and I can operate the scenes if I use the drop down menu or slide control. The problem is with the buttons I have created, when I press the button it send an all off command for the entire house code. So for example, I use house codes A and C mostly for lighting. My livingroom is House code C device code 11. I have 4 preset values set in addition to the on and off buttons. they are 6, 9, 12 and 16 which correspond with my A, B, C and D presets. When I press any of the A, B, C, or D it send the following command: 1/4/2021 8:54:52 PM
    X10 INFO
    SendX10: C Cmd: 0 Dim: 0 Data1/2: 0/0
    This turns off all house code C devices.

    The proper command for the C button or 12 value is: 1/4/2021 5:26:19 PM
    X10 INFO
    SendX10: C10 Cmd: 10 Dim: 4 Data1/2: 0/0

    I have tried everything I can think of recreating the device with every number of option combinations such as appliance, standard, preset and extended preset. along with every combination of available values in the Status/Graphics menus.
    System ProfileDate/time=1/5/2021 7:26:38 PM Eastern Standard Time
    Version=HS4 Pro Edition (Windows)
    License ID=666073
    MyHS Subscription=Basic
    MyHS Subscription Backup Interval=No Backup
    MyHS Subscription Max Cameras=1
    Confguration File=C:\Program Files\HomeSeer HS4\Data\HomeSeerData.json
    In Virtual Machine=No MFG: shuttle inc.
    OS=Microsoft Windows Embedded Standard - Work Station
    OS Version=6.1.7601
    Uptime=2 Days 4 Hours 24 Minutes 50 Seconds
    User/Access=richfd (Admin)
    Lan IP= (hometroller)
    Client IP= (DESKTOP-HIVT00D)
    WAN IP= ()
    Device Count=76
    Event Count=50
    Last Event Ran=Device Value Change : 2nd Floor Hall Lights via Motion, Ran at 1/5/2021 6:44:12 PM
    1. of unique event scripts=1
      Connected Speaker Clients=HOMETROLLER (
      Processor:=x64 Family 6 Model 58 Stepping 9 at 738.14 MHz
      Modules/Threads=117 Modules, 68 Threads
      Available Threads=1023
      System Load=60 Processes, 8% Load
      Free/Total Memory=2.47 GBytes / 3.41 GBytes (72% free)
      Free/Total Virtual Memory=5.85 GBytes / 6.81 GBytes (86% free)
      HomeSeer Memory Used=80 Mbytes
      Plugin Memory Used=5 EXE Plug-Ins using 172 Mbytes
      Plugins Installed=GTS CPUXA 3.5.16105.96,SimpleRF,Wemo,X10,Z-Wave
    PlatformS Series

    Hello Richfd,

    The problem is with the buttons I have created, when I press the button it send an all off command for the entire house code.
    Can you please elaborate on these 'buttons' you refer to? Are these on your Compose devices, in HS or?? How do they interact with the HS device or the X10 plugin?

    Best regards,
    Best regards,

    If you're not out on the edge, you're taking up too much room!
    Interested in 3D maps? Check out my company site: Solid Terrain Modeling