Announcement

Collapse
No announcement yet.

Status update on devices are not well updated...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Status update on devices are not well updated...

    So I have been playing around with turning logging off on all devices (have a script for that, someone here on the forum is the father of that script - works perfectly), and also the main checkbox for logging on the Z-wave plugin config turned off. Then I waited to see what was affected, and well no of my wallswitches (Fibaro 1/2 switches and dimmers) seems to update IF someone manually changes something. This used to work, and some of my scripts depend on it. So somewhere I have made an error...

    Now if I turn on polling again, well that did not change anything.
    I turned on Logging on all devices - no difference.
    Adding a polling intervall will update status - when that intervall occurs.
    Adding an event that triggers a polling of the root device - well that works too.
    I have Associations standard as when included - that is Homeseer on group 1,2 and 3, and endpoint 1 and 2 (I have no idea what endpoint in this case refers to).

    However no matter what I do, it is like I can not get automatic status updates to work if someone manually changes for example a Fibaro 1 channel 3kW switch.

    What am I doing wrong here?

  • #2
    Seems like you might be using "logging" and "polling" as the same thing. Logging is what HS system does when it writes entries to the System Log(you can inhibit logging on a device by device basis). Polling is when you, or the HS system, send a command to a device to inquire about it's state(i. e. on or off).

    If devices are "associated" properly with HS(usually automatically setup when you "include" a device) and you manually change the physical device(i.e. a light switch), AT the device, a message will be sent back to HS to change the state of the device there so as to match the physical switch. This will always occur if the physical device has a property called "instant status".
    On devices without instant status, that are directly communicating(NO hops)) with the controller, HS will often be able to sense the change and reflect it properly in the HS device. So first check if your devices(Fibro) have instant status. If they do HS should see changes; If not are they DIRECTLY communicating; If still not working you can use an Event to periodically poll the device, but be cautious to poll infrequently(>every several minutes) or you can overwhelm the Z-wave system.

    Comment


    • #3
      First: I do know the difference between logging and polling (I used to work as a Linux Sysadm, so logging yes I know a lot about that, polling status from a device is therefore not the same - however the exact process in polling z-wave devices I do not know).

      I have two Z-Wave devices: node 23 and node 27. Node 23 is the hallway single switch, Node 27 is the bathroom double switch. Both are from Fibaro, both are on the same firmware level, and both have the same command classes. Se picture below.

      Now Node 27 works all the time, it pushes up the updated status to the controller.
      However Node 23 never does this.
      The only difference is that 23 is a 1*3kW single switch, and 27 is a 2*1.5kW double switch. Apart from that I have no clue.
      And yes, the node 23 used to work before I turned off logging and turned off polling.
      Both are identical when it comes to associated setup.
      I have more devices that do not work, so the above are just examples.

      Click image for larger version  Name:	node2327.jpg Views:	2 Size:	202.5 KB ID:	1266720

      Comment


      • #4
        Looking at the firmware version information in your post (which shows ZDK 4.54.1) as well as the data rate (40 kbps) it looks to me like your switches are not Z-Wave Plus, but are "older" style Z-Wave switches. The older switches required polling in order for the status to be updated (so the information about setting associations that was in the prior posts doesn't apply).

        If you want instant status update and want to avoid polling, you would need to put more up-to-date Z-Wave switches in place - (typically, Z-Wave Plus switches have a ZDK version of 6 or higher). You'll also want to check your controller to make sure it is Z-Wave plus.

        Comment


        • #5
          Well that is news to me, since the node27 does work with instant status update - and node23 does not. Both on same firmware.

          Comment


          • #6
            I'm have the same situation. I have aroundbout 35 GE wall dimmers and switches with only 6 being z-wave plus but yet all but 4 will instant update. I would like to create an event based on the status of one of them but since it doesn't instant update it's useless. I have polling off and would rather not poll the individual device either so I gave up on creating the event.

            Comment


            • #7
              Originally posted by larhedse View Post
              Well that is news to me, since the node27 does work with instant status update - and node23 does not. Both on same firmware.
              Sorry, my oversight, I now see you are in Sweden - In the US, many of the pre-ZWave plus switches didn't have instant status due to a Lutron patent which has now expired - my understanding, at least for US devices, was that around the Z-Wave plus time, we got instant status due to the patent expiration. So then Sorry, my prior post was my best guess for your situation.

              Comment


              • #8
                No Worries,

                I have decided to "solve" this by polling the devices that do not work every 15 seconds - they are not that important that I need instant status, however instant would have been nice and reduce z-wave traffic.

                Comment


                • #9
                  Old thread - still same problem. Although I have figured out, the hard way, that node 27 above ony indicates when switch 2 is used - it does not monitor when switch 1 in the 2*1.5kW switch is used. And the same is for my other 1*3kW switches, which of course only uses switch one.

                  So HomeSeer does not record when switch one is used - only when switch two is used - and that of course is wrong.

                  Comment


                  • #10
                    Just to be clear? If one uses S2 on a Fibaro switch 1*3kW, it works. One can trigger an event just as it is supposed to work. So a work around for single switches is connect the external breake to S2 instead of S1, trigger events when S2 changes status to mirror that change to S1. Not perfect, however it does work.

                    Comment

                    Working...
                    X