Announcement

Collapse
No announcement yet.

z-wave lock management (No more user codes, max is -1)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • z-wave lock management (No more user codes, max is -1)

    I'm having problems adding user pin codes via the z-wave lock management screen.

    I was able to add one code to each lock, but upon trying to add a second pin code, I get either
    "No more user codes, max is -1"
    or
    "No more user codes, max is 0"

    Click image for larger version

Name:	homeseer-zwave.jpg
Views:	40
Size:	37.1 KB
ID:	1299134
    Joe (zimmer62)

    BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

  • #2
    There is a function in the z-wave plugin that asks the lock for the number of pin codes supported. Your lock must not be returning a proper value for it. What type of lock is it? You could try the following script and see what it returns or whether you get an error.

    Code:
    Sub Main(parms As String)
        Dim ConfigResult As String = ""
        ConfigResult = hs.PluginFunction("Z-Wave", "", "LockUserCodesMax", {NodeID,InterfaceID})
        hs.WriteLog("Lock Check",ConfigResult)
    End Sub
    Replace NodeID with the z-wave node # for your lock, and the InterfaceID with the value found in z-wave.ini
    HS 3.0.0.548: 1970 Devices 1149 Events
    Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

    Comment


    • #3
      Code:
      Sub Main(Parm As Object)
          Dim ConfigResult As String = "" 
          Dim InterfaceID As String = hs.GetINISetting("Interfaces", "IFace_0_Unique", "", "Z-Wave.ini")
          Dim NodeID As String = "24"
          ConfigResult = hs.PluginFunction("Z-Wave", "", "LockUserCodesMax", {NodeID,InterfaceID})     
          hs.WriteLog("Lock Check",ConfigResult)
      End Sub
      The result for this lock is -1
      Lock Check { "Response":"-1" }

      The other lock node reports:
      Lock Check { "Response":"0" }
      So that's clearly why it's doing that...

      The locks show up as these:
      24 Full Name: Node 24 Z-Wave IR Security Safety Entry Control Polling: Polling Disabled
      Manufacturer:
      Ingersoll Rand Security & Safety
      Type:
      0x6341
      ID:
      0x5044
      Listens:
      Yes (Beam 1000ms)
      Version: 3.42 (ZDK 4.54.1) Firmware: 113.22 Neighbor Count:
      8
      Speed:
      40Kbps
      Neighbors: 5, 6, 13, 15, 16, 17, 19, 23
      Last Working Route: 15 (40K) Set Route:
      Uses Interface: Z-NET (1) Basic Type: ROUTING SLAVE, Generic Type: ENTRY CONTROL, Specific Type: SECURE KEYPAD DOOR LOCK
      Command Classes:
      Supported: Application Status(V 1), Manufacturer Specific, Firmware Update Md, Security, Version
      Supported Secure: Antitheft, Association, Basic, Battery(Ver 1), Configuration, Door Lock(Ver 2), Notification(Ver 3), User Code
      Child Device: Application Status CC: Application Status Polling: Polling Disabled
      Child Device: Battery CC: Battery Polling: Polling Interval: 12h, 0m, 0s
      Child Device: Door Lock CC: Door Lock Ver: 2 Polling: Polling Interval: 20m, 26s
      Child Device: Access Control Notification CC: Notification Ver: 3 Polling: Polling Disabled
      Child Device: Home Security CC: Notification Ver: 3 Polling: Polling Disabled
      Child Device: Power Management Notification CC: Notification Ver: 3 Polling: Polling Disabled
      Child Device: System Notification CC: Notification Ver: 3 Polling: Polling Disabled

      2 Full Name: Node 2 Z-Wave IR Security Safety Entry Control Polling: Polling Disabled
      Manufacturer:
      Ingersoll Rand Security & Safety
      Type:
      0x6341
      ID:
      0x5044
      Listens:
      Yes (Beam 1000ms)
      Version: 3.42 (ZDK 4.54.1) Firmware: 128.22 Neighbor Count:
      7
      Speed:
      40Kbps
      Neighbors: 1, 5, 6, 13, 15, 17, 19
      Last Working Route: Direct (40K) Set Route:
      Uses Interface: Z-NET (May change next Optimize) Basic Type: ROUTING SLAVE, Generic Type: ENTRY CONTROL, Specific Type: SECURE KEYPAD DOOR LOCK
      Command Classes:
      Supported: Application Status(V 1), Manufacturer Specific, Firmware Update Md, Security, Version
      Supported Secure: Antitheft, Association, Basic, Battery(Ver 1), Configuration, Door Lock(Ver 2), Notification(Ver 3), User Code


      I thought they were the same model, I just went back to Amazon to confirm what they were:

      Node 2, the amazon description said BE469 CAM 716 (BE469NXCAM716)

      Node 24, it's either the BE369NXCAM619 or the BE469NX-CAMRF I have a couple that I didn't install yet, so it was one of those and I can't check until I get home tonight.

      I have 3 more to install, that are likely the BE469NX-CAMRF but I don't want to touch them until I've got these two locks working right.



      Joe (zimmer62)

      BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

      Comment


      • #4
        What version of the z-wave plugin are you running? If not the latest beta, give that a try. Supposedly there were some fixes in the plugin for the BE469 locks recently.
        HS 3.0.0.548: 1970 Devices 1149 Events
        Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

        Comment


        • #5
          3.0.1.261, which appears to be the latest beta.
          Joe (zimmer62)

          BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

          Comment


          • #6
            Originally posted by zimmer62 View Post
            3.0.1.261, which appears to be the latest beta.
            In that case, I would email support@homeseer.com to generate a help desk ticket.
            HS 3.0.0.548: 1970 Devices 1149 Events
            Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

            Comment


            • #7
              Solved...
              In all likely hood, the znet was too far when adding the locks the first time. Strange that it worked and there was no glaring indication that it only sorta worked.

              I added the first lock last summer and I know my znet was within 10 feet, whichever. Removing both locks and re-adding them worked.

              This time I moved the znet to battery power and looped it around the door knob while I dropped and re-added.
              Joe (zimmer62)

              BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

              Comment

              Working...
              X