Announcement

Collapse
No announcement yet.

SmartStick+ Errors - API Transmit Queue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SmartStick+ Errors - API Transmit Queue

    I switched from the ZTroller to the new smartstick+ yesterday. I started receiving errors and devices stop responding. I upgraded to the latest beta of the zwave plugin and I am running HS3 .206 but still the error starts filling up the log.

    I knew I should have stayed on the ztroller!.

    Oct-04 12:59:31 PM Z-Wave Error SmartStick+: Error, the Z-Wave API Transmit Queue is not empty after waiting 20 seconds - the interface may be disconnected or not operational (SmartStick+).
    Oct-04 12:58:31 PM Z-Wave Error SmartStick+: Error, the Z-Wave API Transmit Queue is not empty after waiting 20 seconds - the interface may be disconnected or not operational (SmartStick+).
    Oct-04 12:57:31 PM Z-Wave Error SmartStick+: Error, the Z-Wave API Transmit Queue is not empty after waiting 20 seconds - the interface may be disconnected or not operational (SmartStick+).

  • #2
    Do you have the Stick on a dedicated USB port. It appears that the stick is not being detected from time to time and this can happen if the stick doesn't have enough power. My suggestion would be to add a USB powered hub which will give you more power for the device and allow you to get the device away from the PC giving you much improved range.
    -Rupp
    sigpic

    Comment


    • #3
      Rupp

      Yes, it is plugged directly into the PC. The Ztroller was plugged into the same port with no issues

      -Mike


      Sent from my iPhone using Tapatalk

      Comment


      • #4
        Originally posted by mbreeden View Post
        Rupp

        Yes, it is plugged directly into the PC. The Ztroller was plugged into the same port with no issues
        The Sticks need more power than the Z-Troller does. Look at the root hub that the stick is plugged into and see if it's a shared port and possibly splitting power with another USB device.
        -Rupp
        sigpic

        Comment


        • #5
          Originally posted by mbreeden View Post
          I switched from the ZTroller to the new smartstick+ yesterday. I started receiving errors and devices stop responding. I upgraded to the latest beta of the zwave plugin and I am running HS3 .206 but still the error starts filling up the log.

          I knew I should have stayed on the ztroller!.

          Oct-04 12:59:31 PM Z-Wave Error SmartStick+: Error, the Z-Wave API Transmit Queue is not empty after waiting 20 seconds - the interface may be disconnected or not operational (SmartStick+).
          Oct-04 12:58:31 PM Z-Wave Error SmartStick+: Error, the Z-Wave API Transmit Queue is not empty after waiting 20 seconds - the interface may be disconnected or not operational (SmartStick+).
          Oct-04 12:57:31 PM Z-Wave Error SmartStick+: Error, the Z-Wave API Transmit Queue is not empty after waiting 20 seconds - the interface may be disconnected or not operational (SmartStick+).
          That's the first I've seen of this. Two things to try:
          1. Change to Another USB port
          2. Make sure that power mgmt is turned off for your USB Root Hub devices in Windows Device Mgr
          website | products | support | youtube

          Comment


          • #6
            I verified all USB ports on my machine. Power management was turned off. The required power for the device was 1000 or 100 and the USB port had 5000 or 500 available. It does not seem to be a power issue.

            Comment


            • #7
              Have you verified the com port number in Windows Device Manager? Don't just use the same port setting that the Z-Troller was using. That may now be the wrong port

              Sent from my Nexus 4 using Tapatalk
              website | products | support | youtube

              Comment


              • #8
                The com port is set correctly in HS3. What is the proper settings for the com port in Windows? There was nothing in the instructions on the com port settings!


                Sent from my iPhone using Tapatalk

                Comment


                • #9
                  Originally posted by mbreeden View Post
                  The com port is set correctly in HS3. What is the proper settings for the com port in Windows? There was nothing in the instructions on the com port settings!


                  Sent from my iPhone using Tapatalk
                  Open the Windows Device Manager and expand the section "Ports (COM & LPT). Look for the UZB entry. That will indicate the correct COM port setting. In this example, it's COM6. Then be sure to choose COM6 when setting up the interface and make sure the interface is enabled (with green check mark)
                  Attached Files
                  website | products | support | youtube

                  Comment


                  • #10
                    Mark:

                    I have no issues with the smartstick working with HS3. The systems see the device and it can control my z-wave network. The issue is that I am getting those errors frequently!! Some times to the point that I have to restart HS3 and the Server to get them responding properly.

                    I have had no issues with my network since moving to HS3 and the ZTroller. This issue happened when I move to the new interface

                    The com port setting in windows is 9600, 8, none none, should that be set differently?

                    - Mike

                    Comment


                    • #11
                      Originally posted by mbreeden View Post
                      Mark:

                      I have no issues with the smartstick working with HS3. The systems see the device and it can control my z-wave network. The issue is that I am getting those errors frequently!! Some times to the point that I have to restart HS3 and the Server to get them responding properly.

                      I have had no issues with my network since moving to HS3 and the ZTroller. This issue happened when I move to the new interface

                      The com port setting in windows is 9600, 8, none none, should that be set differently?

                      - Mike
                      try these:
                      Attached Files
                      website | products | support | youtube

                      Comment


                      • #12
                        All settings are correct. Still seeing same issues


                        Sent from my iPhone using Tapatalk

                        Comment


                        • #13
                          I would suggest reinstalling the drivers: http://homeseer.com/updates3/SmartStickPlusDriver.zip

                          If that doesn't work, then you may have a defective stick.
                          website | products | support | youtube

                          Comment


                          • #14
                            Mark:

                            Sorry was out of town for a few days. I verified that I have the most up to date driver. (per your link). I deleted it from the PC and reinstalled. I will monitor it from now on. I did notice that I am now getting these messages in my log:

                            Z-Wave Warning SmartStick+ : Secure message received from node 114 but the data length is too short. (Not Processed)

                            I seem to be getting them from my door locks and Garage door device. They appear by themselves and with intermixed with the original error.

                            - Mike

                            Comment


                            • #15
                              Can you post your message board support profile per this vid?
                              https://youtu.be/MF6wRAdD7hY
                              website | products | support | youtube

                              Comment

                              Working...
                              X