Announcement

Collapse
No announcement yet.

Error on install.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • alexbk66
    replied
    Mr.Gadget https://forums.homeseer.com/forum/de...read-carefully

    Leave a comment:


  • alexbk66
    replied
    Please post your comments:
    https://forums.homeseer.com/forum/ho...-updating-mono

    Leave a comment:


  • alexbk66
    replied
    Mr.Gadget - the problem with SEL Mono version is well known as I found. There's a lot of discussions on HS forum.

    https://forums.homeseer.com/forum/ho...89#post1284089

    points to https://www.google.com/url?q=https:/...QfCNbuQxXBSEsA

    If you make this work - I better remove the system libraries from my install

    Leave a comment:


  • alexbk66
    replied
    Originally posted by Mr.Gadget View Post
    homeseer@hometrollerSEL:/usr/local/HomeSeer$ sudo updatedb
    homeseer@hometrollerSEL:/usr/local/HomeSeer$ locate System.Runtime.dll
    /usr/local/HomeSeer/Temp/System.Runtime.dll
    /usr/local/HomeSeer/bin/AKGoogleCast/System.Runtime.dll
    /usr/local/HomeSeer/bin/Nest/System.Runtime.dll
    It looks like you don't have System.Runtime.dll at all - only in HS. Strange.

    [EDIT]

    I checked the plugins which work on your system - they all target .NET 4.0 - which is very old. Google libraries minimum version support 4.6.

    IMHO it's completely stupid to choose Linux for .NET app...

    Leave a comment:


  • alexbk66
    replied
    https://forums.homeseer.com/forum/me...after-changing

    Leave a comment:


  • alexbk66
    replied
    Originally posted by Mr.Gadget View Post
    Thanks for the redirect to the Intro..

    The system event APPEARS to be functional now. I had CAST instead of SPEAK selected. Now I need to look into how I can put it to good uses...

    Also, assuming we (you) found all the dependencies for the various DLL files, I'm hoping it doesn't complain about anything missing now. I'll keep a watch on the logs to see if anything else is broken/missing. If so, I'll be sure to send the logs your way. I know the SIRIUSXM metadata seems to be an issue, but that will be addressed in another thread.

    Thanks again for getting these INSTALL issues corrected. Great Work!!!
    INSTALL issues I still need to investigate - because it's not normal to supply .NET system libraries.

    The CAST action is used to send urls to the Google devices. For TTS just use normal HS "Speak" action - because the plugin registers as SPEECH client.

    Leave a comment:


  • Mr.Gadget
    replied
    Thanks for the redirect to the Intro..

    The system event APPEARS to be functional now. I had CAST instead of SPEAK selected. Now I need to look into how I can put it to good uses...

    Also, assuming we (you) found all the dependencies for the various DLL files, I'm hoping it doesn't complain about anything missing now. I'll keep a watch on the logs to see if anything else is broken/missing. If so, I'll be sure to send the logs your way. I know the SIRIUSXM metadata seems to be an issue, but that will be addressed in another thread.


    Thanks again for getting these INSTALL issues corrected. Great Work!!!

    Leave a comment:


  • alexbk66
    replied
    Originally posted by Mr.Gadget View Post
    This is probably my error and lack of understanding the functionality. I don't know what settings I need to have to make it do anything.Still checking other forums to try to determine how to use this TTS feature.
    You can ask me, just explain what you want to achieve and post your screenshots - so I can see what you are doing.

    Again, probably for this better thread is https://forums.homeseer.com/forum/me...e-introduction

    Leave a comment:


  • Mr.Gadget
    replied
    homeseer@hometrollerSEL:/usr/local/HomeSeer$ sudo updatedb
    homeseer@hometrollerSEL:/usr/local/HomeSeer$ locate System.Runtime.dll
    /usr/local/HomeSeer/Temp/System.Runtime.dll
    /usr/local/HomeSeer/bin/AKGoogleCast/System.Runtime.dll
    /usr/local/HomeSeer/bin/Nest/System.Runtime.dll

    It says "Action of GoogleCast: Cast Media could not be carried out because its configuration is not complete" - so it's the problem with the event setup - please check/post here.
    This is probably my error and lack of understanding the functionality. I don't know what settings I need to have to make it do anything.Still checking other forums to try to determine how to use this TTS feature.

    Leave a comment:


  • alexbk66
    replied
    It says "Action of GoogleCast: Cast Media could not be carried out because its configuration is not complete" - so it's the problem with the event setup - please check/post here.

    Also, for Mono issue, please do the following and post the output:

    sudo updatedb
    locate System.Runtime.dll

    Leave a comment:


  • Mr.Gadget
    replied
    Plug-Ins Enabled:
    SonyTV v3.0.0.6:,X10 v3.0.0.46:,Z-Wave v3.0.2.0:,BLOnkyo v2.0.66.0:,AK GoogleCast v3.0.0.39:


    Unsure how to test the Google Home Mini Speaker - But, I didn't get the same error as before, and I did hear a "gong" on the speaker.

    Apr-17 7:53:53 AM AK GoogleCast ERROR [234]: MediaChannel ErrorReceived: SharpCaster.Channels.MediaChannel: LOAD_FAILED : (Pam's Office speaker): [HSPI_AKGoogleCast.SpeakerGoogleTransl]
    Apr-17 7:53:53 AM AK GoogleCast [234]: * Media changed: (Pam's Office speaker)
    Apr-17 7:53:53 AM AK GoogleCast [234]: * Application started: Default Media Receiver (CC1AD845) (Pam's Office speaker)
    Apr-17 7:53:51 AM AK GoogleCast [234]: Send media: (Pam's Office speaker)
    Apr-17 7:53:51 AM AK GoogleCast [234]: LoadMedia: Pam's Office speaker: ()
    Apr-17 7:53:51 AM Event Event TEST Event AKGC TTS1, Action of GoogleCast: Cast Media could not be carried out because its configuration is not complete.
    Apr-17 7:53:51 AM Event Event Trigger "TEST Event AKGC TTS1"
    Apr-17 7:53:51 AM Event Event TEST Event AKGC TTS1 triggered by the event page 'Run' button.
    Attached Files

    Leave a comment:


  • alexbk66
    replied
    And what other plugins do you have working? I can check their settings.

    Leave a comment:


  • alexbk66
    replied
    Can you please check what versions you have
    [EDIT]

    Code:
    gacutil -l | grep System.Runtime

    Leave a comment:


  • alexbk66
    replied
    Originally posted by Mr.Gadget View Post
    Testing a few other features. Not sure if they are working correctly or not. On the AKGC Config page, If I select the "Enable" or "Log" checkbox on a speaker, it unchecks, then returns Checked a short while later.

    Also, When i enabled the "Group" feature, It threw an error, and unchecked again a short while later: [TABLE="class: log_table_row, cellspacing: 0"]
    System.Resources.ResourceManager.dll.zip

    Leave a comment:


  • Mr.Gadget
    replied
    Testing a few other features. Not sure if they are working correctly or not. On the AKGC Config page, If I select the "Enable" or "Log" checkbox on a speaker, it unchecks, then returns Checked a short while later.

    Also, When i enabled the "Group" feature, It threw an error, and unchecked again a short while later:
    Apr-16 7:43:52 PM Error Posting back to plugin web page AKGoogleCast_Config_Page: Could not load file or assembly 'System.Resources.ResourceManager, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.-> Server stack trace: Exception rethrown at [0]: at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr) at (wrapper remoting-invoke) HomeSeerAPI.IPlugInAPI:PostBackProc (string,string,string,int) at Scheduler.proxyPage.postBackProc (Scheduler.StateObject& state, System.String Data) [0x00036] in <9d0c99dc968a48469ec86efcf4ea6794>:0

    Leave a comment:

Working...
X