Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Dynamic speaker client groups

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Originally posted by cc4005 View Post

    Not really--not the functionality I need anyway. I want the device to function normally in all other ways, just prevent TTS messages from being sent to it. I hadn't thought about your current implementation disabling other uses of the minis.

    Back to the thinking of it another way...another idea...Perhaps when speaker groups are found by the PI a flag (e.g. "active") is added that can be set by event. Then in the event speak action the speaker selected is "active" group. It would change depending on which group had the flag set. That way we're only changing a specific TTS action, not the device settings themselves. Might that be possible?
    Or perhaps if the current enable/disable could only apply to speak actions? Or is that already the case?
    -Wade

    Comment


    • #47
      Originally posted by cc4005 View Post

      Or perhaps if the current enable/disable could only apply to speak actions? Or is that already the case?
      Yeah enable/disable HS device only controls TTS.

      Click image for larger version

Name:	enabletts.jpg
Views:	32
Size:	7.6 KB
ID:	1341928

      But the "Enable" setting on plugin configuration page disables the Chromecast altogether, i.e. the plugin doesn't attempt to connect to the device at all. And as I remember, the HS devices for this Chromecast become hidden.

      Click image for larger version

Name:	ConfigTemp.png
Views:	36
Size:	54.9 KB
ID:	1341927

      Comment


      • #48
        Originally posted by alexbk66 View Post

        Yeah enable/disable HS device only controls TTS.
        Oh, ok. Perfect. Got what I need there then.

        I'll try to get threads started on the other issues over the next couple days. Thanks.
        -Wade

        Comment


        • #49
          Originally posted by cc4005 View Post

          I've not left it running for any length of time. I use spud's chromecast PI but am testing Alex's because he was quickly able to add the Disable/Enable TTS per device which will be very useful to me. But since I rely on TTS quite a bit and am having other issues with AKGooglecast it I'm not committing so far as to move my TTS events over yet. I'm just stopping the chromecast PI for a short time while testing this one, then swap back
          I have seen it from 2 hours to overnight.

          *** Disclaimer, I was asking because I am having some other issues with my HS set up, and was trying to narrow things down.
          I am currently converting OS, as I think that is a big part of my issues. Going from Windows 10 Pro to Windows Server.

          Comment


          • #50
            Originally posted by Meapilot View Post
            I have seen it from 2 hours to overnight.
            But what exactly is the problem? Not playing TTS after 2 hours inactivity? Anything in logs?

            Again, this issue doesn't belong to this thread - it's to hard to follow now, especially for other users.

            Comment

            Working...
            X