Announcement

Collapse
No announcement yet.

Startup Error - No device Detected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Startup Error - No device Detected

    Trying your plug-in as it appears the other HS3 Chromecast PI is not being supported any longer. That said it appears your PI suffers from the same group problem.

    Perhaps it's due to the error below. (No CCA's are being found in your PI)

    Click image for larger version

Name:	2020-06-28_10-52-02.png
Views:	117
Size:	145.6 KB
ID:	1397369
    RJ_Make On YouTube

    #2
    Originally posted by ServiceXp View Post
    Trying your plug-in as it appears the other HS3 Chromecast PI is not being supported any longer. That said it appears your PI suffers from the same group problem.

    Perhaps it's due to the error below. (No CCA's are being found in your PI)
    1. "PI suffers from the same group problem" - what group problem?
    2. What's CCA?
    3. Can you describe your setup please in more details?

    There's a null reference exception, but not enough info, I need probably to add more logging. But I suspect that "receiver" information is not complete. Which comes from mDNS (Zeroconf).

    Can you also try:

    1. Disabling the plugin
    2. Deleting "C:\Program Files (x86)\HomeSeer HS3\Config\AKGoogleCast.ini" (and AKGoogleCast.ini.bak)
    3. Staring the plugin.

    Comment


      #3

      1. "PI suffers from the same group problem" - what group problem?

      As seen in the screenshot the groups are returning the gateways IP address and the PI is identifying it as invalid (which it is I guess). The groups are working in Chrome on the same machine without issue

      2. What's CCA?

      Chromecast Audio

      3. Can you describe your setup please in more details?

      Full Unifi network via UDM. I have the CCA's on a segregated 2.4 IoT network VLAN. I have IGMP and mDNS enabled. Windows 10 Build 2004


      Can you also try:

      1. Disabling the plugin
      2. Deleting "C:\Program Files (x86)\HomeSeer HS3\Config\AKGoogleCast.ini" (and AKGoogleCast.ini.bak)
      3. Staring the plugin.


      Deleting those files stopped the error that was being produced, however the CCA's are still not being detected. (Assuming the process is completed automatically by the PI?)


      Click image for larger version

Name:	2020-06-28_12-35-44.png
Views:	74
Size:	87.0 KB
ID:	1397404

      Click image for larger version

Name:	2020-06-28_12-36-22.png
Views:	99
Size:	53.5 KB
ID:	1397403

      Thanks for your help.

      RJ_Make On YouTube

      Comment


        #4
        Originally posted by ServiceXp View Post
        1. "PI suffers from the same group problem" - what group problem?

        As seen in the screenshot the groups are returning the gateways IP address and the PI is identifying it as invalid (which it is I guess). The groups are working in Chrome on the same machine without issue

        3. Can you describe your setup please in more details?

        Full Unifi network via UDM. I have the CCA's on a segregated 2.4 IoT network VLAN. I have IGMP and mDNS enabled. Windows 10 Build 2004

        Deleting those files stopped the error that was being produced, however the CCA's are still not being detected. (Assuming the process is completed automatically by the PI?)
        Groups are created on the Chromecast device, so the group has same IP address as the parent Chromecast. Which can be an issue, especially because the "parent" is selected randomly and the IP may change, i.e. if the "parent" is down - then the group will move to another parent.

        For that reason I use the device name as ID, not the IP address. And for that reason every name should be unique.

        It looks like you have three groups on the same IP? I need to check my code, because I tested with only one group.

        Comment


          #5
          Ver. 3.0.0.43 (in BETA) I added more error logging so we have more info what's wrong.

          Note: There's currently some issue with Updater, I logged support request. I can send you the updater zip file if HST don't fix the problem soon.
          Code:
           
          Updater Error saving the downloaded file: error
          Updater Error downloading package :An exception occurred during a WebClient request.

          Comment


            #6
            You might want to attach it as I don't see it yet in the beta section. And to be clear, the current version is not finding the actual CCA's (7 of them) devices either.

            Thanks for your help.

            RJ_Make On YouTube

            Comment


              #7
              Originally posted by ServiceXp View Post
              You might want to attach it as I don't see it yet in the beta section. And to be clear, the current version is not finding the actual CCA's (7 of them) devices either.

              Thanks for your help.
              HST fixed the updater, should be there now.

              What exactly do you mean by "current version is not finding the actual CCA's"? Do you mean mDNS (Zeroconf) doesn't detect them? Did you add them manually then?

              mDNS issues are common for non-standard network setup, the devices should be on the same subnet as your PC. Also you PC might have multiple network adapters, I try to scan them all, but many mDNS libraries just pick the first available.

              You can try running attached ServiceBrowser.exe to verify that your CCA's are discoverable.

              BTW, are they standard Google CCA's? Because I had reports that devices from different manufacturers have issues.

              Also, on my laptop mDNS stops working sometimes and I have to reboot to fix the problem.

              Click image for larger version  Name:	Annotation 2020-06-30 130522.jpg Views:	0 Size:	35.9 KB ID:	1397712

              Comment


                #8
                1) Correct Zeroconf is not detecting any of the Google Chromecast Audios (these are google CCA's)
                2) I do have multiple Network Adapters in Addition to a Network turning card. (See screenshot below)
                3) The CCA's are detectable as the other Chromecast PI detects the them (Just will not detect Groups)
                4) Everything (CCA's and Groups) is detectable using Chrome and casting from the Google Music.
                5) The ServiceBrowser errored out on startup as administrator. (See screenshot below)

                Click image for larger version

Name:	2020-06-30_5-33-53.png
Views:	57
Size:	395.6 KB
ID:	1397774

                Click image for larger version

Name:	2020-06-30_5-38-09.png
Views:	58
Size:	326.7 KB
ID:	1397776

                Click image for larger version

Name:	2020-06-30_5-40-46.png
Views:	67
Size:	9.7 KB
ID:	1397773

                Click image for larger version

Name:	2020-06-30_5-41-42.png
Views:	56
Size:	328.8 KB
ID:	1397775
                RJ_Make On YouTube

                Comment


                  #9
                  Thank you for detailed report, I can see the issue with groups, I'll fix it tomorrow - it's a bit late here in AU

                  Comment


                    #10
                    One question though - my plugin doesn't detect CCA's - but it does detect other devices?

                    Comment


                      #11
                      Originally posted by alexbk66 View Post
                      One question though - my plugin doesn't detect CCA's - but it does detect other devices?
                      No, Nothing. As seen in the screenshot in post #3 above.
                      RJ_Make On YouTube

                      Comment


                        #12
                        Ok, try ver 3.0.0.44 (BETA)

                        May be remove both ini files just in case

                        Comment


                          #13
                          We have the same results, well same results as in nothing is being found in HS. However the debug log looks much much better.

                          AK GoogleCast Connecting to HomeSeer at 127.0.0.1:10400 ...
                          Host ApiVersion : 3
                          Host CB ApiVersion : 3
                          HSPI Connected(True)
                          HSPI Connected(True)
                          Connection to HomeSeer successful. Waiting for InitIO...

                          GetDeviceEnumerator: 398
                          UpdateConfiguration: scheduled
                          InitIO finished - entering main loop
                          Create ResolverListener
                          Running on windows - using Locator.Zeroconf.DeviceLocator

                          _CreateReceiver id='192.168.1.1: Google-Cast-Group-a2ef5b0870a54493ad9439bbe29f5591-1' ip=':42505'; service.Properties:
                          Service: _googlecast._tcp.local. Port: 42505, TTL: 120, PropertySets: 1
                          Begin Property Set #0
                          -------------------
                          id = a2ef5b08-70a5-4493-ad94-39bbe29f5591
                          cd = a2ef5b08-70a5-4493-ad94-39bbe29f5591
                          rm =
                          ve = 05
                          md = Google Cast Group
                          ic = /setup/icon.png
                          fn = House Audio Group
                          ca = 198692
                          st = 0
                          bs = FA8FCA85205E
                          nf = 2
                          rs =
                          -------------------

                          *CreateReceiver: Google-Cast-Group-a2ef5b0870a54493ad9439bbe29f5591-1, :42505
                          CreateReceiver error: id='192.168.1.1: Google-Cast-Group-a2ef5b0870a54493ad9439bbe29f5591-1' (Google-Cast-Group-a2ef5b0870a54493ad9439bbe29f5591-1) addr='' ip='': System.ArgumentNullException: Value cannot be null.
                          Parameter name: ipString
                          at System.Net.IPAddress.InternalParse(String ipString, Boolean tryParse)
                          at SharpCaster.Models.Chromecast.CreateReceiver(String DisplayName, String ip, UInt32 port, IReadOnlyDictionary`2 properties, Boolean useIdKey)
                          at Locator.Zeroconf.DeviceLocator._CreateReceiver(IZeroconfHost host)
                          Locator.Zeroconf.DeviceLocator: CreateReceiver error: id='192.168.1.1: Google-Cast-Group-a2ef5b0870a54493ad9439bbe29f5591-1' (Google-Cast-Group-a2ef5b0870a54493ad9439bbe29f5591-1) addr='' ip='': Value cannot be null.
                          Parameter name: ipString
                          at System.Net.IPAddress.InternalParse(String ipString, Boolean tryParse)
                          at SharpCaster.Models.Chromecast.CreateReceiver(String DisplayName, String ip, UInt32 port, IReadOnlyDictionary`2 properties, Boolean useIdKey)
                          at Locator.Zeroconf.DeviceLocator._CreateReceiver(IZeroconfHost host)

                          _CreateReceiver id='192.168.1.1: Google-Cast-Group-f251a24b0e774492bf4edf46f610800b-1' ip=':42277'; service.Properties:
                          Service: _googlecast._tcp.local. Port: 42277, TTL: 120, PropertySets: 1
                          Begin Property Set #0
                          -------------------
                          id = f251a24b-0e77-4492-bf4e-df46f610800b
                          cd = f251a24b-0e77-4492-bf4e-df46f610800b
                          rm =
                          ve = 05
                          md = Google Cast Group
                          ic = /setup/icon.png
                          fn = Basement Audio Group
                          ca = 198692
                          st = 0
                          bs = FA8FCA85205E
                          nf = 2
                          rs =
                          -------------------

                          *CreateReceiver: Google-Cast-Group-f251a24b0e774492bf4edf46f610800b-1, :42277
                          CreateReceiver error: id='192.168.1.1: Google-Cast-Group-f251a24b0e774492bf4edf46f610800b-1' (Google-Cast-Group-f251a24b0e774492bf4edf46f610800b-1) addr='' ip='': System.ArgumentNullException: Value cannot be null.
                          Parameter name: ipString
                          at System.Net.IPAddress.InternalParse(String ipString, Boolean tryParse)
                          at SharpCaster.Models.Chromecast.CreateReceiver(String DisplayName, String ip, UInt32 port, IReadOnlyDictionary`2 properties, Boolean useIdKey)
                          at Locator.Zeroconf.DeviceLocator._CreateReceiver(IZeroconfHost host)
                          Locator.Zeroconf.DeviceLocator: CreateReceiver error: id='192.168.1.1: Google-Cast-Group-f251a24b0e774492bf4edf46f610800b-1' (Google-Cast-Group-f251a24b0e774492bf4edf46f610800b-1) addr='' ip='': Value cannot be null.
                          Parameter name: ipString
                          at System.Net.IPAddress.InternalParse(String ipString, Boolean tryParse)
                          at SharpCaster.Models.Chromecast.CreateReceiver(String DisplayName, String ip, UInt32 port, IReadOnlyDictionary`2 properties, Boolean useIdKey)
                          at Locator.Zeroconf.DeviceLocator._CreateReceiver(IZeroconfHost host)

                          _CreateReceiver id='192.168.1.1: Google-Cast-Group-f54037988ef241598af3c996aa82ef52' ip=':42498'; service.Properties:
                          Service: _googlecast._tcp.local. Port: 42498, TTL: 120, PropertySets: 1
                          Begin Property Set #0
                          -------------------
                          id = f5403798-8ef2-4159-8af3-c996aa82ef52
                          cd = f5403798-8ef2-4159-8af3-c996aa82ef52
                          rm =
                          ve = 05
                          md = Google Cast Group
                          ic = /setup/icon.png
                          fn = Upstairs Audio Group
                          ca = 198692
                          st = 0
                          bs = FA8FCA801FB9
                          nf = 2
                          rs =
                          -------------------

                          *CreateReceiver: Google-Cast-Group-f54037988ef241598af3c996aa82ef52, :42498
                          CreateReceiver error: id='192.168.1.1: Google-Cast-Group-f54037988ef241598af3c996aa82ef52' (Google-Cast-Group-f54037988ef241598af3c996aa82ef52) addr='' ip='': System.ArgumentNullException: Value cannot be null.
                          Parameter name: ipString
                          at System.Net.IPAddress.InternalParse(String ipString, Boolean tryParse)
                          at SharpCaster.Models.Chromecast.CreateReceiver(String DisplayName, String ip, UInt32 port, IReadOnlyDictionary`2 properties, Boolean useIdKey)
                          at Locator.Zeroconf.DeviceLocator._CreateReceiver(IZeroconfHost host)
                          Locator.Zeroconf.DeviceLocator: CreateReceiver error: id='192.168.1.1: Google-Cast-Group-f54037988ef241598af3c996aa82ef52' (Google-Cast-Group-f54037988ef241598af3c996aa82ef52) addr='' ip='': Value cannot be null.
                          Parameter name: ipString
                          at System.Net.IPAddress.InternalParse(String ipString, Boolean tryParse)
                          at SharpCaster.Models.Chromecast.CreateReceiver(String DisplayName, String ip, UInt32 port, IReadOnlyDictionary`2 properties, Boolean useIdKey)
                          at Locator.Zeroconf.DeviceLocator._CreateReceiver(IZeroconfHost host)
                          RJ_Make On YouTube

                          Comment


                            #14
                            Here's the PI results.

                            Click image for larger version

Name:	2020-07-01 10_45_09-Mozilla Firefox.png
Views:	56
Size:	15.3 KB
ID:	1398063
                            RJ_Make On YouTube

                            Comment


                              #15
                              Could it be that the PI is not finding the network interface that HS is attached too? I had to use Labs to bind HS to the correct adapter.

                              Click image for larger version

Name:	2020-07-01 10_53_58-Setup.png
Views:	57
Size:	41.4 KB
ID:	1398069
                              RJ_Make On YouTube

                              Comment

                              Working...
                              X