Announcement

Collapse
No announcement yet.

Error on new Linux build

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error on new Linux build

    Hi Spud

    I am on a new Linux build and getting an error when starting up HS3. It looks like a problem with Mono, but I have mono-complete installed. So at a loss on what is causing this error.

    ERROR System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running. at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x00264] in <350cc7bac8c6475198007c91dd299fbc>:0 at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider () [0x0000e] in <350cc7bac8c6475198007c91dd299fbc>:0 at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () [0x0000f] in <350cc7bac8c6475198007c91dd299fbc>:0 at Mono.Zeroconf.ServiceBrowser..ctor () [0x00008] in <350cc7bac8c6475198007c91dd299fbc>:0 at HSPI_Chromecast.ChromecastDiscoverer.Start () [0x00000] in :0 at HSPI_Chromecast.ChromecastApp.b__52_0 () [0x0004a] in :0

  • #2
    You need avahi to be installed and running

    Code:
    sudo apt-get install avahi-daemon

    Comment


    • #3
      Arrrghhh ... read the manual! Thanks so much for the quick advice.

      One more thing I need to fix - stopping the PI turning on the TVs on boot. I remember it was discussed in the beta thread, but I am having difficulty finding the instruction or remembering it. I am documenting my build, so hopefully won't need to ask again next time Might be useful to put that in your installation guide.

      Comment


      • #4
        edit Scripts/Startup.vb and remove or comment out the following line

        Code:
        hs.Speak("Web server port number is " & port)
        If you want to keep this TTS to some of your speaker, you will need to add a parameter to the Speak function to target the speakers you want.

        Comment


        • #5
          That was it. Thanks.

          Comment

          Working...
          X