Announcement

Collapse
No announcement yet.

Can't install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't install

    Can someone help me install this plugin?

    When I try downloading the beta from the forum, it says "can't install"

    When I use the HS repository, it says that version 3.0.0.10 is installed but there's no where to enable or pay for it.

    I have other plugins running without a problem.

    I have HS3 running on a Raspberry Pi3

    Thanks,

    Ben

  • #2
    do you have avahi installed and running?
    and did you check that the Mono.CSharp.dll and CSScriptLibrary.dll are in bin and not in the root folder as explained in the user guide

    a good way to troubleshoot this is to manually start the plugin exe from the command line and see what errors it outputs.

    sudo mono HSPI_chromecast.exe

    Comment


    • #3
      Originally posted by spud View Post
      do you have avahi installed and running?
      and did you check that the Mono.CSharp.dll and CSScriptLibrary.dll are in bin and not in the root folder as explained in the user guide

      a good way to troubleshoot this is to manually start the plugin exe from the command line and see what errors it outputs.

      sudo mono HSPI_chromecast.exe
      Hi Spud,

      Thanks for your quick response. I had already done all the requirements in the isntallation (move dll files and install avahi).

      When I run HSPI_Chromecast I get the following:

      Code:
      pi@raspberrypi:/opt/HomeSeer $ sudo mono HSPI_Chromecast.exe
      Plugin: Chromecast Instance:  starting...
      Connecting to server at 127.0.0.1...
      Connection attempt #1
      Cannot connect(2):Object reference not set to an instance of an object
      Does this help you?

      The plugin browser says version 3.0.0.10 is installed but it is not appearing in the list of active plugins. I would love to buy this plugin if I can get it working!

      Sincerely,

      Ben

      Comment


      • #4
        Originally posted by benrjunk View Post
        Hi Spud,

        Thanks for your quick response. I had already done all the requirements in the isntallation (move dll files and install avahi).

        When I run HSPI_Chromecast I get the following:

        Code:
        pi@raspberrypi:/opt/HomeSeer $ sudo mono HSPI_Chromecast.exe
        Plugin: Chromecast Instance:  starting...
        Connecting to server at 127.0.0.1...
        Connection attempt #1
        Cannot connect(2):Object reference not set to an instance of an object
        Does this help you?

        The plugin browser says version 3.0.0.10 is installed but it is not appearing in the list of active plugins. I would love to buy this plugin if I can get it working!

        Sincerely,

        Ben
        when you try to install it from the plugin browser, what do you get in the logs?

        Comment


        • #5
          Here's what I get in the log file:

          Code:
          Jan-05 9:23:41 AM	 	Info	Plugin Chromecast has connected. IP:127.0.0.1:36708
          Jan-05 9:21:39 AM	 	Error	Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Chromecast.exe: The classes in the module cannot be loaded.Warning, Error details with EXE HSPI_Chromecast.exe: Could not load file or assembly or one of its dependencies.
          Jan-05 9:21:38 AM	 	Updater	Install/Update of package Chromecast was successful.
          Jan-05 9:21:38 AM	 	Updater	Extraction Complete.
          Jan-05 9:21:38 AM	 	Updater	Extracting files from zip file: images.zip
          Jan-05 9:21:38 AM	 	Updater Warning	File exists, not overwriting: \opt\HomeSeer\Config\\Chromecast.ini
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\bin\Chromecast\avahi-sharp.dll.config
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\bin\Chromecast\avahi-sharp.dll
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\bin\Chromecast\Mono.Zeroconf.Providers.Avahi.dll
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\bin\Chromecast\Mono.Zeroconf.dll
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\bin\Chromecast\Sockets.Plugin.dll
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\bin\Chromecast\Sockets.Plugin.Abstractions.dll
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\bin\Chromecast\SharpCaster.dll
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\bin\Chromecast\Newtonsoft.Json.dll
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\bin\Chromecast\Google.Protobuf.dll
          Jan-05 9:21:38 AM	 	Updater	Making dir: \opt\HomeSeer\bin\Chromecast\
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\HSPI_Chromecast.exe.config
          Jan-05 9:21:38 AM	 	Updater	Copying file: \opt\HomeSeer\HSPI_Chromecast.exe
          Jan-05 9:21:37 AM	 	Updater	Installing package Chromecast
          Jan-05 9:21:37 AM	 	Updater	Using local file: Chromecast_Linux_3-0-0-10.zip
          Jan-05 9:21:37 AM	 	Updater	Downloading update: Chromecast
          Jan-05 9:21:37 AM	 	Updater	Starting download of updates
          Jan-05 9:21:26 AM	 	Warning	Using updater override file: updtater_override.txt for updates!
          The problem is I have no idea what dependency is missing. See the following:

          Code:
          pi@raspberrypi:~ $ sudo apt-get install avahi-daemon
          Reading package lists... Done
          Building dependency tree       
          Reading state information... Done
          avahi-daemon is already the newest version (0.6.32-2).
          0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
          pi@raspberrypi:~ $ mono --version
          Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)
          Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
          	TLS:           normal
          	SIGSEGV:       normal
          	Notifications: epoll
          	Architecture:  armel,vfp+hard
          	Disabled:      none
          	Misc:          softdebug 
          	LLVM:          supported, not enabled.
          	GC:            sgen
          pi@raspberrypi:~ $ cd /opt/HomeSeer/bin
          pi@raspberrypi:/opt/HomeSeer/bin $ ls
          Chromecast           homeseer          ISYInsteon       System.Data.SQLite.dll
          CSScriptLibrary.dll  HomeSeerUtil.dll  Mono.CSharp.dll

          I still get the same error when I execute from shell:

          Code:
          pi@raspberrypi:/opt/HomeSeer $ sudo mono HSPI_Chromecast.exe
          Plugin: Chromecast Instance:  starting...
          Connecting to server at 127.0.0.1...
          Connection attempt #1
          Cannot connect(2):Object reference not set to an instance of an object
          Thank you very much for your assistance with this.

          Ben

          Comment


          • #6
            please try to start it using the following command and report what you get

            sudo MONO_LOG_LEVEL=debug mono HSPI_Chromecast.exe

            Comment


            • #7
              I get a lot of data. I captured it and attached to this message. I stopped the process after about 30 seconds.

              Ben
              Attached Files

              Comment


              • #8
                Could you try:

                sudo apt-get install mono-complete

                Comment


                • #9
                  Success! Thank you.

                  Next problem - under events, I don't see any Chromecast triggers under If. Is it possible for a playstate change to trigger an action?

                  Thanks,

                  Ben

                  Comment


                  • #10
                    Nevermind, figured that out.

                    Appears under device listing.

                    Thanks for your support!

                    Ben

                    Comment

                    Working...
                    X