Announcement

Collapse
No announcement yet.

Very unstable connection to my Chromecasts!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by ZoRaC View Post

    I think #1 was resolved with .25, but speak-actions now seem to not be working at all anymore on my CCA.

    On the "device list", it states "Connected to <ip>". If I use the Google Home-app on my phone and adjust the volume, the volume-device is updated instantly.
    If I cast an audiostream to the CCA from an event, it works.
    On the "chromecastconfig"-page, the CCA is listed as "Enabled" and "TTS", but not as "Online".
    If I go to "Speak something", the CCA is not listed there as a speaker and trying to use "Gang:*" (which is the correct name listed in the config) as a speaker manually doesn't help either. A simple "hs.speak()"-script isn't working either.

    So it seems to be an TTS-issue.
    "Forward Speak Actions to HS Speakers:" is enabled.
    With debug-logging, nothing related to TTS is logged when fireing a speak-event - only heartbeat-ping/pongs are logged.

    HomeSeer and the plugin has been restarted multiple times, but no change.
    "online" means it has been discovered by bonjour/avahi, if it is not online it should not be connected unless you manually clicked the connect button or have some event that do so?

    The plugin only allow TTS if it sees the chromecast as Online and Connected, I'm going to remove the Online condition because checking for Connected is enough, however I still would like to know how you end up with a device that is not online but connected?

    Comment


    • #17
      Originally posted by spud View Post

      "online" means it has been discovered by bonjour/avahi, if it is not online it should not be connected unless you manually clicked the connect button or have some event that do so?

      The plugin only allow TTS if it sees the chromecast as Online and Connected, I'm going to remove the Online condition because checking for Connected is enough, however I still would like to know how you end up with a device that is not online but connected?
      That put me in the right direction and I was able to solve it! I’m running pfSense as firewall and HS and the CC's are on different VLANs. After updating pfSense a few weeks ago, Avahi stopped working, so it didn’t forward the traffic between the interfaces anymore. There was an update to the pfSense Avahi-package now, after updating it came “online”.

      I think I clicked “connect” myself, and that’s why it was “connected”.

      Comment


      • #18
        I am having this problem as well, however I am running on a Windows 10 box.
        Bonjour 3.1.0.1
        Plugin Version 3.0.0.29

        When I restart the server, things are perfect, however as time goes on, they drop off.

        Click image for larger version

Name:	Screenshot from 2018-12-23 14-27-03.png
Views:	6
Size:	90.6 KB
ID:	1269066

        I have attached the debug log since my last boot.

        Any ideas?

        Thanks

        Comment


        • #19
          Possible fix: in googleing I found this:

          https://hints.macworld.com/article.p...91201040032543

          I had disabled IPv6 for some reason that I don't remember now. Just for funs, I re-enabled it on my nic and like magic, all my devices are showing online again. We will see if it lasts, but previously a reboot was the only thing that would make them come back online.

          Edit:

          Nevermind - Spoke too soon, 24 hours later I am down 3 devices.

          Edit 2:

          So while this does not fix the problem, it seems to be a first step. While restarting the plugin itself does not bring the chromecasts back, now I can restart bonjour, then restart the plugin, and they do come back. While this is a pain it is better than having to restart the server. It also makes me wonder if it is a bonjour problem. I tried installing the older version of Bonjour Spud has in his dropbox, but it doesn't change anything.

          I also notice that the loss of online status in the plugin config page appear to correlate with the loss of connection status on the devices page. This means a chance to try to fix things with a couple events.

          So when the chromecasts in the devices page have been disconnected for 2 minutes, an event will reconnect them. If any of these events run twice in 90 minutes, Homeseer will restart the bonjour service, then restart the chromecast plugin. I will watch things for a few days and see how it goes.

          Comment


          • #20
            So my fix it event ran a couple times between 03:50 and 05:00 this morning, but the chromecasts are all showing online. Looking back through Windows event logs, I don't see anything to give me any hints. Homeseer logs show three of these entries leading up to my fixit event triggering though.

            ERROR Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

            Googling around I saw some folks saying that this could be triggered by an IP conflict. The chromecasts are not pulling the same IP's as I use reservations, but I do have two cast groups which share an IP with one of the devices. Is it possible that these are causing the disconnects?

            Comment


            • #21
              I am surprised there has been nothing from spud on this. This solution worked fine until the day before yesterday, running a couple times between 3 and 5 am daily. Since the 20th however, I constantly lose connections. The events run to fix it and it just disconnects again. Is anyone else seeing this?

              Comment


              • #22
                Originally posted by spud View Post
                The plugin only allow TTS if it sees the chromecast as Online and Connected, I'm going to remove the Online condition because checking for Connected is enough, however I still would like to know how you end up with a device that is not online but connected?
                Any progress on removing the “online”-check for TTS?

                Comment


                • #23
                  Originally posted by ZoRaC View Post

                  Any progress on removing the “online”-check for TTS?
                  Sorry I forgot about that.
                  It's done in version 3.0.0.31 available in the Beta section of the updater.

                  If you are on Linux you need to update manually from the files attached to this post.
                  Attached Files

                  Comment

                  Working...
                  X