Announcement

Collapse
No announcement yet.

Chromecast Plugin Disconnecting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by brett_cp View Post

    Wow, that was quick! In my few minutes of testing so far this does appear to be resolved. I've noticed that the plugin disconnects periodically so I made a quick event:

    IF ChromecastAudio2751 Root changes and becomes Disconnected
    Then
    Set Device ChromecastAudio2751 Root to Connect

    This appears to work well - are there any downsides I'm not aware of in doing this? Thanks!
    Well, if if the plugin disconnects it is either because
    (a) the TCP connection has been broken, so in this case the plugin will try to reconnect automatically after 30 seconds
    or
    (b) Bonjour/Avahi says to the plugin that the chromecast has disappeared, in this case a reconnection shouldn't be needed until the chromecast service is advertised again by Bonjour/Avahi.

    You can look at debug logs, why it is disconnecting.
    Theoretically an event to reconnect shouldn't be needed, if you want to keep it, I would at least make it like below this to let the auto reconnection do its job

    IF ChromecastAudio2751 Root has been Disconnected for exactly 2 minutes
    Then
    Set Device ChromecastAudio2751 Root to Connect

    Comment


    • #17
      I am still getting these disconnect errors in the AM. I am on 3.0.0.27.
      Oct-29 3:17:44 AM Chromecast INFO Connected to chromecast Master Bedroom speaker
      Oct-29 3:17:44 AM Chromecast INFO Connecting to Master Bedroom speaker/
      Oct-29 3:17:44 AM Chromecast INFO Found Service: Chromecast-Audio-577451f8c2ae831194c7c
      Oct-29 3:17:00 AM Chromecast INFO Disconnected from chromecast Master Bedroom speaker
      Oct-29 3:17:00 AM Chromecast INFO Disconnecting from Master Bedroom speaker/
      Oct-29 3:17:00 AM Chromecast INFO Lost Service: Chromecast-Audio-577451f8c2ae831194c7c
      Oct-29 2:35:55 AM Chromecast INFO Connected to chromecast Living Room speaker
      Oct-29 2:35:55 AM Chromecast INFO Connecting to Living Room speaker/
      Oct-29 2:35:51 AM Chromecast INFO Found Service: Chromecast-Audio-0f0535dad554365369db0
      Oct-29 2:35:06 AM Chromecast INFO Disconnected from chromecast Living Room speaker
      Oct-29 2:35:06 AM Chromecast INFO Disconnecting from Living Room speaker/
      Oct-29 2:35:06 AM Chromecast INFO Lost Service: Chromecast-Audio-0f0535dad554365369db0

      Comment


      • #18
        Originally posted by cowinger View Post
        I am still getting these disconnect errors in the AM. I am on 3.0.0.27.
        Oct-29 3:17:44 AM Chromecast INFO Connected to chromecast Master Bedroom speaker
        Oct-29 3:17:44 AM Chromecast INFO Connecting to Master Bedroom speaker/
        Oct-29 3:17:44 AM Chromecast INFO Found Service: Chromecast-Audio-577451f8c2ae831194c7c
        Oct-29 3:17:00 AM Chromecast INFO Disconnected from chromecast Master Bedroom speaker
        Oct-29 3:17:00 AM Chromecast INFO Disconnecting from Master Bedroom speaker/
        Oct-29 3:17:00 AM Chromecast INFO Lost Service: Chromecast-Audio-577451f8c2ae831194c7c
        Oct-29 2:35:55 AM Chromecast INFO Connected to chromecast Living Room speaker
        Oct-29 2:35:55 AM Chromecast INFO Connecting to Living Room speaker/
        Oct-29 2:35:51 AM Chromecast INFO Found Service: Chromecast-Audio-0f0535dad554365369db0
        Oct-29 2:35:06 AM Chromecast INFO Disconnected from chromecast Living Room speaker
        Oct-29 2:35:06 AM Chromecast INFO Disconnecting from Living Room speaker/
        Oct-29 2:35:06 AM Chromecast INFO Lost Service: Chromecast-Audio-0f0535dad554365369db0
        The plugin disconnects because Bonjour says the service is lost (log line: Lost Service: Chromecast-Audio-0f0535dad554365369db0). This may occur for various reasons, but the service reappears again and the plugin reconnects within 1 minute, so I think everything is fine.

        Comment


        • #19
          Originally posted by spud View Post

          Well, if if the plugin disconnects it is either because
          (a) the TCP connection has been broken, so in this case the plugin will try to reconnect automatically after 30 seconds
          or
          (b) Bonjour/Avahi says to the plugin that the chromecast has disappeared, in this case a reconnection shouldn't be needed until the chromecast service is advertised again by Bonjour/Avahi.

          You can look at debug logs, why it is disconnecting.
          Theoretically an event to reconnect shouldn't be needed, if you want to keep it, I would at least make it like below this to let the auto reconnection do its job

          IF ChromecastAudio2751 Root has been Disconnected for exactly 2 minutes
          Then
          Set Device ChromecastAudio2751 Root to Connect
          Thank you - I'll keep an eye on it. My Chromcast Audio is connected via wired Ethernet and is active/playing music during most of the day (I work from home). Your plugin has allowed me to tie my Chromecast Audio into Allonis myServer, has been great so far!

          Comment


          • #20
            Originally posted by spud View Post

            The plugin disconnects because Bonjour says the service is lost (log line: Lost Service: Chromecast-Audio-0f0535dad554365369db0). This may occur for various reasons, but the service reappears again and the plugin reconnects within 1 minute, so I think everything is fine.
            Ok, thanks Spud. Great plug-in by the way.

            Comment

            Working...
            X