Announcement

Collapse
No announcement yet.

Zeroconf error on startup - Bonjour is running

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zeroconf error on startup - Bonjour is running

    Hi,
    I keep getting the following error on startup:
    v-25 1:32:01 PM Chromecast ERROR System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running. at Mono.Zeroconf.Providers.ProviderFactory.GetProviders() at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider( ) at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () at Mono.Zeroconf.ServiceBrowser..ctor() at HSPI_Chromecast.ChromecastDiscoverer.Start() at HSPI_Chromecast.ChromecastApp.b__70_0()
    Bonjour is running (mDNSresponder v3.0.0.10 is running in task manager).

    This only happens when the HS computer is rebooted. When you go to the plugin page the chromecast devices are listed and enabled but NOT online.

    But, if I stop the Chromecast plugin and then restart it then the plugin works. And the devices appear online. It's almost as if Bonjour is slow to startup or something. My computer is setup to start HS after a 10 second delay following boot, to allow other dependent services to load first.

    Any suggestions?

    Marty.

  • #2
    Originally posted by mminehan View Post
    It's almost as if Bonjour is slow to startup or something. My computer is setup to start HS after a 10 second delay following boot, to allow other dependent services to load first.
    It's probably the cause of the problem, can't you try to increase the 10 seconds delay?

    Comment


    • #3
      So no matter how long I delay the startup of HS3 the plugin always has the "zeroconf" error. But it seems to work again if I stop and start the plugin.
      It has taken up quite a bit of time.

      In the end I have given up relying on Bonjour to do the work of finding the Google Homes.

      My solution was to fix the IP addresses of the Chromecast and Google Home devices on my network and then edit the chomrecast plugin .ini file as per this post: https://forums.homeseer.com/forum/me...ithout-bonjour

      It seems to have done the trick.

      Hope this helps others having bonjour issues.

      Marty.

      Comment

      Working...
      X