Announcement

Collapse
No announcement yet.

Plugin error upon start up

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Plugin error upon start up

    i can’t seem to get the plug in to start successfully. I get the following error. Can anyone help?
    (using hometroller SEL)


    Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Chromecast.exe: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.Warning, Error details with EXE HSPI_Chromecast.exe: Could not load file or assembly 'System.Runtime, Version=4.0.10.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.

  • #2
    I think you already posted about this problem back in May.
    It still the same problem, the plugin needs mono-devel package to be installed, but unfortunately on some SEL it's not an easy thing to do.

    what do you get when you try the following command:
    Code:
     
     sudo apt-get install mono-devel

    Comment


    • #3
      Originally posted by spud View Post
      I think you already posted about this problem back in May.
      It still the same problem, the plugin needs mono-devel package to be installed, but unfortunately on some SEL it's not an easy thing to do.

      what do you get when you try the following command:
      Code:
      sudo apt-get install mono-devel
      I went through this last week. And no it was not easy. the biggest frustration was nothing I found on the internet about updating mono helped. Then I stumbled on the thread linked below. Still not easy but working though that thread I had mono updated and working. Make sure to read through once before starting.

      https://forums.homeseer.com/forum/ho...r-mono-upgrade
      HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
      Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
      Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

      Comment


      • #4
        Here is what I get when I run “sudo apt-get install mono-devel”:

        running command sudo apt-get install mono-devel
        Reading package lists... Building dependency tree... Reading state information... mono-devel is already the newest version. The following packages were automatically installed and are no longer required: libmono-c5-1.1-cil libmono-corlib2.0-cil libmono-corlib4.0-cil libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system-runtime-interopservices-runtimeinformation4.0-cil libmono-system2.0-cil libmono-web4.0-cil libmonoboehm-2.0-1 libmonoboehm-2.0-dev libntdb1 libnunit2.6-cil libqpdf13 python-ntdb Use 'apt-get autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

        Comment


        • #5
          Wow... It now seems to be working.

          Thank you!

          Comment

          Working...
          X