Announcement

Collapse
No announcement yet.

Chromecast Plugin creating multiple groups

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chromecast Plugin creating multiple groups

    Running 3.0.0.31 prior to purchase. It found my 6 google speakers and 1 Google Cast Group. But everyday the add-in creates roughly 5 Google Cast Groups. Each one has the same IP address, but all different IDs. I ran in this mode for the trial period, and purchased today hoping this would fix the problem.

    Now I cannot remove the groups (by hitting delete), and I would imagine it will continue to add them. Please fix this bug, or provide guidance on how to refund.

    Click image for larger version  Name:	cc.JPG Views:	2 Size:	78.1 KB ID:	1296527
    Attached Files

  • #2
    This is really strange, the id of a group is not supposed to change, that's why the group is created multiple times.
    How have you created this group? Is there anything special you use? What kind of chromecast devices do you have?

    From the config page can you enable log to file, and set the File log level to Debug, let it run for a few days then send me the logs?

    The delete button will just delete the HS devices associated with the chromecast.
    To delete a group definitely, you need to edit Config/Chromecast.ini and delete all the lines that start with the id of the group. However if Bonjour advertise a device with the id you just deleted it will be recreated.

    Comment


    • #3
      Thanks Spud, I hav since cleaned out the Chromcast.ini file to just the known devices. Since then it has added a single All Speakers group. I have switched the log to debu mode and it's doing a lot of that right now.

      As an FYI I am attaching a screen shot of previous logs that appear to "log" the problem.

      {"data-align":"none","data-size":"large","data-attachmentid":1296590}

      Comment


      • #4
        The Chromecast Plugin is logging a lot. And it keeps crashing and restarting, so much so that it is difficult to get back into the Addin page and turn logging off. The bug has reproduced itself once already and I have included a screen shot the evidence. How can I export a subset of my log file to you since my current HomeSeerLog.hsd file is 6905856 in size.

        Click image for larger version

Name:	cc3.JPG
Views:	46
Size:	18.3 KB
ID:	1296600

        Comment


        • #5
          From the config page enable "log to file", logs will be written to Logs/Chromecast.txt
          Set the "File Log Level" to Debug but keep the "Log Level" to Info, so that it does not log everything to the HS log db.

          How have you created this "All Speakers" group? Can you try to delete it and recreate it?

          Comment


          • #6
            logfile exported and ready to send.

            Comment


            • #7
              Now logging to file and I'll let it run.
              The All Speakers group was created with the GoogleHome app (which is only 2 speakers).
              I am not able to delete the all speakers group and re-create at this time...

              Comment


              • #8
                Spud, same thing here. I think this started with 3.0.0.31 -- I also think it has to do with TTS. I kept deleting the extra groups in the ini file and they would reappear. I was testing events with TTS at the time. Used to work fine prior to .31 so I un-checked TTS and all has been well for over a week. When I get a chance I will test with TTS again and see what I can find.

                Regards,

                Comment


                • #9
                  Another 5 groups created in the last day. If you look closely, the ID of the groups are all unique from the first post a few days ago. I have since removed the single group using the iPhone Google Home application, and continue to log to file. I'll give it a few minutes and recreate the group. Please advise where to send the logfile, or if I should post it here (?)
                  Click image for larger version

Name:	cc3.PNG
Views:	40
Size:	53.6 KB
ID:	1297020

                  Comment


                  • #10
                    reproduced the bug. Removed the group, cleaned out the Chromecast.ini file, recreated the group and the new group was picked up. Initiated the TTS script which adjusted volume up, executed TTS for "garage open", adjusted volume down. After the script, another group was created. See screenshot below. Logfile ready to post or send directly to you, please advise.

                    Click image for larger version

Name:	cc4.PNG
Views:	39
Size:	26.4 KB
ID:	1297022

                    Comment


                    • #11
                      please send the log file to spud.webb.4@gmail.com

                      Comment


                      • #12
                        Hi there,

                        Monday morning and I now have over 9 groups on the Chromecast status screen, and 54 (duplicate) devices on my Homeseer status page. Please advice of break/fix status, or how to initiate refund.

                        Thank you.

                        Comment


                        • #13
                          I will fix this issue this week by using the name of the group as the id.

                          In the meantime, add the following line in the [GENERAL] section of the file Config/Chromecast.ini,

                          Code:
                          disable_new_chromecasts = True
                          This will avoid new devices to be created when the group is duplicated

                          Comment


                          • #14
                            Please test version 3.0.0.32 available in the beta section of the updater. For Cast Groups the name is now used as an identifier rather than the id, which will prevent the duplicate lines discussed in this thread (unless you change the name of the group)
                            Before starting the new 3.0.0.32 version, make sure to delete the duplicated groups from your ini file.

                            Comment


                            • #15
                              Hi Spud, updated and installed. Everything discovered once, but it's now failing on connection across my 6 speakers. Here is an example from 1 of them in the log.

                              Apr-11 1:18:20 PM Chromecast ERROR Error, Unable to connect speaker client interface: Not Authorized
                              Apr-11 1:18:20 PM Warning Speaker host connection refused from 127.0.0.1 User: default User does not exist, does not have adequate rights, or the password is incorrect.
                              Apr-11 1:18:20 PM Chromecast INFO Speaker client Attic Speaker has connected

                              Comment

                              Working...
                              X