Announcement

Collapse
No announcement yet.

TTS Issue with Google Home Mini when event is fired for the first time

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by spud View Post

    in Tools > Setup > Labs, you may need to set "Bind Server to IP Address" to the correct IP. Then restart the Chromecast plugin.

    That did it, spud! My "play wav file" is now working correctly. Hopefully my response time issues are gone now and I can use system voices. Much thanks!

    Comment


    • #17
      spud any idea what could be the issue with Google TTS by any chance ?

      Comment


      • #18
        Originally posted by banana View Post
        spud any idea what could be the issue with Google TTS by any chance ?
        no I don't know what the issue is, I don't think I have ever experienced this problem on my GH
        Is the problem specific to the Google Home Mini? do you have some other chromecast devices to test with?
        If you try with a much longer message, do you hear the end of the message?


        Comment


        • #19
          I will try testing more, I don't have any other chromecasts to test with yet.
          Some questions:
          1. Why does plugin do two ding sounds before speaking, is this something you specify?
          2. are you able to set delay to let google to generate the wav file before passing url to chromecast?
          3. Are you able to cache wav files locally forever? ( i wonder if the problem is the delay when wav is being generated)

          Comment


          • #20
            I might be onto something.

            I realised there are 2 devices with same ip in my chromecast plugin and both are enabled

            Click image for larger version

Name:	image_78874.png
Views:	20
Size:	72.6 KB
ID:	1301856
            It seems when both are enabled then I have 2 dings when one is enabled I have one ding, and sometimes no ding at all.
            What is the proper protocol for using chromecasts and groups?
            Last edited by banana; April 28th, 2019, 08:58 PM. Reason: formatting

            Comment


            • #21
              Originally posted by banana View Post
              I might be onto something.

              I realised there are 2 devices with same ip in my chromecast plugin and both are enabled

              Click image for larger version

Name:	image_78874.png
Views:	20
Size:	72.6 KB
ID:	1301856
              It seems when both are enabled then I have 2 dings when one is enabled I have one ding, and sometimes no ding at all.
              What is the proper protocol for using chromecasts and groups?
              I would advise to disable the Google Cast Group from the config page. If both are enabled and if you do not target a specific device in your Speak action, the TTS will be sent twice to your device.
              Also you may want to upgrade to version BETA 3.0.0.33 (available in the Beta section of the plugin manager), this version uses a different TTS API and will be released soon.

              When using google voice, the plugin does not generate a wav file, it directly sends a google url to the chromecast.

              Comment


              • #22
                So far so good, after disabling Cast Group last night, it looks like the issue might have been resolved. Will report in couple of days.
                I am guessing that cast group was conflicting with the mini itself?

                Comment


                • #23
                  Hi spud It seems that after installing the latest beta and disabling homegroup everything is functioning as expected. Do you know if there is a way to disable the ding sound?

                  Comment


                  • #24
                    Try what is described in the last post of this thread: https://forums.homeseer.com/forum/me...ore-announcing

                    Comment


                    • #25
                      Looks like Google home mini doesn't have this setting. How unfortunate.

                      Sent from my Pixel XL using Tapatalk

                      Comment

                      Working...
                      X