Announcement

Collapse
No announcement yet.

"Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1" since 3.0.0.40.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Without having anywhere else to turn, I'm at this forum where people are patient with NOOBs like me. I've seen other forums where users are brutal so I stay away. Or maybe someone can recommend a forum that is better than others for issues like this.

    I do have another router, should I try it as an access point and connect all the GH minis to it? At that point do I need to "bind" an IP address for HS?

    I continue to have constant connects/disconnects. Here's just a few minutes worth.
    Mar-05 16:37:33 Chromecast INFO Connected to chromecast Sunroom
    Mar-05 16:37:33 Chromecast INFO Speaker client Sunroom has connected
    Mar-05 16:37:33 Chromecast INFO Connecting speaker client Sunroom to HomeSeer IP 127.0.0.1
    Mar-05 16:37:26 Chromecast INFO Connecting to Sunroom https://192.168.1.91:8009/
    Mar-05 16:36:33 Chromecast INFO Connected to chromecast Office
    Mar-05 16:36:33 Chromecast INFO Connected to chromecast Garage
    Mar-05 16:36:33 Chromecast INFO Speaker client Garage has connected
    Mar-05 16:36:33 Chromecast INFO Connecting speaker client Garage to HomeSeer IP 127.0.0.1
    Mar-05 16:36:33 Chromecast INFO Speaker client Office has connected
    Mar-05 16:36:33 Chromecast INFO Connecting speaker client Office to HomeSeer IP 127.0.0.1
    Mar-05 16:36:26 Chromecast INFO Connecting to Garage https://192.168.1.90:8009/
    Mar-05 16:36:26 Chromecast INFO Connecting to Office https://192.168.1.96:8009/
    Mar-05 16:31:56 Chromecast INFO Disconnected from chromecast Garage
    Mar-05 16:31:56 Chromecast INFO Speaker client Garage has disconnected
    Mar-05 16:31:56 Chromecast INFO Disconnecting from Garage https://192.168.1.90:8009/
    Mar-05 16:31:56 Chromecast INFO Disconnected from chromecast Sunroom
    Mar-05 16:31:56 Chromecast INFO Speaker client Sunroom has disconnected
    Mar-05 16:31:56 Chromecast INFO Disconnecting from Sunroom https://192.168.1.91:8009/
    Mar-05 16:31:56 Chromecast INFO Disconnected from chromecast Kitchen
    Mar-05 16:31:56 Chromecast INFO Disconnecting from Kitchen https://192.168.1.44:8009/
    Mar-05 16:31:56 Chromecast INFO Speaker client Kitchen has disconnected
    Mar-05 16:31:56 Chromecast INFO Disconnected from chromecast Office
    Mar-05 16:31:56 Chromecast INFO Speaker client Office has disconnected
    Mar-05 16:31:56 Chromecast INFO Disconnecting from Office https://192.168.1.96:8009/
    Mar-05 16:31:56 Chromecast INFO Disconnected from chromecast Master Bedroom
    Mar-05 16:31:56 Chromecast INFO Disconnecting from Master Bedroom https://192.168.1.88:8009/
    Mar-05 16:31:56 Chromecast INFO Speaker client Master Bedroom has disconnected

    Comment


    • #17
      I still see the same here and my network is just fine.

      I have tried all kinds of different things, like reserving addresses for each, making sure they are all on the same 2.4 or 5ghz network... and a host of other items I have seen posted in the internet for Google Home Mini disconnects. I have removed and added them back in multiple times, which is a royal PITA as they are not quick. Even started over on this plugin and the 'other' chrome cast plugin.

      Personally I just think these things are crap - which really sucks as I have 9 of them.

      I have personally run out of options.

      My only thoughts are to have the plugin log these less and be a bit more lenient on disconnects. Perhaps only log if they are done for longer.

      Scott

      Comment


      • #18
        I have an event that takes my location and announces I'll be home in a few minutes. It used to work fine. Now all the speakers pop as if they're clearing their throats and then nothing gets spoken. The bottom line is that is my frustration. If I say Hey Google, turn lights on/off, dim, whatever it all works. It's the commands sent from HS3 that don't work as they should.

        Comment


        • #19
          I have noticed this on occasion. But it's hard to replicate.
          Does this happen every time? Do you get the initally connection 'ding' sound before the speaking? What happens if you run two speaking events sequentially?
          iCore5 Win 10 Pro x64 SSD

          HS3 Pro Edition 3.0.0.435 Windows

          BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

          Comment


          • #20
            I'll get back to you after I create that event. But note also that if a particular GH shows as offline, I can't even select it in the list of devices. However, if I say Hey Google to my office mini it answers. So it is connected, it just disappears from my network watcher and consequently from the list of available chromecast devices.

            Comment


            • #21
              @racefern, in your Debug logs I see a lot of lines like this:

              Code:
              DEBUG Lost Service: Google-Nest-Mini-477a8828a61a12a75403ccf1b1d9e79b
              which are the cause of most of the disconnection/reconnection you see.

              This line means that the Zeroconf library has not received any answer from the Nest-mini in X pings. This doesn't mean your Chromecast is not connected to your network anymore, just that it doesn't respond to the zeroconf requests or more probably that something is blocking the requests/responses in your network. I don't remember from the top of my head what is the value for X or the interval between 2 pings, but one thing I could do is to make that configurable so that a "Lost Service" message is only sent after more failed pings.

              Also, in my experience groups can cause some troubles, so please try to disable all groups in the plugin config page, and see if that improve things.

              Comment


              • #22
                spud Thanks for your comments, I'll keep digging into this.

                I did have a "Home Announce" group in the GH app. I removed that and deleted the device from HS3.

                Interesting that even though the devices do not show at times on my Network Watcher Utility, I can still ping them without delay. So somehow they seem to disappear but they haven't. This is just a small utility from nirsoft.net and has nothing to do with HS3 or this PI.

                However, the only time they show as available, which means I can press the "Test" button is when they appear in the utility mentioned above. Of course, the moment they appear as being on the network I still have to wait until the PI polls.

                ​​​​​​​

                Comment


                • #23
                  spud If the GH I want to use is "not available" the "Test" button is not highlighted. Is there a way to be able to try and test regardless of status?

                  In my screenshot the Onkyo is actually Chromecast built-in to the unit itself. The Chromecast Ultra is a chromecast dongle attached to an HDMI port, all the others are GH scattered throughout the house.

                  Click image for larger version

Name:	Screen Shot 03-06-20 at 05.20 PM.PNG
Views:	75
Size:	63.2 KB
ID:	1368437

                  Comment


                  • #24
                    I would like to add one more observation:

                    I can have my main PC as the speaker client and the GH mini in the office right beside the PC.

                    When I manually run the event to speak a sentence, the main PC speaks it perfectly. The GH mini might beep like it's going to speak but never says a word.

                    Comment


                    • #25
                      The PC is using the HS speaker client I presume. This is totally different from Chromecasts/Google Homes. Different technology. What your observation is consistent with is the that your problems with chromecast are a network issue.

                      Have you looked up forums for your specific networking equipment and Google home? I use Unifi gear and there is plenty about configuring your network to support google homes properly. Even putting them on a separate IoT VLAN et (https://help.ubnt.com/hc/en-us/artic...-UniFi-Network).

                      This all sounds like you need to do some homework on your network setup. Is zero handoff turned off? Have you updated the firmware of your network equipment? Is uPNP on or off? Have you added the chomecast plugin to your firewall exceptions on the HS machine? As frustrating as this all seems it will be something simple in your network setup. I had a real problem for a while until I realized that Webroot (antivirus/firewall) was pointing to the wrong file in the exceptions table due to a bug in the Webroot software.
                      iCore5 Win 10 Pro x64 SSD

                      HS3 Pro Edition 3.0.0.435 Windows

                      BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                      Comment


                      • #26
                        mminehan You're 100% right in all your questions and observations. I need to look at zero handoff but not sure where or what?
                        Unfortunately I think part of the problem is my Altice One router and every time I turn around they're changing something on it.
                        Chromecast is allowed through the firewall.
                        Thanks for the link and hopefully I'll get this figured out sooner than later.

                        Comment


                        • #27
                          A lot of trial and error has gone into solving this. I'm down to just the Google Home connected without all the minis or the chromecast. It now stays connected. There are numerous issues with Google Nest and Home products staying connected to wifi and bluetooth so for now, I'm just using one device.

                          However, when I click "Test" in the Chromecast config page, I only get the typical Google ding sound that something is about to be said, but nothing gets spoken. Additionally, if I press test again, nothing at all happens, not even the ding. I have yet to figure out how long I have to wait between pressing Test to get it to ding again never mind getting Google Home to say "This is a test" or whatever it used to say.

                          As I am typing this, I am trying various options and I finally have it working by switching the voice to Google instead of System. Is this required?

                          Comment


                          • #28
                            I am finally closing the loop on this situation. The entire problem was and is still my Altice Once combination cable modem/router. It just can't handle the number of devices I have. Since I already owned a Netgear Nighthawk 7800, I set it up as an access point. Voila! All devices connect and stay connected.

                            Chromecast is now capable of casting to whichever devices I have. I do have to use Google voice as opposed to System voice but that's fine with me.

                            I'm thinking of getting rid of the Altice One system since it's just to limiting for my needs.

                            Comment


                            • #29
                              spud - You mentioned that it is possible to take the logging way down or the pings down. Is this something you can do sooner than later for the HS3 version?

                              I have honestly tried everything I can, including completely replacing my wireless network.

                              But I am still inundated with errors.
                              Here is just an example, with my plugin logging turned as low as possible, this is just the last hour or so.
                              I have run continuous pings to all of my home/nest mini devices without a drop and yet these continue.
                              I am at my wits end and will probably replace all with a different solution as soon as I can figure something.
                              But at this point my log is useless for any other errors as I just can't see past the Chromceast errors.

                              thanks!

                              Code:
                               
                              Apr-27 10:01:45 AM Speaker Speaker host added, Name: Chromecast Instance: all speakers IP address: 127.0.0.1
                              Apr-27 10:01:43 AM Chromecast ERROR Connection refused
                              Apr-27 10:01:23 AM Speaker Speaker host added, Name: Chromecast Instance: Garage IP address: 127.0.0.1
                              Apr-27 10:01:23 AM Speaker Speaker host added, Name: Chromecast Instance: Bonus IP address: 127.0.0.1
                              Apr-27 10:01:13 AM ASR Speaker Client speech recognition stopped
                              Apr-27 10:01:13 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 10:00:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 10:00:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 10:00:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 10:00:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:59:23 AM Speaker Speaker host added, Name: Chromecast Instance: all speakers IP address: 127.0.0.1
                              Apr-27 9:59:23 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:59:23 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:56:23 AM Speaker Speaker host added, Name: Chromecast Instance: Garage IP address: 127.0.0.1
                              Apr-27 9:54:53 AM Speaker Speaker host added, Name: Chromecast Instance: Bonus IP address: 127.0.0.1
                              Apr-27 9:54:53 AM Speaker Speaker host added, Name: Chromecast Instance: Keegan IP address: 127.0.0.1
                              Apr-27 9:53:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:53:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:53:44 AM Z-Wave Device: Garage Lock Entry Access Control Notification Set to NOTIFICATION for type Access Control Notification, Event: No Event
                              Apr-27 9:52:23 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:52:23 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:52:23 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:52:23 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:43:53 AM Speaker Speaker host added, Name: Chromecast Instance: Bonus IP address: 127.0.0.1
                              Apr-27 9:38:53 AM Speaker Speaker host added, Name: Chromecast Instance: Garage IP address: 127.0.0.1
                              Apr-27 9:36:23 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:36:23 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:36:23 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:36:23 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:33:23 AM Speaker Speaker host added, Name: Chromecast Instance: Garage IP address: 127.0.0.1
                              Apr-27 9:32:53 AM Z-Wave Device: Garage Lock Entry Access Control Notification Set to NOTIFICATION for type Access Control Notification, Event: Manual Unlock Operation
                              Apr-27 9:32:53 AM LED Lights Script requested: v2.64 : 6,red,false
                              Apr-27 9:32:53 AM Event Running script and waiting: /home/administraor/HomeSeer/scripts/LED_Status.vb
                              Apr-27 9:32:53 AM Event Event Trigger "Status Lights Set LED 6 Unlocked"
                              Apr-27 9:32:53 AM Device Control Device: Automation Virtual Status Garage Entry LED 6 to Unlocked (0)
                              Apr-27 9:32:53 AM Event Event Trigger "Doors Garage Entry Door Closed Unlocked"
                              Apr-27 9:32:53 AM Z-Wave Device: Garage Lock Entry Door Lock Set to Unlocked Door Closed
                              Apr-27 9:32:53 AM Speaker Speaker host added, Name: Chromecast Instance: Keegan IP address: 127.0.0.1
                              Apr-27 9:31:53 AM Speaker Speaker host added, Name: Chromecast Instance: Bonus IP address: 127.0.0.1
                              Apr-27 9:31:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:31:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:31:23 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:31:23 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:31:23 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:31:23 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:26:23 AM Speaker Speaker host added, Name: Chromecast Instance: Bonus IP address: 127.0.0.1
                              Apr-27 9:22:53 AM Speaker Speaker host added, Name: Chromecast Instance: Garage IP address: 127.0.0.1
                              Apr-27 9:22:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:22:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:18:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:18:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:15:53 AM Speaker Speaker host added, Name: Chromecast Instance: Bonus IP address: 127.0.0.1
                              Apr-27 9:12:53 AM Speaker Speaker host added, Name: Chromecast Instance: Garage IP address: 127.0.0.1
                              Apr-27 9:12:53 AM Speaker Speaker host added, Name: Chromecast Instance: Keegan IP address: 127.0.0.1
                              Apr-27 9:12:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:12:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:12:23 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:12:23 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:09:23 AM Speaker Speaker host added, Name: Chromecast Instance: Bonus IP address: 127.0.0.1
                              Apr-27 9:06:53 AM Speaker Speaker host added, Name: Chromecast Instance: Keegan IP address: 127.0.0.1
                              Apr-27 9:03:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:03:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:03:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:03:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 9:03:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:03:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 9:00:23 AM Speaker Speaker host added, Name: Chromecast Instance: Bonus IP address: 127.0.0.1
                              Apr-27 8:59:53 AM Speaker Speaker host added, Name: Chromecast Instance: Keegan IP address: 127.0.0.1
                              Apr-27 8:59:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 8:59:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 8:56:53 AM ASR Speaker Client speech recognition stopped
                              Apr-27 8:56:53 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 8:53:53 AM Speaker Speaker host added, Name: Chromecast Instance: Bonus IP address: 127.0.0.1
                              Apr-27 8:53:23 AM ASR Speaker Client speech recognition stopped
                              Apr-27 8:53:23 AM Speaker Speaker host disconnected, Name: CHROMECAST IP address: 127.0.0.1
                              Apr-27 8:53:20 AM SDJ-Health 1 queued messages processed
                              Apr-27 8:51:23 AM SDJ-Health Activity Device #135 added to message queue for processing.
                              Apr-27 8:50:23 AM Speaker Speaker host added, Name: Chromecast Instance: all speakers IP address: 127.0.0.1
                              Apr-27 8:49:51 AM Chromecast ERROR Connection refused

                              Comment


                              • #30
                                sbessel Here's how I finally got to the source of my troubles. I installed Wireless Network Watcher from www.nirsoft.net. Although everything would still work and GH and minis would respond when spoken to, they actually appear to be off the network. Then suddenly they would come back on. I say off and then on but really only as far as Chromecast was concerned. When Chromecast couldn't see them, a big red X would appear on the software screen. At the same time on the config screen of Chromecast you could not press the "Test" button. But if you said Hey Google, they worked perfectly.

                                I have an Altice One combo box (Sagemcom), router, cable, everything. I also had sitting around a Netgear Nighthawk 7800. I put the Netgear into access point mode and plugged it into my system. Then I moved nearly all my wireless devices from the Altice One box to the netgear router. Problem solved.

                                What kind of router do you have?

                                Here's a screenshot of my device list and you can see two Xs next to two devices that are off, the Amazon stick and the TV.

                                Click image for larger version

Name:	Screen Shot 04-27-20 at 04.40 PM.PNG
Views:	30
Size:	50.5 KB
ID:	1381281

                                Comment

                                Working...
                                X