Announcement

Collapse
No announcement yet.

Help...Plugin is using a GATEWAY IP as the HS IP which is not reachable

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help...Plugin is using a GATEWAY IP as the HS IP which is not reachable

    So I have a weird one trying to get this PlugIn or work. My Google devices are found without issue and if I send something to be spoken on them, it will start it up but nothing is every said. Looking in the logs it seems that HS is trying to use my GATEWAY IP to talk and not my local network. The devices were found on the local network, but I have a VPN system also running on this windows 10 box and it is trying to use that!!!
    Jan-23 12:53:56 PM Chromecast DEBUG Playing http://10.11.12.173:8080/Wave/chrome...3125356358.wav on Living Room Max
    Jan-23 12:53:56 PM Chromecast DEBUG calling SpeakToFile text=Hello, this is a test for chromecast plug-in file=C:\Program Files (x86)\HomeSeer HS3\html\Wave\chromecast20200123125356358.wav

    The IP of my Living Room Max does show correctly as 192.168.1.75 in the plugin yet as you can see 10.11.12.173 is looking to be used as to what to play when it should be 192.168.1.3. which is my HS. I try the IP it is trying to use in my browser it's won't connect or do anything of course. If I change the IP to that of my local HS and try it in my browser, I does work... http://192.168.1.3:8080/Wave/chromecast20200123125356358.wav It is just trying to use my WAN gateways.

    So the question is...How do I get HS to NOT be on the network of the VPN so it will look to use the ACTUAL local network of 192.168.1.X ???? I mean, it does REACH the Home Max unit, but the max can't seem to do anything after that as it is trying to get to HS. This is not working as it is looking to play something it surely should not even be looking at IP wise!

    The plug appears to pick an IP address on a different subnet than the configured / discovered Chromecast device as the URL and it surely should not.

    Otherwise, HS is just fine and responds to me just well on the private IP of 192.168.1.3.

    Thanks!

    #2
    you need to bind your HS server IP: go to to Tools > Setup > Network > Web server settings and select the correct IP for the field "Bind Server to IP Address"
    then restart the Chromecast plugin.

    Comment

    Working...
    X