Announcement

Collapse
No announcement yet.

Default media controller app is not running on chromecast

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Default media controller app is not running on chromecast

    Please advise what does this error mean and how to fix it.
    Chromecast device named "music" was working until recently. Now it does not. The button "test" in Chromecast plug-in setup doesn't produce any sound either.
    Attached below is the debug info from Chromecast along with the error message
    BTW restarting HS3 doesn't fix the problem.
    Feb-22 10:14:59 AM Chromecast ERROR Default media controller app is not running on chromecast Music
    Feb-22 10:14:54 AM Chromecast DEBUG RX: { "sourceId": "receiver-0", "destinationId": "sender-0", "namespace": "urn:x-cast:com.google.cast.receiver", "payloadUtf8": "{"reason":"NOT_FOUND","requestId":1766689523,"type":"LA UNCH _ERROR"}" }
    Feb-22 10:14:54 AM Chromecast DEBUG TX: { "sourceId": "sender-0", "destinationId": "receiver-0", "namespace": "urn:x-cast:com.google.cast.receiver", "payloadUtf8": "{"appId":"CC1AD845","requestId":1766689523,"type":"LAUN CH"} " }
    Feb-22 10:14:54 AM Chromecast DEBUG Playing http://192.168.1.242:83/Wave/chromec...2101453988.wav on Music
    Feb-22 10:14:53 AM Chromecast DEBUG calling SpeakToFile text=test file=C:\Program Files (x86)\HomeSeer HS3\html\Wave\chromecast20200222101453988.wav

    #2
    To play something a chromecast needs first to load an app like youtube, spotify, etc.... The app used by the HS plugin is the "default media controller", so if it is not loaded yet, the plugin tries to launch it. For some reason your chromecast says it can not find this app ("reason":"NOT_FOUND"), this is the first time I see this error. What kind of chromecast is it? Can you try to power cycle it? Does it have access to internet.

    Comment


      #3
      spud

      Power cycling it resolved the problem. However there is a confusion (for me at least) as there is a free plug-in for HS3 called "Media Controller"

      https://forums.homeseer.com/forum/me...roller-dcorsus

      Do I need this HS3 plug-in in order for my ChromeCast to run properly?

      Thanks,

      risquare

      Comment


        #4
        No, the "Media Controller" plugin has nothing to do with that.
        The app I'm talking about is running on the Chromecast itself, and actually I think it's called "Defaul Media Receiver".

        Comment


          #5
          Thanks. This helps. I was cleaning up unused PIs lately and I was wondering if deleting the “Media Controller” PI may have caused the problem.

          Comment


            #6
            Interesting,... I've seen this error many many times. I'm using Chromecast audios.

            Sent from my LM-G820 using Tapatalk

            RJ_Make On YouTube

            Comment


              #7
              I continue seeing this error all the time. It’s really frustrating. It fixes itself and than it goes bad again. My Chromecast is in an area where there is good 3 bar WiFi coverage. Please fix or advise what to do.

              Thanks,
              risquare

              Comment

              Working...
              X