Announcement

Collapse
No announcement yet.

Just one hitch.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Just one hitch.

    I've got HSTV 3 setup for the most part (just a single user for now) but I am getting the following error when I click the Grid button. The error appears in the HS gui. The webpage only shows the show legend at the bottom after the button is clicked.

    11/20/2007 7:22:30 PM - HSTV - Error Grid: Conversion from type 'DBNull' to type 'String' is not valid.

    Any suggestions? Great upgrade by the way, with the control outputs I have Snapstream back!! YEAH!

    Thanks for the great work. Terry

    ps. the "RUN EARLY" param in control setups. Does that require a unit like 1min or is it implied? thanks again
    Last edited by tman1; November 20th, 2007, 07:51 PM.

  • #2
    That error is driving me crazy.
    Apparently there is some difference (data wise) in the xml files that are available now vs when they came from zap2it's old service. It has something to do with the tvChannels table.

    As for the Run Early, yes, you need to enter something there.
    If can any number. When I was testing, I used a number as high as 600, but there is no limit on it. Although I can't imagine what you would really want to have happen that far ahead. hehe, maybe you have a really slow popcorn popper. You can also set it as a negative number so say you had a watch event. You could send the IR to change the channel and then a few minutes after it starts you could lower the lights. Allowing a few extra minutes of light for a spouse to come in late. hehe.
    --
    Jeff Farmer
    HS 3, HSPhone
    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

    Comment


    • #3
      Thanks for the reply.

      Hope you had a Happy Thanksgiving and thanks for all your great contributions.

      I am going to have to work on my dvr record control. The last attempt didnt fire. I have a control setup like this:
      An app set to launch 2 early (no unit designator) to launch BeyondTV if not running.

      A script set to launch 1 early (no unit designator) to tune BeyondTV to the passed channel variable from the HSTV record event. This is my default channel changer script so Im pretty sure this is not the problem.

      An app set to launch 0 early (no unit designator) to call the BTV window and send the record keystroke then answer yes to the dialog "record this show".

      Btv then records to the end of the current show so no stop event is required.
      Should this work? I can launch the same sequence from an Event in HS and it seems to work fine. When HSTV does the sequence it fails. My next try was going to be having HSTV launch the working HS event 3 mins early. But if I have the input syntax wrong for the run earlies then I will probably have the same issue.

      Attached is a bitmap of my control screen if it helps.

      Thanks again, Later Terry
      Attached Files

      Comment


      • #4
        Is BTV on the same machine that HS is on?
        If not then this won't work because Launch app runs on the HS server.
        --
        Jeff Farmer
        HS 3, HSPhone
        My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
        Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

        Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

        Comment


        • #5
          You are correct Sir!!

          Yes they are on the same machine.

          I think I may have found the problem, just a minute ago in fact. You have to COMPILE those pesky AutoIT scripts if you expect to call the resulting exe from somewhere else. If I had hair Id claim a blonde moment.

          Should know if it all works on the next half hour test slot.

          Thanks for the reply, Later

          Comment

          Working...
          X