Announcement

Collapse
No announcement yet.

Having trouble getting HSTV going on HomeTroller - Fixed!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having trouble getting HSTV going on HomeTroller - Fixed!

    I downloaded HSTV today and can't seem to get it to populate any data. I followed the install instructions in the help file but nothing came through - the log showed "XML Errorcode: -1072896658" when HSTV accessed the xml files created by xmltv. If I go into the "Database Cleanup" and click "Reimport All" it appears the xml files are created OK but HSTV still gets this error. Googling this error implies a problem with the character set in the xml file? My xml files show 'encoding="ISO-8859-1"' (don't know if this means anything to you). Attached is a log excerpt of all the HSTV entries.

    What am I doing wrong?

    Thanks,
    Steve
    Attached Files
    Steve

    (System configuration is in my profile)

  • #2
    Are you signed up with schedulesdirect.org
    John

    Comment


    • #3
      Originally posted by johnnybwis View Post
      Are you signed up with schedulesdirect.org
      Yes, I did that before I started installation. I know xmltv is getting the info successfully from SD because the XML files are in \data\hstv\listings and are about 4MB each. I can look at them and see all the data. It just won't import getting that "XML Errorcode: -1072896658" when the import runs. And it doesn't matter how many days I try to pull, they always error out.

      Steve
      Steve

      (System configuration is in my profile)

      Comment


      • #4
        Fyi

        I accidentally double-clicked one of these XML files and IE displayed this message:
        HTML Code:
        The XML page cannot be displayed 
        Cannot view XML input using style sheet. Please correct the error and then click the Refresh button, or try again later. 
        
        
        --------------------------------------------------------------------------------
        
        System does not support the specified encoding. Error processing resource 'file:///D:/Program Files/HomeSeer HSPRO/Data/hst...
        
        <?xml version="1.0" encoding="ISO-8859-1"?>
        Don't know if this helps anyone?

        Thanks,
        Steve
        Steve

        (System configuration is in my profile)

        Comment


        • #5
          After hours of web searching...

          This appears to be related to running this on my HomeTroller 2 that has restore flash v1.3 on it and runs XP Embedded. Apparently there may be a missing component dependency as referenced here:

          http://blogs.msdn.com/b/embedded/arc...web-pages.aspx

          I have a ticket open at HS helpdesk; let's see if they can help me fix this (preferably before my 7 days runs out at Schedules Direct!).
          Steve

          (System configuration is in my profile)

          Comment


          • #6
            Problem solved!!

            Thanks to Rich (yay!) my problem is now fixed. It indeed was a component dependency problem in their v1.3 build of the restore flash for my HomeTroller 2 running XP Embedded with SP3. I copied an XP file and made a registry entry and Voila! problem gone.

            Thanks again, Rich!!
            Steve

            (System configuration is in my profile)

            Comment

            Working...
            X