Announcement

Collapse
No announcement yet.

iTunes DAAP plugin - Beta testing

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Nov-23 22:33:53 Error Calling SetIOMulti in plugin iTunesDAAP:Object reference not set to an instance of an object.
    Nov-23 22:33:51 SENSOR RECOVERY Sensor Recovery has occurred for Lounge Aeon PIR
    Nov-23 22:33:51 NO ECHO No Echo for Lounge Aeon PIR, Echo (1 mins, 1 secs)
    Nov-23 22:33:51 SENSOR RECOVERY Sensor Recovery has occurred for Dining Room PIR
    Nov-23 22:33:51 NO ECHO No Echo for Dining Room PIR, Echo (1 mins, 3 secs)
    Nov-23 22:33:46 SENSOR RECOVERY Sensor Recovery has occurred for Kitchen PIR
    Nov-23 22:33:46 NO ECHO No Echo for Kitchen PIR, Echo (2 mins, 18 secs)
    Nov-23 22:33:39 Device Control Device: AV iTunes DAAP Shuffle to Shuffle On (1)
    Nov-23 22:33:39 Device Control Device: AV iTunes DAAP Master Volume to Volume=30% (30)
    Nov-23 22:33:39 Event Event Trigger "AV Lounge TV PAUSE"
    Nov-23 22:33:34 Warning Plugin iTunesDAAP is not responding but it is still running, not restarting yet.
    Nov-23 22:33:23 Error Calling HSEvent in plugin iTunesDAAP, Instance :Object reference not set to an instance of an object.
    Nov-23 22:33:23 Error Calling SetIOMulti in plugin iTunesDAAP:Object reference not set to an instance of an object.
    Nov-23 22:33:22 JowiHue Animation Lounge TV Play Finished
    Hi Spud,

    Been getting the above errors when trying to play and stop iTunes. I'm not sure it happens all the time though. I'm on hs3 .146 but I think it did the same on .130. Any ideas or debug log needed??

    Cheers
    J

    Comment


    • #32
      Originally posted by Skinnez View Post
      Nov-23 22:33:53 Error Calling SetIOMulti in plugin iTunesDAAP:Object reference not set to an instance of an object.
      Nov-23 22:33:51 SENSOR RECOVERY Sensor Recovery has occurred for Lounge Aeon PIR
      Nov-23 22:33:51 NO ECHO No Echo for Lounge Aeon PIR, Echo (1 mins, 1 secs)
      Nov-23 22:33:51 SENSOR RECOVERY Sensor Recovery has occurred for Dining Room PIR
      Nov-23 22:33:51 NO ECHO No Echo for Dining Room PIR, Echo (1 mins, 3 secs)
      Nov-23 22:33:46 SENSOR RECOVERY Sensor Recovery has occurred for Kitchen PIR
      Nov-23 22:33:46 NO ECHO No Echo for Kitchen PIR, Echo (2 mins, 18 secs)
      Nov-23 22:33:39 Device Control Device: AV iTunes DAAP Shuffle to Shuffle On (1)
      Nov-23 22:33:39 Device Control Device: AV iTunes DAAP Master Volume to Volume=30% (30)
      Nov-23 22:33:39 Event Event Trigger "AV Lounge TV PAUSE"
      Nov-23 22:33:34 Warning Plugin iTunesDAAP is not responding but it is still running, not restarting yet.
      Nov-23 22:33:23 Error Calling HSEvent in plugin iTunesDAAP, Instance :Object reference not set to an instance of an object.
      Nov-23 22:33:23 Error Calling SetIOMulti in plugin iTunesDAAP:Object reference not set to an instance of an object.
      Nov-23 22:33:22 JowiHue Animation Lounge TV Play Finished
      Hi Spud,

      Been getting the above errors when trying to play and stop iTunes. I'm not sure it happens all the time though. I'm on hs3 .146 but I think it did the same on .130. Any ideas or debug log needed??

      Cheers
      J
      looks like the plugin is not responding, so, stop it, kill any HSPI_ITUNES_DAAP.exe that would still run, restart the plugin, set the log level to debug and see if you can replicate this problem. If you can please post the logs.

      Comment


      • #33
        Hi Spud,

        Log attached from shutting down the plug-in, starting up, creating error etc.
        Toward the end of the log I tried pressing the Login button on the DAAP config page.

        Cheers
        J

        edit: after pressing the login button (even though the plugin said itunes was still connected), the errors don't appear no matter how much I try. I leave this running 24/7 and the iTunes instance is on the same machine. Is it breaking when left for a day or two??

        edit2: After another few tries the errors come back and it stops responding
        Attached Files
        Last edited by Skinnez; November 25th, 2014, 05:08 PM.

        Comment


        • #34
          Originally posted by Skinnez View Post
          Hi Spud,

          Log attached from shutting down the plug-in, starting up, creating error etc.
          Toward the end of the log I tried pressing the Login button on the DAAP config page.

          Cheers
          J

          edit: after pressing the login button (even though the plugin said itunes was still connected), the errors don't appear no matter how much I try. I leave this running 24/7 and the iTunes instance is on the same machine. Is it breaking when left for a day or two??
          not sure what was the problem, it should work leaving it running 24/7
          in your logs it looks like one instance is not correctly stopped, when you stop the plugin you need to make sure in task manager that the HSPI_ITUNES_DAAP.exe does not show anymore, and if it does you need to kill it before restarting the plugin.

          Comment


          • #35
            Yeah I did stop all the .exe instances.
            There was only one. I closed the plugin and had to manually stop the exe
            Any ideas??

            Comment


            • #36
              Originally posted by Skinnez View Post
              Yeah I did stop all the .exe instances.
              There was only one. I closed the plugin and had to manually stop the exe
              Any ideas??
              you have to give me more info and try to isolate the problem. Turn off all your other plugins, restart the iTunes plugin, and try to find the minimum steps you have to do to replicate this error. Then post your debug logs (as .txt please), and tell me what are the steps.

              Was it working better with a previous version of the plugin?
              Have you recently upgraded?
              What is the version of iTunes you are using?

              Comment


              • #37
                Originally posted by spud View Post
                you have to give me more info and try to isolate the problem. Turn off all your other plugins, restart the iTunes plugin, and try to find the minimum steps you have to do to replicate this error. Then post your debug logs (as .txt please), and tell me what are the steps.

                Was it working better with a previous version of the plugin?
                Have you recently upgraded?
                What is the version of iTunes you are using?
                iTunes 12.0.1.26 which is the latest (I think)
                I got the new iPhone 6 at the end of September and updated iTunes then. I did notice that there were a few "problems" with iTunes connecting to Apple's remote app. I think it was better before this update but I had an occasional blip before.

                I updated your plugin from 3.0.0.12 (which I had been using from 16/5/14) to 3.0.0.13 (on 13/10/14)

                I think the main problem may be with one particular event that fires when I pause the TV and a video is playing (using Dirk's MediaController PI)

                Then
                Set Device AV iTunes DAAP Master Volume to Volume=44%
                Then
                Set Device AV iTunes DAAP Shuffle to Shuffle On
                Then Play Playlist
                Playlist ID = -434002974700317245
                Track ID = 26615

                I went back into the playlist bit and thought it was slightly different? The Track ID NEEDS to be selected now where it didn't exist before when I created the event (pre 3.0.0.13 of your PI)
                I'll have a play now and get back to you.

                Cheers
                J

                edit: Found it to do the same thing on another event. It seems to log a play or pause in the log, then hang for 30-60 secs then display those same errors

                Nov-26 22:22:28 Warning Plugin iTunesDAAP is not responding but it is still running, not restarting yet.

                Nov-26 22:22:23 Z-Wave Device: Downstairs Lounge Temperature Set to 22.2 (C)

                Nov-26 22:22:23 Z-Wave Device: Downstairs Lounge Luminance Set to 9 (Lux)

                Nov-26 22:22:22 Error Calling HSEvent in plugin iTunesDAAP, Instance :Object reference not set to an instance of an object.

                Nov-26 22:22:21 RFXCOM 24 (SetIOMulti) set value: 0->ref:63 ControlType:Button

                Nov-26 22:22:21 RFXCOM 24 (SetIOMulti) set value: 0->ref:62 ControlType:Button

                Nov-26 22:22:21 RFXCOM 24 (SetIOMulti) set value: 0->ref:60 ControlType:Button

                Nov-26 22:22:21 Event Event Trigger "PIR Kitchen delay counter reset"

                Nov-26 22:22:21 RFXCOM 24 (SetIOMulti) set value: 0->ref:27 ControlType:Button

                Nov-26 22:22:21 RFXCOM 24 (SetIOMulti) set value: 0->ref:56 ControlType:Button

                Nov-26 22:22:21 Error Calling SetIOMulti in plugin iTunesDAAP:Object reference not set to an instance of an object.

                I've updated both routers firmware and will dig a bit more this weekend - working away until Friday.
                Last edited by Skinnez; November 26th, 2014, 06:19 PM.

                Comment


                • #38
                  Sorry for taking so long, I have a six month old
                  I have tweaked the events a bit to avoid quick re-triggers, which may have been causing problems. It is proving difficult to get time for anything these days. Maybe I've fixed it - time will tell. Something has definitely changed recently with HS3 updates to cause a few problems on this and other plugins.
                  Because I don't have much time I update a few things at once, I know, bad practice and can't pinpoint the cause! Hopefully back to normal soon.
                  Cheers
                  J

                  Comment


                  • #39
                    FATAL

                    I tried installing this plugin from scratch from the updater. When it starts I get the error "FATAL" and the following in my log. I also appear to be unable to start a trial due to license issues. I have never tested this plugin before.

                    Error in System.String InitIO(System.String):Retrieving the COM class factory for component with CLSID {DC0C2640-1415-4644-875C-6F4D769839BA} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).


                    Comment


                    • #40
                      Originally posted by fdarden View Post
                      I tried installing this plugin from scratch from the updater. When it starts I get the error "FATAL" and the following in my log. I also appear to be unable to start a trial due to license issues. I have never tested this plugin before.

                      Error in System.String InitIO(System.String):Retrieving the COM class factory for component with CLSID {DC0C2640-1415-4644-875C-6F4D769839BA} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).


                      Looks like you tried the "HomeSeer iTunes" plugin, some other users have reported the same error here: http://board.homeseer.com/showthread.php?p=1148601

                      This subforum is for the "iTunes DAAP" plugin which is different plugin based on a different API. You can install it from the updater as well, it is in the media section.

                      Comment


                      • #41
                        Hi Spud,

                        I downgraded your PI to 3.0.0.12, as I'm still having the same problems. Seems it happens when connecting to HSTouch server from my iPhone too??
                        I was looking at when I updated PI's and saw I updated yours to 3.0.0.13 on 13/10/14 which is about when I changed to iPhone 6 / iOS8 and think the problems started. I also updated to a newer iTunes version on 15/10/14. I thought I'd try in case the radios were causing problems?? If it's still no better I was going to install an earlier version of iTunes. I'll let you know.
                        Cheers
                        J

                        Comment


                        • #42
                          Hi spud,
                          Things seem a little better, one thing I have noticed is the official iPhone remote app would not connect to iTunes using home sharing. Because I updated to.13 of your PI and changed phones / ios8 about the same time it was difficult to know the cause.
                          Anyway, since using.12 again the iTunes remote app works again, and connectivity to iTunes from your Plugin seems better. I wonder if the radios bit on.13 is causing problems with iTunes or the bonjour service??
                          Any ideas?
                          Cheers
                          J

                          Comment


                          • #43
                            Still the same...
                            This basically happens (eventually) when trying to control iTunes from the PI.
                            This locks up HS3 to point that no other events can be run until a few minutes have passed or I disable the PI.

                            This happened when I tried to run a script that set the iTunes state to paused.
                            Any ideas?

                            Dec-31 23:20:58 Warning Plugin iTunesDAAP is not responding but it is still running, not restarting yet. Dec-31 23:20:56 Z-Wave Device: Downstairs Kitchen Luminance Set to 1 (%) Dec-31 23:20:55 JW Kitchen Luminance written to virtual device : 19 Dec-31 23:20:55 Z-Wave Device: Downstairs Kitchen Luminance Set to 19 (%) Dec-31 23:20:55 Error Calling HSEvent in plugin iTunesDAAP, Instance :Object reference not set to an instance of an object. Dec-31 23:20:44 Z-Wave Device: Downstairs Lounge Luminance Set to 55 (Lux) Dec-31 23:20:25 Error Calling HSEvent in plugin iTunesDAAP, Instance :Object reference not set to an instance of an object. Dec-31 23:19:58 Warning Plugin iTunesDAAP is not responding but it is still running, not restarting yet. Dec-31 23:19:55 Error Calling HSEvent in plugin iTunesDAAP, Instance :Object reference not set to an instance of an object. Dec-31 23:19:42 Error Calling SetIOMulti in plugin iTunesDAAP:Object reference not set to an instance of an object. Dec-31 23:19:25 Error Calling HSEvent in plugin iTunesDAAP, Instance :Object reference not set to an instance of an object. Dec-31 23:19:12 Device Control Device: AV iTunes DAAP Status to Pause (3) by/from: CAPI Control Handler Dec-31 23:18:58 Warning Plugin iTunesDAAP is not responding but it is still running, not restarting yet. Dec-31 23:18:55 Error Calling HSEvent in plugin iTunesDAAP, Instance :Object reference not set to an instance of an object. Dec-31 23:18:25 Error Calling HSEvent in plugin iTunesDAAP, Instance :Object reference not set to an instance of an object. Dec-31 23:18:07 Error Calling SetIOMulti in plugin iTunesDAAP:Object reference not set to an instance of an object. Dec-31 23:17:58 Warning Plugin iTunesDAAP is not responding but it is still running, not restarting yet. Dec-31 23:17:55 Error Calling HSEvent in plugin iTunesDAAP, Instance :Object reference not set to an instance of an object. Dec-31 23:17:51 Z-Wave Device: Downstairs Kitchen Luminance Set to 1 (%) Dec-31 23:17:50 JW Kitchen Luminance written to virtual device : 19 Dec-31 23:17:50 Z-Wave Device: Downstairs Kitchen Luminance Set to 19 (%) Dec-31 23:17:44 Z-Wave Device: Downstairs Lounge Luminance Set to 61 (Lux) Dec-31 23:17:37 Error Calling SetIOMulti in plugin iTunesDAAP:Object reference not set to an instance of an object. Dec-31 23:17:32 JW iTunes set to Paused Variables are : iTunes device - 7 : iTunes device state code - 3 Dec-31 23:17:32 Device Control Device: AV iTunes DAAP Status to Pause (3) by/from: CAPI Control Handler Dec-31 23:17:32 Event Running script in background: C:/Program Files (x86)/HomeSeer HS3/scripts/iTunes player STOP.vb("main","7") Dec-31 23:17:32 Event Event Trigger "AV iTunes Player STOP SCRIPT" Dec-31 23:17:07 JW iTunes set to Paused Variables are : iTunes device - 7 : iTunes device state code - 3 Dec-31 23:17:07 Device Control Device: AV iTunes DAAP Status to Pause (3) by/from: CAPI Control Handler Dec-31 23:17:07 Event Running script in background: C:/Program Files (x86)/HomeSeer HS3/scripts/iTunes player STOP.vb("main","7") Dec-31 23:17:07 Event Event Trigger "AV iTunes Player STOP SCRIPT"

                            Comment


                            • #44
                              Originally posted by Skinnez View Post
                              Still the same...
                              This basically happens (eventually) when trying to control iTunes from the PI.
                              This locks up HS3 to point that no other events can be run until a few minutes have passed or I disable the PI.

                              This happened when I tried to run a script that set the iTunes state to paused.
                              Any ideas?
                              were you able to spot the minimum steps needed to replicate this problem?

                              Comment


                              • #45
                                mmmmmm, interesting. I was just trying a few things and I've just got a similar error from Dirk's Mediacontroller PI!! I wonder if its the version of HS3 I'm on :/

                                Something's not quite right, any ideas??

                                Cheers

                                J

                                Comment

                                Working...
                                X