No announcement yet.

Pairing with firefly

  • Filter
  • Time
  • Show
Clear All
new posts

    Pairing with firefly


    Since I don't want to run itune on my HA server and not on my mac, is it possible to pair with the firefly media server I have installed on my storage box?

    a long time ago I tested this plugin with forked-daap which I think is a fork of firefly, and it worked, see this thread:

    forked-daap is a media-server and a media-player as well, I'm not sure if firefly can actually play some music or just stream to other players?

    If you can pair the iOS Remote app with firefly, then the iTunes DAAP should work as well


      How did you typed in the 4 numbers code in forked-daapd? (That's what I'm using also)


        I don't remember how I did the pairing with forked-daap, I would have to test again.

        Could you try to directly set the ip and port of your forked-daap server in iTunesDAAP.ini like below, then restart the plugin and see if it can connect.



          When I restart the plugin with ip and port I get this in hs3 log:

          Nov-30 23:23:06 iTunesDAAP INFO Status update Thread Killed! Nov-30 23:23:05 iTunesDAAP DEBUG Stack: at System.Net.HttpWebRequest.GetResponse() at Dmap.ContentFetcher.FetchResponse(String path, Int64 offset, String query, WebHeaderCollection extraHeaders, Int32 requestId, Boolean disableKeepalive) at Dmap.ContentFetcher.Fetch(String path, String query, WebHeaderCollection extraHeaders, Int32 requestId) at HSPI_ITUNES_DAAP.Status.PlayStatusUpdate() Nov-30 23:23:05 iTunesDAAP ERROR Exception in play status update thread, try#5: The remote server returned an error: (401) Unauthorized.

          the username of firefly is admin with no password so I don't know what unauthorized means.


            here is what you need to do to pair with forked-daap

            - from the plugin config page, clcik on "Pair with iTunes"
            - then create a hs.remote file that contains the following and put it in your music library directory. (the file needs to have the .remote extension)
            HomeSeer iTunes Plugin
            - then click the Done button in the config page

            I had to do it several times to finally got it to connect to my foreked-daap instance. Then I was able to browse the forked-daap library from HS using the Player page, but I couldn't make it play anything.

            I tried to do the same thing with iOS Remote App from an iPad, and with Retunes from an Android phone, but couldn't make it play anything either. So I probably have a problem in the config of my forked-daap instance or a bad version.

            I installed forked-daap 0.19gcd but I saw that there is a new fork that seem more active: So I may try to use that one instead and see if it works better.

            Let me know if you have more success than me. What version of forked-daap are you running? Can you control it using the Remote app
            or Retunes app?


              Well, I tried your suggestions. It seems that if I type firefly ip address manually I can pair and login but the login part is only for few seconds.

              looking at hs log I see "INFO Status update Thread Killed!"
              and "ERROR Exception in play status update thread, try#5: The remote server returned an error: (401) Unauthorized."

              I'm using firefly svn-1696

              beside that this is how iTuneDAAP config page looks after paring:
              Attached Files