Announcement

Collapse
No announcement yet.

iTunes DAAP plugin now works with HSTouch Media API, finally!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • iTunes DAAP plugin now works with HSTouch Media API, finally!

    I have tested it successfully with both the HSTouch Android Client and the HSTouch Windows client. The iOS Client will be updated soon as well.

    you need:

    - HSTouch Server plugin version 3.0.0.78 available in the Beta section of the updater
    - iTunes DAAP version 3.0.0.24 available here
    - HSTouch Android client version 1.0.0.136 posted here

    mptest.xml, attached to this post is a very simple HSTouchDesigner template for a media player screen. I will try to come up with a more fancy design, but if some of you want to share theirs, it would be cool!

    Click image for larger version

Name:	mediaapi.png
Views:	1
Size:	111.0 KB
ID:	1208436

  • #2
    Great progress!!!
    Now I have one other problem I hope you can help with or shed some light.
    Using the "Homeseer Devices" as control, there is one for each Airplay "Zone" in my HS3 web interface. If I link to that in a HSTouch project and send the "On" command, it connects to the Airtplay speaker and goes full volume.
    If I used the "Toggle On/Off" command, then it connects and goes to the last known volume. But you can't turn it off again. You can hit that button all you want. First time it connects and starts playing on that speaker but subsequent presses are ignored.
    Sending an explicit "Off" command (expecting itunes to disconnect from the airplay zone like it does from the HS3 web interface) does nothing, instead the following ERROR comes up in the log:

    Nov-14 23:26:08 HSTouch Server Error (5) CAPIHandleStatus failed with reason: Input string was not in a correct format.

    Comment


    • #3
      Originally posted by electron73 View Post
      Great progress!!!
      Now I have one other problem I hope you can help with or shed some light.
      Using the "Homeseer Devices" as control, there is one for each Airplay "Zone" in my HS3 web interface. If I link to that in a HSTouch project and send the "On" command, it connects to the Airtplay speaker and goes full volume.
      If I used the "Toggle On/Off" command, then it connects and goes to the last known volume. But you can't turn it off again. You can hit that button all you want. First time it connects and starts playing on that speaker but subsequent presses are ignored.
      Sending an explicit "Off" command (expecting itunes to disconnect from the airplay zone like it does from the HS3 web interface) does nothing, instead the following ERROR comes up in the log:

      Nov-14 23:26:08 HSTouch Server Error (5) CAPIHandleStatus failed with reason: Input string was not in a correct format.
      In version 3.0.0.25 available here I have fixed the "Toggle On/Off" action. You need to delete your airplay speaker devices, install the new version, and it will recreate the speaker devices correctly. Then you need to restart the HSTouch server plugin and probably select again the correct devices in HSTouch designer.

      Note that even before this fix the On/Off controls were working correctly for me.

      Comment


      • #4
        Originally posted by spud View Post
        In version 3.0.0.25 available here I have fixed the "Toggle On/Off" action. You need to delete your airplay speaker devices, install the new version, and it will recreate the speaker devices correctly. Then you need to restart the HSTouch server plugin and probably select again the correct devices in HSTouch designer.

        Note that even before this fix the On/Off controls were working correctly for me.
        Hi and thank you so much for the quick reply and the info. I have been super busy lately but I'll try it out this weekend. I guess there's also nothing you can do about the broken song selector in the iOS app, since it's on HS to finally release a fixed version there? I read somewhere the Android client is already fixed.

        Comment


        • #5
          Awesome work Spud. I've been testing this out and most things seems to work well. Would it be possible to let us know some of the known issues you've seen so far. What I've found is the following: The Play/Pause toggle doesn't work (have to use Play/Stop, which I assume is the same thing?), Also, I couldn't find a device for current track time, nor could I get the tracking to work. When I set a text box or slider to track via 'Position (Time) of Current Track, nothing is displayed when a song is playing.

          I'll keep looking around for more, but if you have a known's issues list, it'll save time. Here's a screenshot of my project on Android. I think textbox/listbox borders are broken in the client. Displays fine in the Windows client.
          Attached Files
          Last edited by Sireone; December 9th, 2015, 10:22 PM.

          Comment


          • #6
            Originally posted by Sireone View Post
            Awesome work Spud. I've been testing this out and most things seems to work well. Would it be possible to let us know some of the known issues you've seen so far. What I've found is the following: The Play/Pause toggle doesn't work (have to use Play/Stop, which I assume is the same thing?), Also, I couldn't find a device for current track time, nor could I get the tracking to work. When I set a text box or slider to track via 'Position (Time) of Current Track, nothing is displayed when a song is playing.

            I'll keep looking around for more, but if you have a known's issues list, it'll save time. Here's a screenshot of my project on Android. I think textbox/listbox borders are broken in the client. Displays fine in the Windows client.
            I will have a look at the Play/Pause toggle problem. For iTunes Play/Pause and Play/Stop should be the same thing.

            Position (Time) is not implemented because that would mean constantly querying itunes to know the position, I'm not sure it is even possible.

            Comment


            • #7
              Originally posted by spud View Post
              I will have a look at the Play/Pause toggle problem. For iTunes Play/Pause and Play/Stop should be the same thing.

              Position (Time) is not implemented because that would mean constantly querying itunes to know the position, I'm not sure it is even possible.
              Got it. Any time line on the iOS client?

              Sent from my XT1060 using Tapatalk

              Comment


              • #8
                wondering if you have heard when the new ios client might get published?
                HS Install Date: Feb. 16, 2007

                HS3 Pro, Z-Wave, Insteon, BLStat, HS Touch Server, MyQ

                WeatherXML, BLBackup, BLLAN, BLLock, Restart, CaddX, OpenSprinkler

                Comment


                • #9
                  Originally posted by misraels View Post
                  wondering if you have heard when the new ios client might get published?
                  I asked Rich, he said:
                  "Apple normally takes a long time to approve apps during the holiday so I will try to get it submitted early next week."

                  Comment


                  • #10
                    The new HS3Touch client (version 3.0.0.17) is now in the app store.
                    Music selector should work now with this version.

                    Comment


                    • #11
                      Guidance on setting up HSTouch with Music Page

                      Now that this is available with the iOS client I've just started messing with this. I downloaded your mptest.xml project. I can't seem to get it to pull in my list of artists though, can you give me a little direction on what the settings should be for that page element.

                      Comment


                      • #12
                        The horrendous bug with the client hanging indefinitely upon start at "getting data" until manually killed and restarted still persists
                        And the iOS client still crashes when the server goes down briefly for a reboot, instead of sitting and waiting for the server to come back up.

                        Very disappointing

                        Comment


                        • #13
                          Hi Spud. I'm using your plugin 3.0.0.26 and trying out the mptest.xml you uploaded on an android client.

                          I'm getting mixed results, possibly because there's more work for me to do on mptest.xml, I'm not sure. I'm just getting started with hstouch designer and am struggling to find much documentation or instructions. In any case, the transport and volume buttons work well. Album art is spotty at best, even though it works well in the plugin player (as does everything else).

                          What I can't do on the android client is select any music. I get lists of playlists, albums and artists just fine. Problem is I can't drill down any deeper than that. If I select artist, I can select an artist but then get no lists of albums so can't select tracks. If I select albums, I get a list of albums but selecting any one gives no results either. If I select playlists, I get a list of playlists but selecting one actually generates an error in the hs3 log:
                          ERROR The remote server returned an error: (400) Bad Request.
                          and then
                          ERROR Cannot find playlist Fleetwood Mac setlist0

                          Can you shed any light on this for me?

                          Comment


                          • #14
                            Originally posted by lakemirror View Post
                            Hi Spud. I'm using your plugin 3.0.0.26 and trying out the mptest.xml you uploaded on an android client.

                            I'm getting mixed results, possibly because there's more work for me to do on mptest.xml, I'm not sure. I'm just getting started with hstouch designer and am struggling to find much documentation or instructions. In any case, the transport and volume buttons work well. Album art is spotty at best, even though it works well in the plugin player (as does everything else).

                            What I can't do on the android client is select any music. I get lists of playlists, albums and artists just fine. Problem is I can't drill down any deeper than that. If I select artist, I can select an artist but then get no lists of albums so can't select tracks. If I select albums, I get a list of albums but selecting any one gives no results either. If I select playlists, I get a list of playlists but selecting one actually generates an error in the hs3 log:
                            ERROR The remote server returned an error: (400) Bad Request.
                            and then
                            ERROR Cannot find playlist Fleetwood Mac setlist0

                            Can you shed any light on this for me?
                            what version of HSTouch server, and HSTouch Android client are you running?

                            Comment


                            • #15
                              HSTouch server 3.0.0.91
                              client 1.0.134

                              Comment

                              Working...
                              X