Announcement

Collapse
No announcement yet.

Noob question - multiple itunes daap instances

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Noob question - multiple itunes daap instances

    I have itunes daap v 3.0.0.26 running in hs3pro on a widows 10 pc and happily paired with an itunes library on a separate windows 10 machine. Works perfectly, btw, very happy especially with the hstouch abilities.

    I'm trying to add another instance of the plugin to control itunes 12.3.2.35 on a third w10 pc. I created a new instance of the plugin and named it "rack". It created a second set of controls in devices but I can't get it to pair with the itunes library on that pc.

    When I press the pair with itunes button on the config page for the rack plugin, I get no response. The log pops up the error: Failed to listen on prefix 'http://*:4555/' because it conflicts with an existing registration on the machine.

    I've searched the forum and can't find any references to this, or any setup step that I failed to take. Help, please.

    Tom

  • #2
    Failed to listen on prefix 'http://*:4555/' because it conflicts with an existing registration on the machine.
    it means there is something else already listening on port 4555, it could be your other iTunes DAAP instance although it is only supposed to listen on this port during the paring process. So, try to disable all your iTunes DAAP instances, make sure there is no HSPI_ITUNES_DAAP.exe running in task manager, then restart the instance you want to pair.

    If it's still not working maybe another program is listening on this port. In this case you can change the port to something else than 4555. To do that edit Config/iTunesSAAP_rack.ini and add the following line in the GENERAL section

    Code:
    [GENERAL]
    pairing_service_port=4556
    then restart the plugin instance.

    of course you can try different port number if 4556 doesn't work either

    Comment


    • #3
      Originally posted by spud View Post
      it means there is something else already listening on port 4555, it could be your other iTunes DAAP instance although it is only supposed to listen on this port during the paring process. So, try to disable all your iTunes DAAP instances, make sure there is no HSPI_ITUNES_DAAP.exe running in task manager, then restart the instance you want to pair.
      One step at a time....I shut down both instance of the plugin, found 4 instances of HSPI_ITUNES.ext in the task manager and shut them down. Started the "rack" instance of the plugin. Went to the rack server and tried to pair itunes using 1234 and itunes responded "the passcode you entered was incorrect." Tried other number combos and got the same message.

      So I'm not getting the port error in hs3 anymore but itunes seems to be looking for a specific code.

      Comment


      • #4
        Update....I shut down itunes on the rack server. I shut down both instances of the plugin on the hs3 box and shut down hspi_itunes.exe in task manager. I then started the rack plugin and started itunes on the rack server. When I pressed "pair with itunes" on the plugin config page, the remote button appeared in itunes on the rack server. Pressing it and putting in a 4 number code still ended up with the "password incorrect" in itunes. Meanwhile, no errors in the hs3 log.

        So basically still at the same spot as last message, just wanted to try shutting down itunes and restarting.

        Comment


        • #5
          when you input a code in iTunes, what it does is contact the plugin on port 4555 and ask if the code is ok, the plugin always answers yes no matter what the code is. So the only thing that could go wrong is the plugin not getting the request because of a firewall or something, so try to disable firewall on both ends

          Comment


          • #6
            Disabling both firewalls allowed itunes to pair with the plugin.

            Thanks.

            Comment


            • #7
              And just to follow up, the original iteration of the plugin loaded and connected without problem.

              Looks like all is well here. Just need some time to configure the second plugin in hstouch designer. Thanks for your help.

              Comment


              • #8
                Second Music source for Media API

                I've now have my first instance of iTunes DAAP plugin working great with the media api and HSTouch.

                However I have multiple instances of iTunes DAAP plugin working controlling a few instances of iTunes. However I can't seem to figure out how to configure HSTouch to recognize those additional instances of the plugin as seperate music sources in HSTouch. For example I am trying to set up an HSTouch page to use the "music selector element" however when I go to set the properties for this element, I only have one music source to choose from. (Source 1.1 which is my original instance of the iTunes DAAP plugin) How can I get more than the Source 1.1 to show up as options in HSTouch?
                Attached Files

                Comment

                Working...
                X