Announcement

Collapse
No announcement yet.

Unable to connect with DAAP plugin

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to connect with DAAP plugin

    Hello,

    I'm new to Homeseer and the designer. I'm primarily a Mac user, but have a MacBook Pro running HStouch Designer under Windows 7.

    That being said, I have my ZS2 up and running, controlling lights, and downloading weather, ip cameras, etc.

    I am unable to get the iTunesDAAP plugin to connect.

    I get a yellow error message in the 'Manage Plugins" page saying:

    "Warning: Failed getting InterfaceStatus from itunesDAAP - the interface was not found in the list of active interfaces, the list may need to be refreshed."

    I have removed the plugin and reinstalled it. I've restarted everything. I have iTunes running on my connected iMac. Bonjour is native so I can't even reinstall it as far as I know.

    For this reason I think, I am also not showing any sign of the iTunesDAAP plugins dropdown menu for configuration??

    As an aside, I can only deploy my project to my iPad Air 2 maybe one in 50 tries. Sometimes I get a connection error, sometimes a box with two progress bars that don't move, sometimes it says it didn't transfer all of the files, sometimes it says it couldn't transfer all of the graphics and then sometimes it partially works with some of the graphics cutoff. I've also removed and reinstalled the software, and restarted everything multiple times, connecting from both the LAN and WWW. Port 10200 and HTTP ports are forwarded.

    Any help is appreciated. I hope this isn't a duplicate thread, but I couldn't find this specifically.

  • #2
    what do you get in the log when you start the iTunes DAAP plugin?

    on Linux controllers, instead of Bonjour you need to install the avahi package. To do so run the following command from the command line:

    Code:
    sudo apt-get install avahi-daemon
    then restart the plugin.

    Comment


    • #3
      Originally posted by spud View Post
      what do you get in the log when you start the iTunes DAAP plugin?

      on Linux controllers, instead of Bonjour you need to install the avahi package. To do so run the following command from the command line:

      Code:
      sudo apt-get install avahi-daemon
      then restart the plugin.
      Is that on the iMac, or SSH into the ZS2?

      Here is the log:

      Mar-03 8:38:36 PM Plug-In Finished initializing plug-in iTunesDAAP
      Mar-03 8:38:33 PM Info Plugin iTunesDAAP with instance: iMac has disconnected

      Mar-03 8:38:33 PM Error Initializing plug-in(1): iTunesDAAP Instance:iMac:System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running. at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x00000] in :0 at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider () [0x00000] in :0 at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () [0x00000] in :0 at Mono.Zeroconf.ServiceBrowser..ctor () [0x00000] in :0 at HSPI_ITUNES_DAAP.ITunesDiscoverer.Start () [0x00000] in :0 at HSPI_ITUNES_DAAP.ITunesApp.Init () [0x00000] in :0

      Mar-03 8:38:33 PM iTunesDAAP ERROR System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running. at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x00000] in :0 at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider () [0x00000] in :0 at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () [0x00000] in :0 at Mono.Zeroconf.ServiceBrowser..ctor () [0x00000] in :0 at HSPI_ITUNES_DAAP.ITunesDiscoverer.Start () [0x00000] in :0 at HSPI_ITUNES_DAAP.ITunesApp.Init () [0x00000] in :0
      Mar-0


      3 8:38:32 PM iTunesDAAP INFO iTunes plugin is not paired with any iTunes instance. Please go to iTunes plugin config page
      Mar-03 8:38:30 PM iTunesDAAP INFO iTunesDAAP version 3.0.0.26
      Mar-03 8:38:30 PM Info Plugin iTunesDAAP with instance iMac has connected. IP:127.0.0.1:56102

      Comment


      • #4
        Originally posted by SeaOtter View Post
        Is that on the iMac, or SSH into the ZS2?
        this is on the Zee S2

        Comment


        • #5
          Originally posted by spud View Post
          what do you get in the log when you start the iTunes DAAP plugin?

          on Linux controllers, instead of Bonjour you need to install the avahi package. To do so run the following command from the command line:

          Code:
          sudo apt-get install avahi-daemon
          then restart the plugin.
          I tried install avahi and got 404 Not Found

          followed by a bunch of Failed to fetch http://mmirrordirector.raspbian.org...

          Comment


          • #6
            Originally posted by SeaOtter View Post
            I tried install avahi and got 404 Not Found

            followed by a bunch of Failed to fetch http://mmirrordirector.raspbian.org...
            where did you get a "404 Not Found"?
            Did you ssh into the Zee2?
            Is the Zee2 connected to internet?
            Could you post here the whole output of the "sudo apt-get install avahi-daemon" command?

            Comment


            • #7
              Originally posted by spud View Post
              where did you get a "404 Not Found"?
              Did you ssh into the Zee2?
              Is the Zee2 connected to internet?
              Could you post here the whole output of the "sudo apt-get install avahi-daemon" command?
              homeseer@HomeTrollerZeeS2 ~ $ sudo apt-get install avahi-daemon
              sudo: unable to resolve host HomeTrollerZeeS2
              Reading package lists... Done
              Building dependency tree
              Reading state information... Done
              The following extra packages will be installed:
              bind9-host geoip-database libavahi-core7 libbind9-80 libdns88 libgeoip1
              libisc84 libisccc80 libisccfg82 liblwres80 libnss-mdns
              Suggested packages:
              avahi-autoipd geoip-bin
              The following NEW packages will be installed:
              avahi-daemon bind9-host geoip-database libavahi-core7 libbind9-80 libdns88
              libgeoip1 libisc84 libisccc80 libisccfg82 liblwres80 libnss-mdns
              0 upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
              Need to get 1,127 kB/2,964 kB of archives.
              After this operation, 8,345 kB of additional disk space will be used.
              Do you want to continue [Y/n]? Y
              Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main libisc84 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u4
              404 Not Found
              Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main libdns88 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u4
              404 Not Found
              Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main libisccc80 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u4
              404 Not Found
              Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main libisccfg82 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u4
              404 Not Found
              Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main libbind9-80 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u4
              404 Not Found
              Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main liblwres80 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u4
              404 Not Found
              Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main bind9-host armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u4
              404 Not Found
              Failed to fetch http://mirrordirector.raspbian.org/r...b7u4_armhf.deb 404 Not Found
              Failed to fetch http://mirrordirector.raspbian.org/r...b7u4_armhf.deb 404 Not Found
              Failed to fetch http://mirrordirector.raspbian.org/r...b7u4_armhf.deb 404 Not Found
              Failed to fetch http://mirrordirector.raspbian.org/r...b7u4_armhf.deb 404 Not Found
              Failed to fetch http://mirrordirector.raspbian.org/r...b7u4_armhf.deb 404 Not Found
              Failed to fetch http://mirrordirector.raspbian.org/r...b7u4_armhf.deb 404 Not Found
              Failed to fetch http://mirrordirector.raspbian.org/r...b7u4_armhf.deb 404 Not Found
              E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

              Comment


              • #8
                could you try to run

                Code:
                sudo apt-get update
                and then retry the install

                Comment


                • #9
                  Originally posted by spud View Post
                  could you try to run

                  Code:
                  sudo apt-get update
                  and then retry the install

                  That worked. Thank you.

                  Now if I could only get the full xml to deploy to my iPad...

                  Comment

                  Working...
                  X