Announcement

Collapse
No announcement yet.

Volume levels not updating

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Volume levels not updating

    It seems that the volume of the AirPlay nodes and Master Volume does not update when changed from another device or iTunes.

    However, most other controls (Track, Pause/Play, etc) do seem to update "live" when changed from another device or iTunes.

    Can the Volume controls be made to do the same?

    The reason is this: I have created keypad button events for Volume Up and Volume Down which create iTunesDAAP + and - actions. If the volume has been changed from another device, this doesn't work properly.

    For example, the volume automatically sets to 30 when first turn on. Then, I may adjust the volume to 50 with iTunes or another DAAP remote. When I use the iTunesDAAP + action, the volume goes to 35 when it should go to 55.

    If the volume control updated "live", this wouldn't happen. Alternately (and less desirably), the + control could be made to read the current volume status before updating.

  • #2
    Bump? It would be great to get this working.

    Sent from my BlackBerry Priv.

    Comment


    • #3
      in version 3.0.0.28 available here I have completely revamped the code that handles speakers, this should work a lot better now.

      Please test and let me know.

      Comment


      • #4
        Fixed for me!

        Comment


        • #5
          ok... so now I know it's a version issue for me too.

          Thanks

          Comment


          • #6
            Today, I have been getting this error when trying to set volume using iTunesDAAP.

            Restarting the plugin fixed the problem.
            Attached Files

            Comment


            • #7
              Still getting iTunes control problems from time to time. I don't know what event precipitates the problem. Restarting the plug-in fixes the issue.

              Here is the log from tonight:

              Mar-31 6:43:29 PM iTunesDAAP ERROR Cannot set speaker absolute volume: The remote server returned an error: (403) Forbidden.
              Mar-31 6:43:29 PM iTunesDAAP ERROR Error when getting master volume: The remote server returned an error: (403) Forbidden.
              Mar-31 6:43:29 PM Insteon Received 1C.4D.72:1 (Remote Living Room) Go OFF
              Mar-31 6:43:29 PM Device Control Device: iTunes iTunes DAAP Living Room to - (-1002)
              Mar-31 6:43:29 PM Event Event Trigger "Keypad Button Event Living Room Volume Down"

              Still on 3.0.0.28. Is the newer beta likely to help?

              Comment


              • #8
                Originally posted by warrenmr View Post
                Still getting iTunes control problems from time to time. I don't know what event precipitates the problem. Restarting the plug-in fixes the issue.

                Here is the log from tonight:

                Mar-31 6:43:29 PM iTunesDAAP ERROR Cannot set speaker absolute volume: The remote server returned an error: (403) Forbidden.
                Mar-31 6:43:29 PM iTunesDAAP ERROR Error when getting master volume: The remote server returned an error: (403) Forbidden.
                Mar-31 6:43:29 PM Insteon Received 1C.4D.72:1 (Remote Living Room) Go OFF
                Mar-31 6:43:29 PM Device Control Device: iTunes iTunes DAAP Living Room to - (-1002)
                Mar-31 6:43:29 PM Event Event Trigger "Keypad Button Event Living Room Volume Down"

                Still on 3.0.0.28. Is the newer beta likely to help?
                yes version 3.0.0.29 may help.
                when this problem happens are the device status updated when you try to play something from iTunes

                Comment


                • #9
                  Originally posted by spud View Post
                  yes version 3.0.0.29 may help.
                  when this problem happens are the device status updated when you try to play something from iTunes
                  I don't believe any device status are updated when this occurs (play state, album art, volume levels, etc). Certainly no controls work.

                  I have not yet tried 3.0.0.29 because the problem doesn't occur very often and it is easy to fix (restarting the plugin). I will leave 28 in place to 100% verify that status updates are not occurring when this issue arises.

                  Comment

                  Working...
                  X