Announcement

Collapse
No announcement yet.

Manually adding the port

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Manually adding the port

    I have 2 Kodi installations at home , one is being discovered automatically but there is a problem with the other which i don't understand so i'm adding it manually , i used the Kodi.ini file added everything and it's working perfectly , my problem is the port , it's automatically set to 8080 , is there anyway i can change that ?

    thanks
    Rami

  • #2
    what do you have in your ini?

    you can set the port like this:

    Code:
    [PLAYERS]
    1###name=TV Room
    1###ipaddress=192.168.1.102
    1###port=8081

    Comment


    • #3
      Thank you so much , it came to my mind right after posting the question , tried it and worked perfectly i was actually tried to delete the thread lol

      thank you so much for the quick reply

      Comment


      • #4
        Originally posted by spud View Post
        what do you have in your ini?

        you can set the port like this:

        Code:
        [PLAYERS]
        1###name=TV Room
        1###ipaddress=192.168.1.102
        1###port=8081
        This is not working. I have configured the port in the config file bust still it connects to 8080:

        Jun-26 13:42:04 Kodi DEBUG -->10.10.11.16:8080 { "jsonrpc": "2.0", "method": "Player.GetActivePlayers", "params": {}, "id": 2 }
        Jun-26 13:42:04 Kodi DEBUG <--10.10.11.16:8080 { "id": 1, "jsonrpc": "2.0", "result": { "volume": 100 } }
        Jun-26 13:42:04 Kodi DEBUG -->10.10.11.16:8080 { "jsonrpc": "2.0", "method": "Application.GetProperties", "params": { "properties": [ "volume" ] }, "id": 1 }
        Jun-26 13:42:04 Kodi DEBUG <--10.10.11.16:8080 { "id": 0, "jsonrpc": "2.0", "result": "pong" }
        Jun-26 13:42:04 Kodi DEBUG <--10.10.11.16:9090 { "id": 0, "jsonrpc": "2.0", "result": "pong" }
        Jun-26 13:42:04 Kodi DEBUG -->10.10.11.16:9090 { "jsonrpc": "2.0", "method": "JSONRPC.Ping", "params": {}, "id": 0 }
        Jun-26 13:42:04 Kodi DEBUG -->10.10.11.16:8080 { "jsonrpc": "2.0", "method": "JSONRPC.Ping", "params": {}, "id": 0 }
        Jun-26 13:42:04 Kodi DEBUG Pinging on http port 8080
        Jun-26 13:42:04 Plug-In Finished initializing plug-in Kodi
        Jun-26 13:42:04 Kodi DEBUG Connecting on tcp port 9090
        Jun-26 13:42:04 Kodi INFO Resolved Service: Kodi - _xbmc-jsonrpc-h._tcp. - 10.10.11.16 - 8080
        Jun-26 13:42:04 Kodi INFO Resolved Service: Kodi - _xbmc-jsonrpc._tcp. - 10.10.11.16 - 9090
        Jun-26 13:42:04 Kodi INFO Found Service: Kodi
        Jun-26 13:42:04 Kodi INFO Found Service: Kodi
        Jun-26 13:42:04 Kodi INFO Kodi version 3.0.1.6
        Jun-26 13:42:04 Info Plugin Kodi has connected. IP:127.0.0.1:62374

        Kodi.ini:

        [GENERAL]
        upgrade_xbmc_to_kodi_done=true
        log_level=Debug
        [PLAYERS]
        1###name=Kodi
        1###ipaddress=10.10.11.16
        1###port=8081

        This is Kodi on a Nvidia Shield, the shield is using port 8080 so cannot use that for kodi.

        Regards,

        Frans

        Comment


        • #5
          Originally posted by posixx View Post
          This is not working. I have configured the port in the config file bust still it connects to 8080:

          Jun-26 13:42:04 Kodi DEBUG -->10.10.11.16:8080 { "jsonrpc": "2.0", "method": "Player.GetActivePlayers", "params": {}, "id": 2 }
          Jun-26 13:42:04 Kodi DEBUG <--10.10.11.16:8080 { "id": 1, "jsonrpc": "2.0", "result": { "volume": 100 } }
          Jun-26 13:42:04 Kodi DEBUG -->10.10.11.16:8080 { "jsonrpc": "2.0", "method": "Application.GetProperties", "params": { "properties": [ "volume" ] }, "id": 1 }
          Jun-26 13:42:04 Kodi DEBUG <--10.10.11.16:8080 { "id": 0, "jsonrpc": "2.0", "result": "pong" }
          Jun-26 13:42:04 Kodi DEBUG <--10.10.11.16:9090 { "id": 0, "jsonrpc": "2.0", "result": "pong" }
          Jun-26 13:42:04 Kodi DEBUG -->10.10.11.16:9090 { "jsonrpc": "2.0", "method": "JSONRPC.Ping", "params": {}, "id": 0 }
          Jun-26 13:42:04 Kodi DEBUG -->10.10.11.16:8080 { "jsonrpc": "2.0", "method": "JSONRPC.Ping", "params": {}, "id": 0 }
          Jun-26 13:42:04 Kodi DEBUG Pinging on http port 8080
          Jun-26 13:42:04 Plug-In Finished initializing plug-in Kodi
          Jun-26 13:42:04 Kodi DEBUG Connecting on tcp port 9090
          Jun-26 13:42:04 Kodi INFO Resolved Service: Kodi - _xbmc-jsonrpc-h._tcp. - 10.10.11.16 - 8080
          Jun-26 13:42:04 Kodi INFO Resolved Service: Kodi - _xbmc-jsonrpc._tcp. - 10.10.11.16 - 9090
          Jun-26 13:42:04 Kodi INFO Found Service: Kodi
          Jun-26 13:42:04 Kodi INFO Found Service: Kodi
          Jun-26 13:42:04 Kodi INFO Kodi version 3.0.1.6
          Jun-26 13:42:04 Info Plugin Kodi has connected. IP:127.0.0.1:62374

          Kodi.ini:

          [GENERAL]
          upgrade_xbmc_to_kodi_done=true
          log_level=Debug
          [PLAYERS]
          1###name=Kodi
          1###ipaddress=10.10.11.16
          1###port=8081

          This is Kodi on a Nvidia Shield, the shield is using port 8080 so cannot use that for kodi.

          Regards,

          Frans
          Sorry for the delay I'm on vacation.
          you can't change the port on which Kodi is listening from the plugin, you have to do it from Kodi's settings.
          Adding the port in the ini file is only necessary if for some reason the plugin does not discover Kodi, in your case it seems that the discovery works just fine

          Comment


          • #6
            Hello Spud,

            Yes i changed the port within kodi settings because otherwise the webserver wouldn't start. So it is not detecting the correct setting; that's why i added the port manually..

            Frans

            Comment


            • #7
              Originally posted by posixx View Post
              Hello Spud,

              Yes i changed the port within kodi settings because otherwise the webserver wouldn't start. So it is not detecting the correct setting; that's why i added the port manually..

              Frans
              Your logs show that Kodi is still advertising the service on port 8080, so either you failed to change the port in Kodi's settings or there is something wrong in Kodi.
              Also, your logs show that Kodi correctly answers the ping request as well as subsequent request on port 8080, so everything looks ok with this port.

              Comment


              • #8
                Ok found the issue. Apparently SPMC (adroid fork of Kodi) was still using the port. So i uninstalled SPMC and changed port back to 8080. After that wiped plugin config; it didn't find kodi automatically, but when inserting ip etc in the kodi.ini the instance is found and works now.

                Thanks for helping me out!

                Frans

                Comment

                Working...
                X