Announcement

Collapse
No announcement yet.

System.Net.WebException after Kodi shutdown

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • System.Net.WebException after Kodi shutdown

    Hello Spud,

    When you have kodi players registered in HS and these are shutdown or suspended, the HS log shows:

    ERROR System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.IO.IOException: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult) at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult) --- End of inner exception stack trace --- at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult) at System.Net.PooledStream.EndRead(IAsyncResult asyncResult) at System.Net.Connection.ReadCallback(IAsyncResult asyncResult) --- End of inner exception stack trace --- at Microsoft.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSu ccess(Task task) at Microsoft.Runtime.CompilerServices.TaskAwaiter.HandleNonSucc ess(Task task) at Microsoft.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(T ask task) at HSPI_Kodi.KodiPlayer.d__126.MoveNext()

    As this is expected behaviour could you catch this exception and suppress this or maybe show a informational message instead?

  • #2
    when Kodi is shutdown or suspended, the zeroconf service is supposed to notify the plugin which result in a graceful disconnection without any error:
    Code:
    Sep-06 12:39:28 INFO Lost Service: Kodi (MacBook) - _xbmc-jsonrpc-h._tcp.
    Sep-06 12:39:28 INFO Lost Service: Kodi (MacBook) - _xbmc-jsonrpc._tcp.
    Sep-06 12:39:28 DEBUG Disconnecting

    Do you see the "Lost Service" lines in your logs?
    Could you post a full debug logs?

    Comment

    Working...
    X