Announcement

Collapse
No announcement yet.

Kodi/XBMC Plug-in - Beta Testing

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • you need to install bonjour, as explained in the user guide

    Comment


    • That is odd... I did install it...

      Ok, back to the drawing board... Let me reinstall it. Sorry about that, Spud.
      Transitioning to HS3Pro .298 - WinXPEmbedded

      Hometroller S3 Pro - WinXPEmbedded - HSP 2.5.0.81 - BLStat - HSPhone - HSTouch Srvr 1.0.0.73 - Touchpad - BLLan - BLOccupied - DSC Plug 2.0.0.14 - BLStat .38

      Comment


      • Hows do I use the "Radio" channels option using the event trigger.
        XBMC Action -> Player Open Media
        Instance: xxx
        Media Type: Channel
        Channel Type: Radio

        I get an error.
        Attached Files

        Comment


        • Originally posted by zakrzep View Post
          Hows do I use the "Radio" channels option using the event trigger.
          XBMC Action -> Player Open Media
          Instance: xxx
          Media Type: Channel
          Channel Type: Radio

          I get an error.
          For this to work, you need at least one PVR client add-on enabled in Kodi with some tv/radio channels.

          That being said I will try to avoid this error when no channels are found.

          Comment


          • Hi.

            I'm having connection issues with this plugin and Kodi. Sometimes it connects, and most of the time it does not.

            Kodi is running on the same network with a cable connection. I get connection from the android app "Kore" (remote) when I check for connectivity issues.
            The system is HomeSeer 3.0.0.297 on linux.

            From the log I get this:

            After system reboot:
            Jan-20 11:04:50 Plug-In Finished initializing plug-in Kodi

            Jan-20 11:04:50
            Kodi DEBUG Connecting on tcp port 9090
            Jan-20 11:04:50 Kodi INFO Resolved Service: Kodi (Odroid) - _xbmc-jsonrpc-h._tcp - 10.0.0.85 - 8080
            Jan-20 11:04:50 Kodi INFO Resolved Service: Kodi (Odroid) - _xbmc-jsonrpc._tcp - 10.0.0.85 - 9090
            Jan-20 11:04:50 Kodi INFO Found Service: Kodi (Odroid)
            Jan-20 11:04:50
            Kodi INFO Found Service: Kodi (Odroid)
            Jan-20 11:04:50 Kodi INFO Kodi version 3.0.1.0
            Clicking the "Connect" button on Device Management:
            Device: Kodi (Odroid) Root to Connect (-1) by/from: CAPI Control Handler
            Content of Kodi.ini:
            [PLAYERS]
            1###name=Kodi (Odroid)
            1###ipaddress=10.0.0.85
            1###username=kodi
            [GENERAL]
            log_level=Debug
            upgrade_xbmc_to_kodi_done=true
            [SPEAK_PROXY]
            forward_to_hs=False
            enable=True
            display_time=10
            Any advice?

            Comment


            • Hi Spud!
              Got an error message when trying to register the Kodi plugin with my license number:
              No more registrations are available for this license..
              I disabled the old XMBC plugin before I tried to register the new one. So what do I do now?
              Regards Roger

              Comment


              • Originally posted by rogerbl View Post
                Hi Spud!
                Got an error message when trying to register the Kodi plugin with my license number:
                No more registrations are available for this license..
                I disabled the old XMBC plugin before I tried to register the new one. So what do I do now?
                Regards Roger
                This should have worked, I have emailed Rich about this... will let you know when I have some news. Thanks

                Comment


                • need help. just tried to download plugin and getting this.


                  Jun-02 9:46:03 PM Error Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Kodi.exe: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)

                  Comment


                  • Originally posted by csullivan2005 View Post
                    need help. just tried to download plugin and getting this.


                    Jun-02 9:46:03 PM Error Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Kodi.exe: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)Warning, Error details with EXE HSPI_Kodi.exe: Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)
                    I think you need to install the following patch for the NET4 framework:
                    https://www.microsoft.com/en-us/down...s.aspx?id=3556

                    Comment


                    • Thanks I got it working. Is it possible to use Alexa to speak text when searching for a movie using the the send text function. Anything like this remotely possible. Or what about create a virtual device named Modern Family. If you say to Alexa turn on Modern Family will it be able to tell Homeseer that in send text for Kodi plugin.

                      Comment


                      • I'm having trouble creating an event to run a favorite. First off in Kodi local host web viewer I don't see the option for favorite in main menu. I figured how to create a main menu item. However can't figure out the URL for favourites.

                        Second when creating an event I'm trying to do the following. Player open media, Kodi local host, favourite, than when I select the favorite it shows two tv shows. I select on one and it displays than quickly vanishes and says please select. It's not letting me keep it selected within the event


                        Any idea with the two issues above. Thanks.

                        Comment


                        • If I have an amazon fire tv. Does Kodi have to be actually on all the time. For example if my amazon tv is on the amazon home menu page will this plugin not work? Confused on how this works. I have both a smart tv and an amazon fire tv. I have a Kodi app on my smart tv. Doesn't seem like this plugin works when Kodi app on tv is not up and running. Wondering how this applies to amazon fire tv as well.

                          Comment


                          • Hi Spud,

                            I have a Kodi version 17.5 running on my Qnap NAS.

                            Now I just installed HS3 with your plugin and I'm getting error...

                            I troubleshot some and fix few things, got your latest 3.0-1-11, installed package avahi-daemon, make sure all is enabled "Bonjour" on my NAS and all options in Kodi correctly set.

                            I installed ffmpeg package as well, so it went further...

                            But now this is the error I have in the logs and I'm stuck here!

                            Code:
                            Queuing plugin Kodi to load...
                            05:57:07:7586:[Plug-In]->Finished initializing plug-in Kodi
                            Plugin: Kodi Instance:  starting...
                            Connecting to server at 127.0.0.1...
                            Connection attempt #1
                            05:57:07:9183:[Info]->Plugin Kodi has connected. IP:127.0.0.1:44168
                            Connected (HomeSeer API 3). Waiting to be initialized...
                            05:57:08:1145:[Starting Plug-In]->Initializing plugin Kodi ...
                            May-26 17:57:08 INFO Kodi version 3.0.1.11
                            05:57:08:1196:[Kodi]->INFO Kodi version 3.0.1.11
                            System.DllNotFoundException: libavahi-client.so.3
                              at (wrapper managed-to-native) Avahi.Client.avahi_client_new(intptr,Avahi.ClientFlags,Avahi.ClientCallback,intptr,int&)
                              at Avahi.Client..ctor (Avahi.ClientFlags flags) [0x00052] in <fb88040940de4728bee4f76c4c09c2b5>:0
                              at Avahi.Client..ctor () [0x00000] in <fb88040940de4728bee4f76c4c09c2b5>:0
                              at Mono.Zeroconf.Providers.Avahi.ZeroconfProvider.Initialize () [0x00001] in <663a8b382afb43c3a47117d32de92186>:0
                              at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x001f1] in <350cc7bac8c6475198007c91dd299fbc>:0
                            May-26 17:57:08 ERROR System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running.
                              at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x00264] in <350cc7bac8c6475198007c91dd299fbc>:0
                              at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider () [0x0000e] in <350cc7bac8c6475198007c91dd299fbc>:0
                              at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () [0x0000f] in <350cc7bac8c6475198007c91dd299fbc>:0
                              at Mono.Zeroconf.ServiceBrowser..ctor () [0x00008] in <350cc7bac8c6475198007c91dd299fbc>:0
                              at HSPI_Kodi.KodiPlayerDiscoverer.Start () [0x00000] in <d8af49e330f44a6cb5c26365e2a25706>:0
                              at HSPI_Kodi.KodiApp.Init () [0x00293] in <d8af49e330f44a6cb5c26365e2a25706>:0
                            05:57:08:1532:[Kodi]->ERROR System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running.
                              at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x00264] in <350cc7bac8c6475198007c91dd299fbc>:0
                              at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider () [0x0000e] in <350cc7bac8c6475198007c91dd299fbc>:0
                              at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () [0x0000f] in <350cc7bac8c6475198007c91dd299fbc>:0
                              at Mono.Zeroconf.ServiceBrowser..ctor () [0x00008] in <350cc7bac8c6475198007c91dd299fbc>:0
                              at HSPI_Kodi.KodiPlayerDiscoverer.Start () [0x00000] in <d8af49e330f44a6cb5c26365e2a25706>:0
                              at HSPI_Kodi.KodiApp.Init () [0x00293] in <d8af49e330f44a6cb5c26365e2a25706>:0
                            Connection lost, exiting
                            Error sending over stream: Unable to write data to the transport connection: Cannot access a disposed object.
                            Object name: 'System.Net.Sockets.Socket'..
                            05:57:08:1565:[Info]->Plugin Kodi with instance:  has disconnected
                            Disconnected from server - client
                            05:57:08:1576:[Error]->Initializing plug-in(2): Kodi Instance::Object reference not set to an instance of an objectSTACK:  at (wrapper managed-to-native) System.Object.__icall_wrapper_mono_remoting_wrapper(intptr,intptr)
                              at (wrapper remoting-invoke) HomeSeerAPI.IPlugInAPI.InitIO(string)
                              at Scheduler.clsHSPI.CheckInterfaces () [0x000c4] in <03c63de3f1dc4fe5b4c97ebd223f29dc>:0
                            05:57:38:3008:[Starting Plug-In]->Initializing plugin Kodi ...
                            Error sending over stream: Unable to write data to the transport connection: The socket has been shut down.
                            Anything else I could check or verify?

                            Thanks in advance for help!
                            Joel

                            Comment


                            • Spud,

                              Also here is a screenshot, where the Kodi link is not active and where you don't see it in the manage of plugin.

                              Comment


                              • Originally posted by 838Joel View Post
                                Hi Spud,

                                I have a Kodi version 17.5 running on my Qnap NAS.

                                Now I just installed HS3 with your plugin and I'm getting error...

                                I troubleshot some and fix few things, got your latest 3.0-1-11, installed package avahi-daemon, make sure all is enabled "Bonjour" on my NAS and all options in Kodi correctly set.

                                I installed ffmpeg package as well, so it went further...

                                But now this is the error I have in the logs and I'm stuck here!

                                Code:
                                Queuing plugin Kodi to load...
                                05:57:07:7586:[Plug-In]->Finished initializing plug-in Kodi
                                Plugin: Kodi Instance:  starting...
                                Connecting to server at 127.0.0.1...
                                Connection attempt #1
                                05:57:07:9183:[Info]->Plugin Kodi has connected. IP:127.0.0.1:44168
                                Connected (HomeSeer API 3). Waiting to be initialized...
                                05:57:08:1145:[Starting Plug-In]->Initializing plugin Kodi ...
                                May-26 17:57:08 INFO Kodi version 3.0.1.11
                                05:57:08:1196:[Kodi]->INFO Kodi version 3.0.1.11
                                System.DllNotFoundException: libavahi-client.so.3
                                  at (wrapper managed-to-native) Avahi.Client.avahi_client_new(intptr,Avahi.ClientFlags,Avahi.ClientCallback,intptr,int&)
                                  at Avahi.Client..ctor (Avahi.ClientFlags flags) [0x00052] in <fb88040940de4728bee4f76c4c09c2b5>:0
                                  at Avahi.Client..ctor () [0x00000] in <fb88040940de4728bee4f76c4c09c2b5>:0
                                  at Mono.Zeroconf.Providers.Avahi.ZeroconfProvider.Initialize () [0x00001] in <663a8b382afb43c3a47117d32de92186>:0
                                  at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x001f1] in <350cc7bac8c6475198007c91dd299fbc>:0
                                May-26 17:57:08 ERROR System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running.
                                  at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x00264] in <350cc7bac8c6475198007c91dd299fbc>:0
                                  at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider () [0x0000e] in <350cc7bac8c6475198007c91dd299fbc>:0
                                  at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () [0x0000f] in <350cc7bac8c6475198007c91dd299fbc>:0
                                  at Mono.Zeroconf.ServiceBrowser..ctor () [0x00008] in <350cc7bac8c6475198007c91dd299fbc>:0
                                  at HSPI_Kodi.KodiPlayerDiscoverer.Start () [0x00000] in <d8af49e330f44a6cb5c26365e2a25706>:0
                                  at HSPI_Kodi.KodiApp.Init () [0x00293] in <d8af49e330f44a6cb5c26365e2a25706>:0
                                05:57:08:1532:[Kodi]->ERROR System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running.
                                  at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x00264] in <350cc7bac8c6475198007c91dd299fbc>:0
                                  at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider () [0x0000e] in <350cc7bac8c6475198007c91dd299fbc>:0
                                  at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () [0x0000f] in <350cc7bac8c6475198007c91dd299fbc>:0
                                  at Mono.Zeroconf.ServiceBrowser..ctor () [0x00008] in <350cc7bac8c6475198007c91dd299fbc>:0
                                  at HSPI_Kodi.KodiPlayerDiscoverer.Start () [0x00000] in <d8af49e330f44a6cb5c26365e2a25706>:0
                                  at HSPI_Kodi.KodiApp.Init () [0x00293] in <d8af49e330f44a6cb5c26365e2a25706>:0
                                Connection lost, exiting
                                Error sending over stream: Unable to write data to the transport connection: Cannot access a disposed object.
                                Object name: 'System.Net.Sockets.Socket'..
                                05:57:08:1565:[Info]->Plugin Kodi with instance:  has disconnected
                                Disconnected from server - client
                                05:57:08:1576:[Error]->Initializing plug-in(2): Kodi Instance::Object reference not set to an instance of an objectSTACK:  at (wrapper managed-to-native) System.Object.__icall_wrapper_mono_remoting_wrapper(intptr,intptr)
                                  at (wrapper remoting-invoke) HomeSeerAPI.IPlugInAPI.InitIO(string)
                                  at Scheduler.clsHSPI.CheckInterfaces () [0x000c4] in <03c63de3f1dc4fe5b4c97ebd223f29dc>:0
                                05:57:38:3008:[Starting Plug-In]->Initializing plugin Kodi ...
                                Error sending over stream: Unable to write data to the transport connection: The socket has been shut down.
                                Anything else I could check or verify?

                                Thanks in advance for help!
                                Joel
                                On your HS3 linux machine, try to install the libavahi-client3 package

                                Code:
                                sudo apt-get install libavahi-client3
                                then restart the Kodi plugin

                                Comment

                                Working...
                                X