Announcement

Collapse
No announcement yet.

Persistant Connection

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Persistant Connection

    Hi Again,

    I have been really enjoying this plugin and have been making use of the great built in features, to control lights etc based on Kodi on my HTPC.

    I have noticed a couple things and was wondering if you could clarify things for me in regards to how the plugin connects to the Kodi.

    I have noticed that sometimes when I exit Kodi and re open I have to actually restart the plugin and manually connect to the Kodi client. Is this supposed to happen this way? Or will the plugin attempt a connection once Kodi announces itself.

    I was trying to create an event to mitigate this (in the situation where I would reboot the Kodi HTPC)

    Essentially I wanted it to try to force a connection 5 minutes if it was disconnected.

    Any thoughts or advice on this would be appreciated.

  • #2
    the plugin is supposed to try to connect everytime a Kodi instance announce itself.
    Some other users have reported the same kind of problem, but I did not manage to replicate it so far.

    Could you tell me a bit more about your setup: HS3 running on Linux or Windows? Kodi running on Linux or Windows? version of Kodi, version of the plugin?

    does it happen everytime you restart Kodi?
    when you exit Kodi, does the root device status correctly changes to Disconnected?

    thanks

    Comment


    • #3
      Hi,

      thanks for the prompt reply!

      So initially I had issues with the Plugin finding Kodi Automatically. I realized I didn't have Bonjour on both my Windows 8 HTPC and Windows 8 HS3 machines. Since then I have installed it on both. Even after installing it I had to manually go in and change the configuration to manually Map the IP address before it appeared and connected.

      It doesn't properly notice that it is disconnected and the status shows connected although the events clearly aren't working.

      I usually have restart the plugin and manually click connect.

      One thing I notice is that it did find my Kodi Android Client automatically that I was playing around with.

      I use the latest version of Kodi (15.1 I think) and the latest version of your plugin (the beta that you put out that has the parameter field)

      Comment


      • #4
        - in Kodi settings, make sure you have "Announce these services to other systems via Zeroconf" ticked.
        - temporarily disable your firewall on both windows machine
        - shut down Kodi and the plugin
        - make sure there isn't a ghost HSPI_XBMC.exe process running
        - start the plugin
        - start Kodi

        does the plugin automatically connect?

        Comment


        • #5
          Hi Thanks for the reply,

          Firewall should be disabled on both windows machines but I will check.

          I will run through those steps as soon as I am off work.
          How long should I wait after starting things up again before it should connect?

          Comment


          • #6
            Originally posted by skarragallagher View Post
            Hi Thanks for the reply,

            Firewall should be disabled on both windows machines but I will check.

            I will run through those steps as soon as I am off work.
            How long should I wait after starting things up again before it should connect?
            less than 1 minute

            Comment


            • #7
              I'll give it 5 and let you know.

              Comment


              • #8
                So I checked the firewall and the zeroconf setting. Everything is configured properly. When I closed Kodi the plugin never was notified about the disconnect. Likewise when I started the plugin and Kodi the plugin never auto reconnected. I had to manually connect. Clearly the plugin is having issues communication issues.

                I did notice that there was an update for Bonjour. Maybe I will try again after running it.

                Any other thought in the meantime?

                Sent from my XT1254 using Tapatalk

                Comment


                • #9
                  No love as far as the update is concerned. Should I be using version 3.0? I am using 2.3.4 I think.

                  Sent from my XT1254 using Tapatalk

                  Comment


                  • #10
                    So I am doing some additional testing today. I noticed that there was a thread with someone having issues connecting due to IPv6. I have since disabled Ipv6, Disabled the zeroconf settings in Kodi and re-enabled.

                    Also I have a ceton infinitv 4 that I was using for which I had to create a network bridge to enable Network TV tuning. I have since removed the bridge and just have a standard setup.

                    Hoping that this solves the issues with auto-connect. Time will tell

                    Comment


                    • #11
                      I thought I had answered you yesterday, but somehow the post didn't go through, sorry for that.

                      any version of Bonjour should work just fine.
                      in the Kodi plugin config page set the log level to debug
                      when a Kodi instance is started on your network, you should see something like the following in your logs:

                      Code:
                      INFO Found Service: Kodi (spud)
                      INFO Found Service: Kodi (spud)
                      INFO Resolved Service: Kodi (spud) - _xbmc-jsonrpc._tcp. - 192.168.1.102 - 9090
                      INFO Resolved Service: Kodi (spud) - _xbmc-jsonrpc-h._tcp. - 192.168.1.102 - 808
                      1
                      DEBUG Connecting on tcp port 9090
                      DEBUG Pinging on http port 8081
                      if you don't see any of this, then activate the debug logging in Kodi settings, then restart Kodi and look for lines with the keyword ZeroconfMDNS in Kodi.log

                      Comment


                      • #12
                        No Problem, Thanks for the advice, this is exactly what I was looking for. I'll check the logs and post back

                        Thanks again for the help

                        Comment


                        • #13
                          I have had bigger fish to fry, but I am still working on this. Thanks for your continued help. I have yet to get to the root of the issue but since I had to rebuild by Homeseer server this was the last of my worries.

                          Stay tuned

                          Thanks

                          Comment


                          • #14
                            I think I have this working.

                            The issue was I was using an older version of bonjour (1.0) that I had found on the internet somewhere.

                            I downloaded the one in your post and it works properly now. Time will tell if they autoconnect properly but it looks promising

                            Thanks again

                            Comment


                            • #15
                              All of my connections issue have been resolved

                              Thanks again.

                              BTW what PVR backend do you use?

                              Comment

                              Working...
                              X