Announcement

Collapse
No announcement yet.

XBMC plugin not connecting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • XBMC plugin not connecting

    Hi,

    Been previously using the plugin, but its no longer working when I try to set the username and password. Automatic detection works fine - XBMC auto adds in the XBMC instance through discovery, its the connection that is failing

    Troubleshooting performed is as follows:
    - Have tried re-configuring XBMC and plugin for both with account / password & without (no difference)
    - Have tried updating all Windows Updates including .NET
    - Have tried removing all XBMC components, the plugin and then reinstalling
    - Have tried restarting homeseer

    ERROR Could not load file or assembly 'Newtonsoft.Json, Version=6.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)


    Full About Page details:
    Current Date/Time: 28/09/2015 10:23:09 PM AUS Eastern Standard Time
    HomeSeer Version: HS3 Pro Edition 3.0.0.187 (Windows)
    HomeSeer: Is Registered
    Operating System: Microsoft Windows 7 Ultimate - Work Station
    OS Version: 6.1.7601 Service Pack: 1.0
    System Uptime: 1 Day 11 Hours 50 Minutes 24 Seconds
    User Name and Access Level: admin (Admin)
    LAN IP Address: 10.0.1.10 (autom8me-PC)
    Client IP Address: 10.0.0.140 (28304L)
    External IP Address: 204.152.214.170 (204.152.214.170.static.quadranet.com)
    Network Adapter: Adapter -> Atheros AR8131 PCI-E Gigabit Ethernet Controller (NDIS 6.20) IP: 10.0.0.2/24 MAC: BC:AE:C5:0E:4F:61
    Network Adapter: D-Link DGE-530T Gigabit Ethernet Adapter (rev.B) IP: 10.0.1.10/24 MAC: 00:1C:F0:C8:8E:97
    Network Adapter: TAP-Win32 Adapter V9 IP: 10.191.1.6/30 MAC: 00:FF:FE:2B:75:41
    Network Adapter: Loopback Address (localhost) IP: 127.0.0.1
    Web Server Address:Port: 10.0.0.2:80
    Number of Devices: 285
    Number of Events: 40
    Event Last Ran: Curtains - Winter : Close Curtain - Bar - 1, Ran at 28/09/2015 6:03:25 PM
    Number of unique event scripts used: 1
    Plug-Ins Enabled: HSTouch Server:,RFXCOM:,Device Comparison 3P:,Global Cache:,weatherXML:,Z-Wave:,MyS0mfy:,SqueezeBox:,XBMC:
    Processor Type and Speed: AMD64 Family 16 Model 6 Stepping 3 at 2.89 GHz
    Modules/Threads: 118 Modules, 103 Threads
    System Processes/Load: 124 Processes, 16% Load
    Free / Total Physical Memory: 1.41 GBytes / 4.00 GBytes (35% free)
    Free / Total Virtual Memory: 4.31 GBytes / 7.99 GBytes (54% free)
    HomeSeer Memory Used: 67 Mbytes
    Plug-In Memory Used: 9 EXE Plug-Ins using 205 Mbytes

  • #2
    you probably have a version of Newtonsoft.Json.dll in your HS3 directory. (probably installed by another plugin)
    delete it and restart the XBMC plugin

    Comment


    • #3
      Fixed it - many thanks.

      Can I suggest that you put this on your install notes / stick?

      Comment

      Working...
      X