Announcement

Collapse
No announcement yet.

Samsung TV Y2016 and newer (series K and up) remote control

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by robilium View Post
    Then at some point I went back to the device page and all the buttons miraculously showed up. Not sure what I did
    There is an issue w HS3 that is doesn't automatically refreshes the devices page, so just refreshing that page has the buttons show up

    Comment


    • Trying to control my new Samsung Q9FN 65" TV, however nothing happens. Have tried version 3.0.0.33, and the beta version 3.0.0.38. However when I press any buttons on the remote, nothing happens.

      tatus is activate and Online. I have activate remote control on the TV, can control it with the Samsung App.

      Going to: http://192.168.2.247:8001/api/v2/ on a computer results in this:
      {"device":{"FrameTVSupport":"false","GamePadSupport":"tru e", "ImeSyncedSupport":"true","OS":"Tizen","TokenAuthSupport ":"t rue","VoiceSupport":"true","countryCode":"NO","description" : "Samsung DTV RCR","developerIP":"0.0.0.0","developerMode":"0","duid":"uu i d:c15fc058-0ab1-4c8d-80ca-b3f11d81e291","firmwareVersion":"Unknown","id":"uuid:c15fc05 8-0ab1-4c8d-80ca-b3f11d81e291","ip":"192.168.2.247","model":"18_KANTM2_QTV"," modelName":"QE65Q9FNA","name":"[TV] Samsung Q9 Series (65)","networkType":"wired","resolution":"3840x2160","smartH ubAgreement":"true","type":"Samsung SmartTV","udn":"uuid:c15fc058-0ab1-4c8d-80ca-b3f11d81e291","wifiMac":"c0:48:e6:c3:3b:8d"},"id":"uuid:c15f c058-0ab1-4c8d-80ca-b3f11d81e291","isSupport":"{"DMP_DRM_PLAYREADY":"false","DMP _DRM_WIDEVINE":"false","DMP_available":"true","EDEN_availabl e":"true","FrameTVSupport":"false","ImeSyncedSupport":"tr ue" ,"TokenAuthSupport":"true","remote_available":"true","rem ote _fourDirections":"true","remote_touchPad":"true","remote_voi ceControl":"true"}\n","name":"[TV] Samsung Q9 Series (65)","remote":"1.0","type":"Samsung SmartTV","uri":"http://192.168.2.247:8001/api/v2/","version":"2.0.25"}

      Any Ideas?

      Comment


      • Log when I press one of the power buttons, seem to get unauthorized...
        Attached Files

        Comment


        • Originally posted by cp1983 View Post
          Trying to control my new Samsung Q9FN 65" TV, however nothing happens. Have tried version 3.0.0.33, and the beta version 3.0.0.38. However when I press any buttons on the remote, nothing happens.

          tatus is activate and Online. I have activate remote control on the TV, can control it with the Samsung App.

          Going to: http://192.168.2.247:8001/api/v2/ on a computer results in this:
          {"device":{"FrameTVSupport":"false","GamePadSupport":"tru e", "ImeSyncedSupport":"true","OS":"Tizen","TokenAuthSupport ":"t rue","VoiceSupport":"true","countryCode":"NO","description" : "Samsung DTV RCR","developerIP":"0.0.0.0","developerMode":"0","duid":"uu i d:c15fc058-0ab1-4c8d-80ca-b3f11d81e291","firmwareVersion":"Unknown","id":"uuid:c15fc05 8-0ab1-4c8d-80ca-b3f11d81e291","ip":"192.168.2.247","model":"18_KANTM2_QTV"," modelName":"QE65Q9FNA","name":"[TV] Samsung Q9 Series (65)","networkType":"wired","resolution":"3840x2160","smartH ubAgreement":"true","type":"Samsung SmartTV","udn":"uuid:c15fc058-0ab1-4c8d-80ca-b3f11d81e291","wifiMac":"c0:48:e6:c3:3b:8d"},"id":"uuid:c15f c058-0ab1-4c8d-80ca-b3f11d81e291","isSupport":"{"DMP_DRM_PLAYREADY":"false","DMP _DRM_WIDEVINE":"false","DMP_available":"true","EDEN_availabl e":"true","FrameTVSupport":"false","ImeSyncedSupport":"tr ue" ,"TokenAuthSupport":"true","remote_available":"true","rem ote _fourDirections":"true","remote_touchPad":"true","remote_voi ceControl":"true"}\n","name":"[TV] Samsung Q9 Series (65)","remote":"1.0","type":"Samsung SmartTV","uri":"http://192.168.2.247:8001/api/v2/","version":"2.0.25"}

          Any Ideas?
          You should definitely use the version in the beta section of the updater. Recommend you do the following (after updating to latest Pi version)

          a/ make sure TV is on
          b/ make sure you have set allowance on tv for remote control
          c/ turn debug flag on
          d/ turn log to disk on
          e/ go to config page and remove the remote device
          f/ add (again) the remote device, make sure you are in front of your TV to confirm (or at least I think you need to confirm)
          g/ go to device management page and click on create remote buttons
          h/ click on one of the buttons
          i/ turn log to disk off (DON'T FORGET THIS STEP)

          If it doesn't work, post the disk log file (found <hsroot>/html/MediaController/Logs/MediaControllerDebug.txt

          Are your running this on Windows or Linux?

          After you post the log (because it doesn't work), turn the log to disk back on, restart hs, wait until all on-line, try some of the buttons, turn log to disk off, post log file. Note at all time, debug remained ON!

          Cheers,

          Dirk

          Comment


          • I just tried updating the PI from .33 to .38 beta. I turned off the PI, the pressed update. Install failed. Do I have to disable the PI, reboot, then update ?

            Comment


            • Originally posted by mikee123 View Post
              I just tried updating the PI from .33 to .38 beta. I turned off the PI, the pressed update. Install failed. Do I have to disable the PI, reboot, then update ?
              try restart hs.

              Comment


              • Hi

                Attached is the log while following the steps above.

                Note I do not get any questions on confirmation on the TV when I add the remote device. IP control is enabled.

                Regards
                Christian
                Attached Files

                Comment


                • Here is the log after restarting Homeseer.

                  I am running homeseer on Ubuntu 18.04.1
                  Attached Files

                  Comment


                  • Originally posted by cp1983 View Post
                    Hi

                    Attached is the log while following the steps above.

                    Note I do not get any questions on confirmation on the TV when I add the remote device. IP control is enabled.

                    Regards
                    Christian
                    A quick search of the error showed a posting by somebody with same error but found that the app was denied. So check your settings. On my TV it is under Network-> MultiMedia Device Manager where you find a list of all allowed or denied applications.

                    Comment


                    • Originally posted by cp1983 View Post
                      Hi

                      Attached is the log while following the steps above.

                      Note I do not get any questions on confirmation on the TV when I add the remote device. IP control is enabled.

                      Regards
                      Christian
                      oh oh, I'm seeing some postings from around October, stating that a recent FW update (1250) to the TV seems to have "broken" all the 3rd party apps. If true, this could be by mistake or intentionally. So far I haven't seen any posting of what change it might have been except one user stating: "doesn't work anymore with SmartView either but still works with SmartThings". If someone can take wireshark traces we might be able to figure it out, unless it is all encrypted. Let me know what you find. At least there should be a request popping up on the TV to allow access, unless that access was authorized in the past or denied in the past.

                      Comment


                      • Hi

                        On the device listings, I can see our two phones are enabled as i accepted those in the popup on the TV when I first connected those to the TV. Have not gotten any popup at all while trying to connect to the TV from homeseer.

                        I have run wireshark while adding the tv remote in homeseer. I cannot see any traffic going from the homeseer IPaddress to the TV ipaddress.

                        Anything special you want me to try while capturing packets?

                        Regards
                        Christian

                        Comment


                        • Hi,

                          Tried againAfter 7 minutes there was communication between the TV and Homeseer. However I cannot make anything of the capture file.

                          Regards,
                          Christian

                          Comment


                          • Originally posted by cp1983 View Post
                            Hi

                            On the device listings, I can see our two phones are enabled as i accepted those in the popup on the TV when I first connected those to the TV. Have not gotten any popup at all while trying to connect to the TV from homeseer.
                            So are your phones still working? Is this the Smartthing app or Smartview app? Can you check which SW/FW version is on your TV?

                            In the mean time I found more postings where people figured out (or better, are figuring it out as they still have issues) that with the introduction of FW update 1250, the port to use now is 8002 (instead of 8001) but more importantly use SSL which is quite a challenge for this PI.

                            Before I even go there to code in SSL, I need to figure out how to determine that the TV works per old protocol or new. Any chance you can capture some info of your tv for me? If you go to the PI's config page, at the bottom, there is button "Log Whole Network". Can you click on that and go to <hs root>/html/MediaController/SearchResults and zip up all files in that directory and post or pm me. I noticed you are on a linux box so perhaps a bit harder to get files of it. Another option is to click on "view upnp devices". This will open another screen. Take a screenshot of what you see. Focus on the Samsung devices, where-ever you see blue hyperlinked items, click on those, take screenshots and follow the hyperlinks until there are no more. Post all the screenshots or pm them to me.

                            Dirk

                            Comment


                            • Originally posted by cp1983 View Post
                              Hi

                              On the device listings, I can see our two phones are enabled as i accepted those in the popup on the TV when I first connected those to the TV. Have not gotten any popup at all while trying to connect to the TV from homeseer.

                              I have run wireshark while adding the tv remote in homeseer. I cannot see any traffic going from the homeseer IPaddress to the TV ipaddress.

                              Anything special you want me to try while capturing packets?

                              Regards
                              Christian
                              cp1983 can you type the following into a browser. Make sure you are in front of the TV, it may prompt for allowance.

                              http://192.168.2.247:8001/api/v2/

                              could you paste the response.

                              Thanks,

                              Dirk

                              Comment


                              • Sent you the SearchResults.zip on a PM.

                                Checked the TV version, version is 1153. Disabled automatic update.

                                Clicked on the link got a popup on the TV which I approved, got this result:
                                {"device":{"FrameTVSupport":"false","GamePadSupport":"true", "ImeSyncedSupport":"true","OS":"Tizen","TokenAuthSupport":"t rue","VoiceSupport":"true","countryCode":"NO","description": "Samsung DTV RCR","developerIP":"0.0.0.0","developerMode":"0","duid":"uui d:c15fc058-0ab1-4c8d-80ca-b3f11d81e291","firmwareVersion":"Unknown","id":"uuid:c15fc05 8-0ab1-4c8d-80ca-b3f11d81e291","ip":"192.168.2.247","model":"18_KANTM2_QTV"," modelName":"QE65Q9FNA","name":"[TV] Samsung Q9 Series (65)","networkType":"wired","resolution":"3840x2160","smartH ubAgreement":"true","type":"Samsung SmartTV","udn":"uuid:c15fc058-0ab1-4c8d-80ca-b3f11d81e291","wifiMac":"c0:48:e6:c3:3b:8d"},"id":"uuid:c15f c058-0ab1-4c8d-80ca-b3f11d81e291","isSupport":"{"DMP_DRM_PLAYREADY":"false","DMP _DRM_WIDEVINE":"false","DMP_available":"true","EDEN_availabl e":"true","FrameTVSupport":"false","ImeSyncedSupport":"true" ,"TokenAuthSupport":"true","remote_available":"true","remote _fourDirections":"true","remote_touchPad":"true","remote_voi ceControl":"true"}\n","name":"[TV] Samsung Q9 Series (65)","remote":"1.0","type":"Samsung SmartTV","uri":"http://192.168.2.247:8001/api/v2/","version":"2.0.25"}

                                Tried the same link from my linux box running Homeseer, then I did not get any popup on the TV, however I got this result:

                                device
                                FrameTVSupport "false"
                                GamePadSupport "true"
                                ImeSyncedSupport "true"
                                OS "Tizen"
                                TokenAuthSupport "true"
                                VoiceSupport "true"
                                countryCode "NO"
                                description "Samsung DTV RCR"
                                developerIP "0.0.0.0"
                                developerMode "0"
                                duid "uuid:c15fc058-0ab1-4c8d-80ca-b3f11d81e291"
                                firmwareVersion "Unknown"
                                id "uuid:c15fc058-0ab1-4c8d-80ca-b3f11d81e291"
                                ip "192.168.2.247"
                                model "18_KANTM2_QTV"
                                modelName "QE65Q9FNA"
                                name "[TV] Samsung Q9 Series (65)"
                                networkType "wired"
                                resolution "3840x2160"
                                smartHubAgreement "true"
                                type "Samsung SmartTV"
                                udn "uuid:c15fc058-0ab1-4c8d-80ca-b3f11d81e291"
                                wifiMac "c0:48:e6:c3:3b:8d"
                                id "uuid:c15fc058-0ab1-4c8d-80ca-b3f11d81e291"
                                isSupport "{"DMP_DRM_PLAYREADY":"false","DMP_DRM_WIDEVINE":"false","DM P_available":"true","EDEN_available":"true","FrameTVSupport" :"false","ImeSyncedSupport":"true","TokenAuthSupport":"true" ,"remote_available":"true","remote_fourDirections":"true","r emote_touchPad":"true","remote_voiceControl":"true"}\n"
                                name "[TV] Samsung Q9 Series (65)"
                                remote "1.0"
                                type "Samsung SmartTV"
                                uri "http://192.168.2.247:8001/api/v2/"
                                version "2.0.25"


                                Regards

                                Christian

                                Comment

                                Working...
                                X