Announcement

Collapse
No announcement yet.

Help! Remote and MultiScreen no longer work after TV reset

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help! Remote and MultiScreen no longer work after TV reset

    I had to reset my LG B7 TV and now I've lost the ability to change inputs and such. Remote and MultiScreen apparently have new IDs now. I edited the .ini file to replace the old IDs with the new IDs, then restarted the plugin. Everything appears to be online again, but clicking buttons to change things does nothing. What have I missed?

    I have events using these devices and do not want to have to go back and change everything.
    HomeSeer 3, Insteon, Z-wave, USB-UIRT, Google Hub/Chromecasts/Smart Speakers, Foscam cameras, Amcrest camera, RCA HSDB2a doorbell
    Plugins: BLLAN, BLOccupied, BLUSBUIRT, Chromecast, Insteon, Jon00 Homeseer/Echo Skill Helper, Jon00 DB Charting, MediaController, NetCAM, PHLocation2, Pushover 3P, weatherXML, Z-wave

    #2
    Originally posted by mrceolla View Post
    I had to reset my LG B7 TV and now I've lost the ability to change inputs and such. Remote and MultiScreen apparently have new IDs now. I edited the .ini file to replace the old IDs with the new IDs, then restarted the plugin. Everything appears to be online again, but clicking buttons to change things does nothing. What have I missed?

    I have events using these devices and do not want to have to go back and change everything.
    You changed what in the .ini file? what do you mean by IDs? There should never be a reason to change anything manually in the .ini file. If for some reason the TV has a new IP address, it will be discovered and updated, if for some reason it gets a new UDN, you would find it in the device table and add it and use the remove button to remove the old.
    IF the TV has another UDN (have never seen that), you would have to allow the remote again.

    Comment


      #3
      Never mind, I think. I discovered a 2nd .ini file for Remote and replaced the IDs in there as well, leaving the image paths with the old ID. After saving the file and restarting the plugin, I regained the ability to change inputs via HS. I think everything is good now, unless there's a 3rd .ini somewhere else. If you can think of anything else I should change, please let me know.
      HomeSeer 3, Insteon, Z-wave, USB-UIRT, Google Hub/Chromecasts/Smart Speakers, Foscam cameras, Amcrest camera, RCA HSDB2a doorbell
      Plugins: BLLAN, BLOccupied, BLUSBUIRT, Chromecast, Insteon, Jon00 Homeseer/Echo Skill Helper, Jon00 DB Charting, MediaController, NetCAM, PHLocation2, Pushover 3P, weatherXML, Z-wave

      Comment


        #4
        Originally posted by dcorsus View Post

        You changed what in the .ini file? what do you mean by IDs? There should never be a reason to change anything manually in the .ini file. If for some reason the TV has a new IP address, it will be discovered and updated, if for some reason it gets a new UDN, you would find it in the device table and add it and use the remove button to remove the old.
        IF the TV has another UDN (have never seen that), you would have to allow the remote again.
        Yes, UDN is what I was referring to as ID. The reason I edited it is because I did not want new HS devices and then need to update all my events. I did have to re-allow the plugin to connect to my TV via a message box on my TV. For some reason, after the factory reset, MultiScreen and Remote got new UDNs. Player did not. I then had 5 items listed for my TV in the plugin config. The 3 original, with 2 being offline, and the 2 new ones which were online. I then performed the edits described above.

        Does that clear up my situation?
        HomeSeer 3, Insteon, Z-wave, USB-UIRT, Google Hub/Chromecasts/Smart Speakers, Foscam cameras, Amcrest camera, RCA HSDB2a doorbell
        Plugins: BLLAN, BLOccupied, BLUSBUIRT, Chromecast, Insteon, Jon00 Homeseer/Echo Skill Helper, Jon00 DB Charting, MediaController, NetCAM, PHLocation2, Pushover 3P, weatherXML, Z-wave

        Comment


          #5
          Originally posted by mrceolla View Post

          Yes, UDN is what I was referring to as ID. The reason I edited it is because I did not want new HS devices and then need to update all my events. I did have to re-allow the plugin to connect to my TV via a message box on my TV. For some reason, after the factory reset, MultiScreen and Remote got new UDNs. Player did not. I then had 5 items listed for my TV in the plugin config. The 3 original, with 2 being offline, and the 2 new ones which were online. I then performed the edits described above.

          Does that clear up my situation?
          UDNs don't tend to change, hence that's why they are called UNIQUE but I guess a factory reset does cause them to change.

          I'm still concerned that you might have overlooked something in the ,ini file so I would not recommend you go that path but that is your decision

          Comment


            #6
            I realize manually editing config files could go badly. I made a backup in case.

            I am concerned about overlooking something as well ;-) Let me outline my steps more clearly for others' potential benefit in the future, and for you to maybe see if I missed something.

            First, does this plugin only have the 2 .ini files?

            In the main config file, I first searched for and removed all references to the two new UDNs. These were only in two location: near the top of the config where it lists all found devices in one line for each, and the multi-line device details block. After all references to the new UDNs were removed, I then did a find/replace on the old UDNs to switch them to the new ones. The old UDNs were in more locations within the config file, and more numerous, since they have been added to HS.

            In the remote-specific ini file, I had only one old UDN to worry about. I did a find/replace to update it to the new, correct UDN, except for the image filenames which contained the old UDN. I figured the images were created during the 'add to HS' process with the old UDNs, and I never did the add process on the new UDNs, so images with the new UDN in the filenames wouldn't exist. Only 2 or 3 instances needed to get changed here.

            I then stopped the plugin, saved my edits, then restarted the plugin. My Remote device appears to be working just fine. I'm not sure what MultiScreen does or how to test that, but it appears Online and Offline when it should. The Player UDN never changed.

            Can you think of anything I may have overlooked?

            I'm sure my situation is rare, and this may be impractical, but it might be nice if there was a way to update a device's UDN in the plugin or have a way to 'replace' an existing, added device with a newly found device, and have the plugin take care of all necessary replacements, to avoid having to create new HS devices and updating all events. This would be useful for my factory reset situation. It might also be helpful when replacing a device with a new one. I realize the latter may be far more complicated since devices can have different characteristics, inputs, etc., but it still might help make swapping out devices easier. We'll all get new TVs someday. Just a thought.
            HomeSeer 3, Insteon, Z-wave, USB-UIRT, Google Hub/Chromecasts/Smart Speakers, Foscam cameras, Amcrest camera, RCA HSDB2a doorbell
            Plugins: BLLAN, BLOccupied, BLUSBUIRT, Chromecast, Insteon, Jon00 Homeseer/Echo Skill Helper, Jon00 DB Charting, MediaController, NetCAM, PHLocation2, Pushover 3P, weatherXML, Z-wave

            Comment

            Working...
            X