Announcement

Collapse
No announcement yet.

MeiKu No Roku's Found

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MeiKu No Roku's Found

    Hello,

    I am trying to use the MeiKu Roku plugin following the available information and I cannot get it to discover any of the three Roku's on the network. I have 2 Roku 3 and a Roku 4, all running in the same subnet as my HS3 box.

    A root device for the MeiKu plugin is created; however, nothing else appears to happen.

    I tried a few different things, including:
    * Disabling Windows Firewall
    * Disabling Webroot Anti-Virus
    * Deleted plugin and config files




    System:
    Code:
    Current Date/Time: 6/13/2017 10:01:03 PM
    HomeSeer Version: HS3 Pro Edition 3.0.0.318
    Operating System: Microsoft Windows 10 Pro - Work Station
    System Uptime: 0 Days 0 Hours 40 Minutes 7 Seconds
    IP Address: 192.168.6.20
    Number of Devices: 184
    Number of Events: 15
    Available Threads: 800
    
    Enabled Plug-Ins
    2.0.47.0: BLBackup
    3.0.0.68: HSTouch Server
    1.1.2.9: JowiHue
    3.0.0.0: MeiKu
    1.5.0.0: MQTT
    3.0.0.28: Nest
    0.0.0.31: Pushover 3P
    3.1.0.20: Sonos
    3.0.1.128: Z-Wave
    config.ini
    Code:
    [settings]
    RootDeviceRef=196
    DiscoveryTimeout=00:00:30
    DiscoveryInterval=00:10:00
    DevicePollInterval=00:01:00
    CreateHeadPhonesDevice=True
    DebugLogging=True
    HsLoggingLevel=Debug

    Debug Log
    Code:
    2017-06-13 21:22:00,519 DEBUG [3] HSPI - {"DiscoveryInterval":"00:10:00","DiscoveryTimeout":"00:00:30","DeviceAppPollInterval":"00:45:00","DevicePollInterval":"00:01:00","CreateHeadPhonesDevice":false,"CreateApplicationsDevice":false,"CreateControlDevice":false,"DebugLogging":true,"HsLoggingLevel":1,"DeleteUninstalledApps":false}
    2017-06-13 21:22:03,363 INFO [3] HSPI - Discovery: Starting Roku discovery with a timeout of 00:00:30
    2017-06-13 21:22:33,768 INFO [14] HSPI - Discovery: Discovery scan complete. Checking found devices.
    2017-06-13 21:22:33,768 DEBUG [14] HSPI - {}
    2017-06-13 21:22:33,799 INFO [14] HSPI - Discovery: Discovery complete. 0 found; 0 new
    2017-06-13 21:23:00,562 INFO [14] HSPI - Polling Device: 6/13/2017 9:23:00 PM
    2017-06-13 21:23:00,655 INFO [3] HSPI - Discovery: Starting Roku discovery with a timeout of 00:00:30
    2017-06-13 21:23:30,951 INFO [14] HSPI - Discovery: Discovery scan complete. Checking found devices.
    2017-06-13 21:23:30,951 DEBUG [14] HSPI - {}
    2017-06-13 21:23:30,983 INFO [14] HSPI - Discovery: Discovery complete. 0 found; 0 new
    2017-06-13 21:24:00,575 INFO [18] HSPI - Polling Device: 6/13/2017 9:24:00 PM
    2017-06-13 21:25:00,589 INFO [18] HSPI - Polling Device: 6/13/2017 9:25:00 PM
    2017-06-13 21:26:00,603 INFO [18] HSPI - Polling Device: 6/13/2017 9:26:00 PM
    2017-06-13 21:26:28,045 WARN [3] HSPI - Device creation: No known devices to create
    2017-06-13 21:26:29,420 WARN [3] HSPI - Device creation: No known devices to create
    2017-06-13 21:26:30,279 WARN [3] HSPI - Device creation: No known devices to create

  • #2
    Did you go into the config screen (Plugins -> MeiKu -> Config) and go to the Roku tab and check "create" devices for those rokus?

    Do you have Devices listed at all under that tab?

    If not you can try increasing the discovery timeout on the first tab to say a minute and clicking "discovery" again on the Roku tab.
    Thanks,
    Frank

    Comment


    • #3
      Nevermind. I missed it in the logs where it says there are no devices found. Do you have uPnP enabled on your router? I think this might be necessary to discover the rokus. If that doesn't work, I will create a screen to manually add one by IP address if that suits your needs but you will have to have them set with static IPs either on the Roku (which is possible) or via a Static DHCP assignment on your router. I can have it done in the next day or two. It was on my list of things to add anyways.
      Thanks,
      Frank

      Comment


      • #4
        No worries. You are correct I do not have any any devices. I do not have uPnP of my router (enterprise gear so not even an option). My Rokus already have a static IP addresses as I selectively VPN those to work with certain content restrictions so a manual add would work great for me.

        Sent from my Pixel XL using Tapatalk

        Comment


        • #5
          Originally posted by NerdBitMN View Post
          No worries. You are correct I do not have any any devices. I do not have uPnP of my router (enterprise gear so not even an option). My Rokus already have a static IP addresses as I selectively VPN those to work with certain content restrictions so a manual add would work great for me.

          Sent from my Pixel XL using Tapatalk
          In that case I'll add a way to have you add them manually if that works for you.

          If you want to see if it's your network (which I'm doubtful it is), you could see if the Roku App from the google play store finds your Rokus. If it can, then it's something on my end. This is my first experience with ssdp discovery so I wouldn't be surprised if I messed something up (though it does work locally for me).
          Thanks,
          Frank

          Comment


          • #6
            I do use the Roku app already and it's auto discover process works.

            Sent from my Pixel XL using Tapatalk

            Comment


            • #7
              Is it possible for me to manually add the roku to the ini file if I know the format that is expected?

              Sent from my Pixel XL using Tapatalk

              Comment


              • #8
                Roku Plugin Install issue

                Hello, I am glad to see a plugin for Roku units.

                I have downloaded it to test before purchase but, I am having an issue. It was successfully downloaded and installed but, when I enable the plugin, I get the following message for the plugin status.

                WARNING: Failed getting InterfaceStatus from MeiKu - the interface was not found in the list of active interfaces, the list may need to be refreshed.

                I have refreshed the screen and also disabled and re-enabled the plugin and still get the warning.

                Please advise.


                Current Date/Time: 6/16/2017 12:54:33 AM
                HomeSeer Version: HS3 Pro Edition 3.0.0.318
                Operating System: Microsoft Windows Embedded Standard - Work Station
                System Uptime: 0 Days 3 Hours 55 Minutes 27 Seconds
                IP Address: 192.168.1.11
                Number of Devices: 474
                Number of Events: 89
                Available Threads: 200

                Enabled Plug-Ins
                2.0.34.0: BLSecurity
                0.0.0.21: drhsIpPlugIn
                1.0.0.0: HikAlarmCheck
                3.0.0.75: HSTouch Server
                3.0.0.0: MeiKu
                3.0.6132.16975: UltraGCIR3
                3.0.6092.18438: UltraHTDAudio3
                3.0.6196.17229: UltraPioneerAVR3
                3.0.6171.18152: UltraTivo3
                3.0.1.124: Z-Wave

                Comment


                • #9
                  Please note, upon further research, there is no error listed within Homeseer but, it looks like this plugin requires .net framework 4.6.1. This is not provided with a Homeseer S6 Pro device, which is running Windows Embedded Standard. I will contact Homeseer Tech support and review options.

                  Comment


                  • #10
                    Originally posted by NerdBitMN View Post
                    Is it possible for me to manually add the roku to the ini file if I know the format that is expected?

                    Sent from my Pixel XL using Tapatalk
                    No, i actually store most the configuration in the main root device. I had a deployment last night for my day job so i'm a bit behind, but I'm hoping to have the manual add screen done this weekend. Sorry it's taking so long.
                    Thanks,
                    Frank

                    Comment


                    • #11
                      Originally posted by morrisdlx View Post
                      Please note, upon further research, there is no error listed within Homeseer but, it looks like this plugin requires .net framework 4.6.1. This is not provided with a Homeseer S6 Pro device, which is running Windows Embedded Standard. I will contact Homeseer Tech support and review options.
                      I didn't know there was a restriction on the .net framework version. What version does the s6 pro have? Maybe I can downgrade the version I use.
                      Thanks,
                      Frank

                      Comment


                      • #12
                        In order to give as much info as possible I have copied data that I had posted elsewhere....

                        This morning, I downloaded the MeiKu Roku plugin.
                        Results:
                        • My first challenge seemed to be that the plugin installed but had a Warning message stating that the screen may need to be refreshed. Upon looking closer, I noted that the Roku plugin was requiring .NET Framework 4.6.1 to function.
                        • As I am running a Homeseer HomeTroller S6 Pro which has Windows Embedded Standard installed, I was not sure I could update .NET without causing problems. I called Homeseer Tech Support (Mat) who verified that there would be no issues with upgrading to 4.6.1.
                        • I upgraded .NET but, the Roku app was still not functioning. I disabled and enable it only to have it notify me that the app had crashed. I uninstalled the plugin and all references and reinstalled it.
                        • The plugin started and when I went to configure it using the Manage Plugin tab, the system became extremely sluggish. I disabled the plugin and the system response returned to normal.
                        • I enabled the plugin and it crashed again.
                        Please advise is there an installation sequence I need to use? I very much hope that the plugin is compatible with the HomeTroller S6 platform.

                        Current Date/Time: 6/16/2017 1:35:40 PM
                        HomeSeer Version: HS3 Pro Edition 3.0.0.318
                        Operating System: Microsoft Windows Embedded Standard - Work Station
                        System Uptime: 0 Days 0 Hours 18 Minutes 14 Seconds
                        IP Address: 192.168.1.11
                        Number of Devices: 475
                        Number of Events: 89
                        Available Threads: 199

                        Enabled Plug-Ins
                        2.0.34.0: BLSecurity
                        0.0.0.21: drhsIpPlugIn
                        1.0.0.0: HikAlarmCheck
                        3.0.0.75: HSTouch Server
                        3.0.0.0: MeiKu
                        3.0.6132.16975: UltraGCIR3
                        3.0.6092.18438: UltraHTDAudio3
                        3.0.6196.17229: UltraPioneerAVR3
                        3.0.6171.18152: UltraTivo3
                        3.0.1.124: Z-Wave

                        Comment


                        • #13
                          See my response here: https://forums.homeseer.com/showpost...43&postcount=3

                          and I also sent you a PM on how to send me debug logs.
                          Thanks,
                          Frank

                          Comment


                          • #14
                            Originally posted by NerdBitMN View Post
                            Is it possible for me to manually add the roku to the ini file if I know the format that is expected?

                            Sent from my Pixel XL using Tapatalk
                            I don't want you to think I forgot you. I had planned on working on this this weekend, but my wife had plans for Father's day I had not accounted for. Once we get the kids to sleep tonight, I'm gonna get work on this and some other needed things such as an (even more) robust error handling in the plugin.
                            Thanks,
                            Frank

                            Comment


                            • #15
                              Originally posted by NerdBitMN View Post
                              Is it possible for me to manually add the roku to the ini file if I know the format that is expected?

                              Sent from my Pixel XL using Tapatalk
                              @NerdBitMN, I have updated the plugin. At the bottom of the "Roku" config tab, there is a text input box for you to enter an IP address. Enter the IP address of a Roku and click "Add by IP". This was quick and dirty. I'll pretty it up later. I just wanted to get this done for you.

                              Note that the Rokus use port 8060 for communication, so you may need to allow access to that port within your network. The plugin should let you know if it was successful or not. Also note that this will just add the device to the plugin's list of "known devices" Once it shows up in the list you'll have to check the "create devices" checkbox for each Roku in the list to have the plugin create the HomeSeer devices.

                              In addition, if you get it working and at some point you change the IP address, you can enter the new IP address in the same box, click "Add by IP" again and it will update the existing device(s) (based on serial number) with the new location so you don't have to delete and re-add devices.

                              I'm still not sure why discovery isn't working. If you want to try it, you could increase the Discovery Timeout to like a minute or so and click "Discover Rokus" on the Rokus tab. However, since you have static IPs, adding them manually should work.
                              Thanks,
                              Frank

                              Comment

                              Working...
                              X