Announcement

Collapse
No announcement yet.

MeiKu No Roku's Found

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Dave,

    I added more debugging to the plugin, hopefully this will at least get the plugin to start up so we can get some debug info out of it. Let me know how it works.
    Thanks,
    Frank

    Comment


    • #17
      Hi @sirmeili,

      First, sorry for the delay I have been working on quite a few outdoor projects while the weather is nice.

      I have the following findinds

      Scenario #1: Autodiscover
      - uPnP is absolutely required for automatic discovery to work
      - Test: Swapped in cheap router, enabled uPnP all devices discovered
      - Test: Clean plugin and install, disable uPnP in router: no devices discovered

      I do find it odd that uPnP is required even though HS3 and Roku are on the same subnet/vlan

      Scenario #2: Manual IP
      - This works great, added by IP and everything worked as intended

      Overall outcome: I will likely use this plugin in the future, it does exactly what is intended. For now, my trial expires in 4 days and will add to the list of future plugins.



      Thanks,
      Donald

      Comment


      • #18
        Originally posted by NerdBitMN View Post
        Hi @sirmeili,

        First, sorry for the delay I have been working on quite a few outdoor projects while the weather is nice.

        I have the following findinds

        Scenario #1: Autodiscover
        - uPnP is absolutely required for automatic discovery to work
        - Test: Swapped in cheap router, enabled uPnP all devices discovered
        - Test: Clean plugin and install, disable uPnP in router: no devices discovered

        I do find it odd that uPnP is required even though HS3 and Roku are on the same subnet/vlan

        Scenario #2: Manual IP
        - This works great, added by IP and everything worked as intended

        Overall outcome: I will likely use this plugin in the future, it does exactly what is intended. For now, my trial expires in 4 days and will add to the list of future plugins.



        Thanks,
        Donald
        So I looked into this. I don't have uPnP turned on in my router (Ubiquiti Edge Router Light). I am using SSDP, which is the basis for uPnPs discovery process. It could be that your normal router is somehow blocking SSDP from working. I believe SSDP uses multicast on UTP port 1900.

        Either way. I'm glad the manual way worked
        Thanks,
        Frank

        Comment


        • #19
          Originally posted by sirmeili View Post
          So I looked into this. I don't have uPnP turned on in my router (Ubiquiti Edge Router Light). I am using SSDP, which is the basis for uPnPs discovery process. It could be that your normal router is somehow blocking SSDP from working. I believe SSDP uses multicast on UTP port 1900.

          Either way. I'm glad the manual way worked

          It is funny you mention that since I am using the EdgeRouter Pro. Reading the release notes I did find they added uPnP a while back; however, I have not tried enabling it yet. For laughs I would be curious if the following shows as enabled for you.

          Code:
          ubnt@ubnt:~$ configure
          [edit]
          ubnt@ubnt# show service upnp
          Configuration under specified path is empty
          [edit]
          ubnt@ubnt# show service upnp2
          Configuration under specified path is empty
          [edit]
          ubnt@ubnt#

          Comment


          • #20
            Originally posted by NerdBitMN View Post
            It is funny you mention that since I am using the EdgeRouter Pro. Reading the release notes I did find they added uPnP a while back; however, I have not tried enabling it yet. For laughs I would be curious if the following shows as enabled for you.

            Code:
            ubnt@ubnt:~$ configure
            [edit]
            ubnt@ubnt# show service upnp
            Configuration under specified path is empty
            [edit]
            ubnt@ubnt# show service upnp2
            Configuration under specified path is empty
            [edit]
            ubnt@ubnt#
            Mine shows the same. I"m thinking maybe multicast isn't set up? I know in olderversions it was not supported. I'm on EdgeOS 1.8.5 (which is probably old as well).
            Thanks,
            Frank

            Comment

            Working...
            X