Announcement

Collapse
No announcement yet.

Run as a remote plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Run as a remote plugin

    Hi, is it possible to run the MeiKu plugin from a machine other than the HS3?

    Basically the connection for the plugin needs to connect to an IP address other than 127.0.0.1. Perhaps a command line option could allow this (how I have done it with my plugins).

    The reason I ask is my Roku box is on another segment and it has been configured to talk to a VPN router for Internet access meaning it can't see other subnets in my local network. It can therefore only communicate locally on it's local subnet and the HS3 server is not there.

    What I need to do is install this plugin on the same subnet as the Roku and then have the plugin connect over the internal network to the HS3 server (via a layer 3 switch).

    4 boxes in the IP flow:

    HS3 > L3 switch > MeiKu plugin > Roku

    For this to work, I need a version of the plugin where I can specify the IP address of HS3 as I run it, for example:

    HSPI_MeiKu.exe 10.10.10.10

    Many thanks,

    Chris

  • #2
    Yes, run it with the switch -s

    For instance: -s 10.10.10.10

    I'm not sure if it will pull the images down correctly for the statuses, but it should work. Just make sure to put all the DLLs including the 3 homeseer DLLs (Scheduler.dll, HSCF.dll, and HomeSeerAPI.dll).

    And remember the Homeseer DLLs should be updated when you update Homeseer.

    If this doesn't work, let me know and I'll try it, however, I'm about 99% sure it works as I developed it on a separate machine for a while before I got my development license of HomeSeer.
    Thanks,
    Frank

    Comment


    • #3
      Here are the optional command line switches:

      -p, --port (Default: 10400) HomeSeer admin port

      -s, --server (Default: 127.0.0.1) HomeSeer IP address
      Thanks,
      Frank

      Comment


      • #4
        Awesome, thanks! It works.

        I actually found another hack if you are on windows:

        netsh interface portproxy add v4tov4 listenport=10400 listenaddress=127.0.0.1 connectport=10400 connectaddress=<HS3 address>

        This worked too but I will use your -s flag.

        The images are working although I think I spotted a type in the path? The plugin looks for http://images/MeiLKu/status/0.png but the folder I had from the plugin install (on HS3 server) is http://images/MeiKu/status/0.png

        Cheers,

        Chris

        Comment


        • #5
          I'll need to store that little tidbit away. I'm sure it would be useful in a lot of other places
          Thanks,
          Frank

          Comment

          Working...
          X